Стартовая страница

Полезные советы для Windows 7 от Nizaury v.1.49.

Постоянная ссылка, на обновляющиеся версии сборников. Используйте её для скачивания новых версий.
Альтернативная постоянная ссылка (используйте, если у вас не скачивается по предыдущей).
Полезные советы для Windows 7 - это сборник советов, в котором содержится полезная информация для простого решения ошибок и вопросов, возникающих при работе с Windows 7.

Инструкция использования данного справочника

Общий список советов

Перейти к разделу:

Установка

Настройки

Администрирование

Интерфейс

Сети (Интернет и Локальная)

Тонкие настройки

Твики Реестра

Устранение неполадок

Разное

История версий

Оффициальный сайт сборника: http://nizaury.blogspot.com
Гостевая книга на сайте: http://nizaury.blogspot.com/2009/12/blog-post_07.html

E-mail автора: psdw7@delfi.lv


Инструкция использования данного справочника

1) При нажатии на наименование совета в общем списке, вы перейдете на отдельную страницу данного совета.

2) При нажатии на наименование совета в содержании, вы перейдете на отдельную страницу данного совета.

3) При нажатии на наименование раздела в содержании, вы перейдете на отдельную страницу данного раздела.

4) При нажатии на миниобраз изображения, он увеличится.

5) При нажатии на значок [image], а также при нажатии на увеличенное изображение или вне его, оно закроется.

6) Если в совете несколько изображений, вы можете переключиться на следующее нажав на [image] или [image], находящиеся слева или справа на изображении.

7) При нажатии на кнопку "Показать" текст совета откроется на текущей странице.

Пример

Назад на главную.


Главная страница

Полезные советы для Windows 7 от Nizaury v.1.49.

Установка

1. Как добавить новое устройство(драйвер) вручную?

1) Нажимаем Windows + R
2) В открывшемся окне набираем hdwwiz, жмём OK
3) В открывшемся окне, жмем Далее(Next)
4) В следующем окне выбираем Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list), жмём Далее(Next)
5) Выбираем в списке самую верхнюю строчку Показать все устройства(Show all devices), жмём Далее(Next)
6) В следующем окне нажимаем на кнопку Установить с диска(Install From Disk), в нижнем правом углу
7) В открывшемся окне нажимаем кнопку Обзор(Browse) и указываем путь к файлу драйвера (inf-файл), нажимаем Ok, а затем Далее(Next)
8) Подтверждаем желание установить нажатием Далее(Next)

2. Где в 7-ке хранятся скачанные с Winupdate обновления?

C:\Windows\SoftwareDistribution\Download. После установки эту папку можно смело очистить.

3. Как определить неизвестное устройство?

Узнаем VendorID(VEN) или HardwareID(DEV) устройства. В диспетчере устройств нажимаем у неизвестного устройства Свойства. Далее Сведения-Проматываем до ID оборудования.
Теперь идем на http://www.pcidatabase.com/. И вводим одно из найденных значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:
Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные
там тоже это указывается.

4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Здесь

5. Во время инсталяции, после копирования файлов, установщик (сама система) виснет.

Она не висит. Попробуйте выбрать другой монитор в персонализации - параметры дисплея. Это бывает, если у видеокарты два выхода. Такое состояние "зависания" может иметь разное время: от 2-3 минут до 25-30.

6. Как установить с флешки?

Вариант 1

1) Открываем образ Windows программой UltraISO, заходим в меню Самозагрузка - Записать образ Жесткого диска.
2) Вставляем флешку в USB-порт (она должна появиться вверху). Выбираем ее. Выбираем в пункте Метод записи USB-HDD и жмем Записать.
3) Выскакивает предупреждение об уничтожении информации, жмем Да. Ждем, когда завершится запись (от 5 до 20 минут).
4) Заходим в BIOS со вставленной флешкой и ставим загрузку в первую очередь с USB-HDD.
5) Если все сделали правильно, то после рестарта компьютера, если вставлена флешка с записанным образом, загрузка пойдет с нее безусловно, то есть без фразы "Press any key to boot from...".
6) Сама по себе установка мало чем отличается от установки с загрузочного DVD-диска, но есть один момент. Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, нужно снова идти в BIOS и ставить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку. Иначе, возможно, загрузка снова пойдет с флешки.

Вариант 2

Подготовка USB-флеш для будущей загрузки и установки Windows 7:

1) Берете USB-драйв размером не менее 4ГБ, подключаем его к USB-порту.
2) Запустите командную строку CMD.EXE с правами администратора
3) Запустите утилиту управления дисками diskpart, дождаться приглашения DISKPART>
4) Выполняете команду list disk (отображает список всех дисков ПК)
5) Ищете среди них наш диск USB, в нашем примере это Disk 1
6) Выполняете команду select disk # (где # – это номер нашего USB-драйва, полученного в предыдущей команде). Для нашего случая – select disk 1. Данная команда указывает diskpart, что все дальнейшие операции будут проводиться с данным диском.
7) Выполняете команду clean (стирает все данные и разделы на USB диске)
8) Выполняете команду create partition primary (создание нового раздела на диске)
9) Выполняете команду select partition 1 (выбор раздела, как дальнейшего объекта для манипуляций)
10) Выполняете команду active – делаем выбранный раздел активным
11) Выполняете команду format fs=NTFS – форматируем раздел в файловую систему NTFS
12) Выполняете команду assign – активируем процесс подключения устройства, получения букв для созданных разделов (если автостарт опция включена – всплывает окно, как будто вы только что подключили USB-драйв)
13) exit – выходим из diskpart в командную строку.
14) USB-драйв готов

Рисунок 1 из 2

Берем имеющийся у вас дистрибутив Windows 7, допустим, на DVD-диске, установленной в DVD-rom G:
В командной строке (не в diskpart !!! ) выполняем следующие команды:
1) G:
2) cd boot – переходим в каталог boot дистрибутива
3) Выполняете команду bootsect /nt60 I: – где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
4) Копируем на него со стандартного инсталляционного пакета все файлы. Можно использовать как системный Windows Explorer, так и команды xcopy или robocopy
Всё, USB-драйв готов. Загружаем ПК с полученного USB-драйва.

Рисунок 2 из 2

7. Интеграция LIP в дистрибутив Windows 7.

Вариант 1 вручную с помощью WAIK.

Для работы нам потребуются WAIK, GimageX

1) Скачайте и установите Windows® Automated Installation Kit (AIK) for Windows® 7
2) Перезагрузите компьютер.

Русификация установщика install.Wim
1) Создаёте на диске D: папки Lip, Mount и mWim
2) В папку Lip копируете lp_x86.cab и создаёте в ней подпапку uLip
3) При помощи GimageX экспортируете из папки \Sources\install.wim в папку D:\mWim образ Ultimate (индекс 5) как install.wim
4) Выполняете перезагрузку вашего ПК.
5) Монтируете файл D:\mWim\install.wim в папку D:\Mount выполнив в консоли команду:
(команды копируете, и вставляете в консоль по правому клику)
dism /Mount-Wim /WimFile:D:\mWim\install.wim /index:1 /MountDir:D:\Mount
6) Интегрируете LIP
dism /image:D:\Mount\ /Add-Package /PackagePath:D:\Lip\lp_x86.cab
7) Применяем все настройки для русского языка командой:
dism /image:D:\Mount /Set-AllIntl:ru-RU
Примеры запуска команд DISM:
dism /image:D:\Mount /Set-UILang:ru-RU (язык интерфейса системы)
dism /image:D:\Mount /Set-SysLocale:ru-RU (язык системной локали для не Unicode)
dism /image:D:\Mount /Set-UserLocale:ru-RU (денежный формат, формат времени)
dism /image:D:\Mount /Set-InputLocale:0419:00000419 (настройки ввода с клавиатуры)
dism /image:D:\Mount /Set-TimeZone:"Russian Standard Time" (временная зона)
8) Демонтируете образ с сохранением изменений:
dism /Unmount-Wim /MountDir:D:\Mount /commit
Демонтаж без сохранения:
dism /Unmount-Wim /MountDir:D:\Mount /discard
9) Заменяете файл sources\install.wim в дистрибутиве, файлом D:\mWim\install.wim 10) Там же правите текст файла sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
Русификация установщика Boot.Wim
1) Распаковываете lp.cab в папку D:\Lip\uLip
expand D:\Lip\lp_x86.cab -f:* D:\Lip\uLip
2) Очищаете папку D:\Mount
3) При помощи GimageX экспортируем из файла \Sources\boot.wim (индекс 2 !!!) в папку D:\mWim\ как boot.wim.
4) Монтируете файл boot.wim в папку D:\Mount
dism /Mount-Wim /WimFile:D:\mWim\boot.wim /index:1 /MountDir:D:\Mount
5) Добавляете в boot.wim русский язык:
xcopy D:\Lip\uLip\setup\* D:\Mount\ /cheryki
6) Добавляете в boot.wim файлы лицензий:
xcopy D:\Lip\uLip\sources\license\* D:\Mount\sources\license\ /cheryki
7) Правите текст файла D:\Mount\sources\lang.ini так же, как описано выше. 8) Демонтируете с сохранением файл boot.wim, папку uLip можно удалить.
dism /Unmount-Wim /MountDir:D:\Mount /commit
9) Заменяете файл sources\boot.wim в дистрибутиве, файлом D:\mWim\boot.wim

Вариант 2 с помощью интегратора

1) Скачайте Интегратор обновлений и языковых пакетов Windows 7
2) Запустите его
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дожидаетесь успешного выполнения и видите результат.

8. Установка Language Interface Pack (LIP).

1. Заходите в Control Panel >> раздел Clock, Language and Region.
2. В разделе Regional and Language Options >> Keyboards and Languages >> нажимаете Install or uninstall display languages.
3. В появившемся окне нажимаете Install Languages и указываете путь к папке с lp.cab
Можно просто набрать lpksetup в командной строке или в поле Выполнить и сразу переходите к третьему пункту.

9. Как не вводить ключ при инсталляции Windows?

Вариант 1

по материалам technet.microsoft.com:
EI.cfg is a Windows Setup-specific configuration file used to determine what edition and license will be used during installation. This file replaces PID.txt and is located on the product media under the \sources folder.
Добавьте в файл EI.cfg находящийся в папке \sources строку:
[PID]
Value="xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"

Вариант 2

Создаете файл Autounattend.xml со следующим текстом и кладете в \sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.

<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<UserData>
<AcceptEula>true</AcceptEula>
<FullName>MyName</FullName>
<Organization>Microsoft</Organization>
<ProductKey>
<Key>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
</UserData>
</component>
</settings>
</unattend>

10. Создание загрузочного образа ISO Windows 7 из VHD образа + интеграция LIP.

Для работы нам потребуются WAIK, GimageX (русская старая) или GimageX (английская новая), WinImage и ERD Commander для x86 или x64

Вариант 1

1) Скачайте и установите Windows® Automated Installation Kit (AIK) for Windows® 7
2) Перезагрузите компьютер.
3) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
4) Запускаете утилиту WinImage, открываете в ней извлеченный VHD-образ. В открывшемся диалоге щелкаем ОК. Выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем папку VHD. Чуть ниже выбираем Extract with pathname. Ждем завершения процесса распаковки. Если появится ошибка, просто нажимаем продолжить.

Рисунок 1 из 5

5) Распакуйте образ дистрибутива(ваш ISO) в папку C:\DVD
6) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
7) Распакуйте lp.cab в папку C:\Lip\uLip
expand C:\Lip\lp.cab -f:* C:\Lip\uLip
8) При помощи GimageX узнаете индекс Ultimate

Рисунок 2 из 5

9) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

Рисунок 3 из 5

10) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

Рисунок 4 из 5

11) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

Рисунок 5 из 5

12) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:
dism /Mount-Wim /WimFile:C:\mWim\install.wim /index:1 /MountDir:C:\Mount
14) Интегрируете LIP в install.wim
dism /image:C:\Mount\ /Add-Package /PackagePath:C:\Lip\lp.cab /ScratchDir:C:\Temp
15) Применяете все настройки для русского языка командой:
dism /image:C:\Mount /Set-AllIntl:ru-RU
16) Копируете через Micosoft Diagnostics and Recovery Toolset -> Explorer все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr 17) Демонтируете install.wim с сохранением изменений из C:\Mount:
dism /Unmount-Wim /MountDir:C:\Mount /commit
18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount
dism /Mount-Wim /WimFile:C:\mWim\boot.wim /index:1 /MountDir:C:\Mount
19) Добавляете в boot.wim русский язык:
xcopy C:\Lip\uLip\setup\* C:\Mount\ /cheryki
20) Добавляете в boot.wim файлы лицензий:
xcopy C:\Lip\uLip\sources\license\* C:\Mount\sources\license\ /cheryki
21) Правите текст файла (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\Mount\sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
22) Демонтируете boot.wim с сохранением изменений из C:\Mount:
dism /Unmount-Wim /MountDir:C:\Mount /commit
23) Правите текст файла (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
24) Заменяете файл (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
25) Заменяете файл (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
26) Перезагружаетесь в Windows
27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
29) Сохраняете в другое место или под другим именем.

Вариант 2

Создание английской Windows 7 (быстро и легко)

1) Идёте в меню Пуск, пишите diskmgmt.msc и нажимаете Enter
2) В верхнем меню нажимаете Действие -> Присоединить виртуальный жесткий диск.
3) Указываете его местонахождение, жмете ОК

Рисунок 1 из 2

4) Выбираете нужную вам букву для данного диска
5) Установите Windows AIK
6) Запустите программу GImageX и укажите в параметрах как на рисунке:

Source: - путь к виртуальному диску
Destination - путь куда будет сохранен готовый install.wim файл
Name - Имя образа (Windows 7 Ultimate)
Description - Описание образа (Windows 7 Ultimate)
Compression - Сжатие полученного install.wim файла (Maximum)

Рисунок 2 из 2

7) Открываете с помощью UltraISO образ дистрибутива Windows 7
8) Удаляете в папке \Sources файл install.wim
9) Добавляете созданный вами новый install.wim вместо старого.
10) Сохраняете образ под новым именем.
11) Записываете образ на флэшку или DVD.

11. Как установить Windows 7 из VHD-образа?

Вариант 1

Первое, что потребуется - это сам образ, извлеченный из RAR-архива. Второе - необходимо подготовить логический диск. Желательно выделить под установку чистый диск с размером 15-25Гб. И, наконец, потребуется утилита WinImage.

1) Запускаем утилиту WinImage, открываем в ней извлеченный VHD-образ. В открывшемся диалоге щелкаем ОК. Выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем предварительно подготовленный диск. Чуть ниже выбираем Extract with pathname. Ждем завершения процесса распаковки.

Рисунок 1 из 2

2) По завершении распаковки скачиваем утилиту EasyBCD. В окне приложения нажимаем Add/Remove Entries, затем внизу в поле Add entries выбираем имя для нашей новой ОС (к примеру, Windows 7 build XXXX), указываем тип (Windows Vista/Longhorn) и выбираем тот диск, в который мы извлекли содержимое образа. Щелкаем Add entry, а затем вверху щелкаем Save. В списке ОС теперь должно быть два пункта. Затем идем в раздел Change Settings и выбираем в качестве ОС, загружаемой по умолчанию, выбираем Windows 7 build XXXX. Нажимаем Save settings и перезагружаемся.

Рисунок 2 из 2

3) Наслаждаемся сборкой Windows 7 build XXXX с разлоченными функциями.

Вариант 2 как основная система.

1) Создаем папку VHD на любом разделе диска. Образ VHD, извлеченный из RAR-архива, открываем утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем папку VHD. Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
3) Выбираем Micosoft Diagnostics and Recovery Toolset -> Explorer и удаляем все файлы с диска C:\ (Диск с уже установленной Windows 7).Процесс может быть длительным, ждите.
4) Переносим все файлы из папки VHD на диск C:/. Папка VHD-> выделяем все файлы-> щелкаем правой кнопкой-> параметр move to-> выбираем диск С:\
5) Удаляем папку VHD.
6) Перезагружаемся снова в ERD. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
7) Радуемся установленной Windows 7.

Вариант 3 как вторая система

1) Образ VHD, извлеченный из RAR-архива, открываем утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем любой логический диск (необязательно форматированный, у меня например там фильмы лежат). Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
3) После выбора языка раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
4) После перезагрузки нам становиться доступен выбор из двух ОС. Нас интерисует вторая Windows 7 Ultimate(recovered). Выбираем её и ждем пока закончится настройка системы. В процессе, компьютер будет два раза перезагружен, незабываем после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered). Всё, VHD установлен.
5) Если загружаетесь через Windows 7 Ultimate(recovered), то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все).Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить -> compmgmt.msc).Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкаем правой кнопкой на диске, выбираем Change Drive Letter and Paths, нажимаем Add, выбираем любую букву для диска, ОК, диск доступен.

12. Повышение оценки производительности жесткого диска.
Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

13. Автоматическая установка OEM-информации.

Представляем вашему вниманию небольшой скрипт, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создаете файл Autounattend.xml со следующим текстом и кладете в \sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
Не забудьте заменить серийный ключ (product key) на ваш и назовите файл autounattend.xml.
<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0409:00000409</InputLocale>
<SystemLocale>en-US</SystemLocale>
<UILanguage>en-US</UILanguage>
<UILanguageFallback>en-US</UILanguageFallback>
<UserLocale>en-US</UserLocale>
</component>
<component name=”Microsoft-Windows-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<DiskConfiguration>
<Disk wcm:action=”add”>
<CreatePartitions>
<CreatePartition wcm:action=”add”>
<Extend>false</Extend>
<Type>Primary</Type>
<Order>1</Order>
<Size>40000</Size>
</CreatePartition>
</CreatePartitions>
<ModifyPartitions>
<ModifyPartition wcm:action=”add”>
<Order>1</Order>
<PartitionID>1</PartitionID>
<Format>NTFS</Format>
<Letter>C</Letter>
<Extend>true</Extend>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass=”oobeSystem”>
<component name=”Microsoft-Windows-Shell-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<OEMInformation>
<Logo>E:\oemlogo.bmp</Logo>
<Manufacturer>Fabrikam</Manufacturer>
<Model>Superfast1000</Model>
<SupportHours>Anytime, day or night</SupportHours>
<SupportPhone>1-800-SUPPORT</SupportPhone>
<SupportURL>www.fabrikam.com</SupportURL>
</OEMInformation>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>1</ProtectYourPC>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
<AutoLogon>
<Password>
<Value>Password</Value>
<PlainText>true</PlainText>
</Password>
<Username>Administrator</Username>
<Enabled>true</Enabled>
<LogonCount>5</LogonCount>
</AutoLogon>
<UserAccounts>
<AdministratorPassword>
<Value>Password</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>
</component>
</settings>
<cpi:offlineImage cpi:source=”wim:c:/documents%20and%20settings/vmux/desktop/sourceos/install.wim#Windows 7 ULTIMATE” xmlns:cpi=”urn:schemas-microsoft-com:cpi” />
</unattend>

Внимание!!!
Не используйте данный метод, если имеете важную информацию на жестком диске или же сделайте резервную копию системы. Дело в том, что файл ответов в данном совете стирает все разделы и логические диски при установке.
Если же вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам 9 и 14 данного раздела.

14. Автоматическая установка OEM-Logo.

Создаете файл Autounattend.xml со следующим текстом и кладете в \sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass=”windowsPE”>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OEMInformation>
<HelpCustomized>false</HelpCustomized>
<Manufacturer>Hewlett-Packard</Manufacturer>
<Model>Compaq Presario SR1610IL</Model>
<Logo>C:\Windows\Sytem32\oemlogo.bmp</Logo>
<SupportHours>9 AM to 9 PM (Mon-Sat)</SupportHours>
<SupportPhone>1-600-114772 (Toll free), 0124-2346992 (Toll Number)</SupportPhone>
<SupportURL>http://www.hp.com/in/support</SupportURL>
</OEMInformation>
</component>
</settings>
</unattend>
oemlogo.bmp
положите ваше лого в папку " \Sources\$OEM$\$$\System32\oemlogo.bmp"

15. Как установить LocalPack-RU?

Нужно в командной строке от имени Администратора выполнить команду: DISM /Online /Add-Package /PackagePath:<полный_путь_к_локал-паку>.CAB
Если не сработает - значит, нужно проделать почти то же самое, но загрузившись с установочного носителя.
Тогда /Online нужно будет заменить на /image:<буква_диска_с_установленной_системой>:.
Этим способом, кстати, MVE, можно установить лангпак на любую редакцию Windows 7
После установки нужно зайти в C:\Windows\Globalization\MCT\MCT-...\Theme

16. Автономная установка обновлений Windows.

1. Создаем батник (обычный текстовый документ, у которого потом меняем расширение на .bat) с именем, например Update, и с текстом:
@Echo Off
Title Installing Windows7 Updates
For %%F In (MSU\*.msu) Do Call :msin %%F
For %%A In (CAB\*.cab) Do Call :kbin %%A
Exit
:msin
Start /Wait %1 /quiet /norestart
:kbin
Start /Wait pkgmgr /ip /m:%1 /quiet /norestart
GoTo :EOF
Exit

2. Рядом с батником cоздаем папки CAB и MSU.
3. Кладём обновления .msu в папку MSU и .cab в папку CAB.
4. Запускаем Update.bat и ждем когда закроется окно командной строки. Готовый Update.bat

17. Как добавить подпись к драйверам?

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер нне устанавливается, ибо нет подписи Microsoft.На помощь пришли энтузиасты со своей программой Driver Signature Enforcement Overrider (DSEO). Она позволяет создавать свои собственные непроверенные свидетельства.

Таким образом, суть метода относительно проста. Требуется лишь включить тестовый режим в операционной системе и для всех драйверов устройств, не имеющих цифровой подписи, при помощи программы Driver Signature Enforcement Overrider получить свидетельства. Радует то, что при этом полностью отсутствуют риски привести операционную систему к нерабочему состоянию. Ведь от нас не требуется изменение загрузчика или других ее системных файлов. Используется штатный метод, специально предусмотренный Microsoft. Иногда на рабочем столе возле часов может появиться маленькая надпись, сообщающая версию билда операционной системы. (Надпись можно убрать используя рекомендации из совета 6 в "Тонких настройках")
Программа Driver Signature Enforcement Overrider работает как с 32-битными, так и с 64-битными операционными системами. Перед использованием необходимо обязательно отключить контроль учетных записей пользователей (UAC). Инсталляция программы не требуется, просто скачайте ее и запустите. Интерфейс предельно прост, и вся работа осуществляется в виде мастера.
Порядок действий:
1) Включите тестовый режим, установив переключатель в положение "Enable Test Mode". Кстати, сразу отмечу, что здесь же предусмотрено обратное действие "Disable Test Mode", отключающее тестовый режим.
2) Теперь нужно добавить подписи для непроверенных системных файлов. Для этого выберите "Sign a System File" и введите имя файла, включая полный путь. Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
3) Перезагрузите компьютер. Вот собственно и все. После перезапуска компьютера драйверы будут работать.

Скачать:
С оффициального сайта
С зеркала

18. Windows 7 Enterprice = Windows 7 Ultimate + активация без подмены загрузчика.
Для желающих установить версию Windows 7 Ultimate, но не считающих нужным использовать активаторы из-за возможности возникновения проблем с восстановлением загрузчика после применения активаторов, есть замечательное решение.

Активация через KMS-Server(автоскрипт от alexfire74):

1) Скачиваете архив Microsoft.Windows.7.Enterprice.RTM.x86-x64.eng-rus-wzt.zip с 4 торрентами для закачки Windows 7 Enterprice RTM Volume OEM.
2) Выбираете нужную вам версию и скачиваете её.
3) Устанавливаете её. Далее уже действуем в установленном Windows.
4) Нажимаете левой кнопкой мыши на часы на панели задач
5) Нажимаете Изменение настроек даты и времени
6) Запоминаете вашу разницу от Гринвича (Например: (UTC+02:00) или (UTC+03:00))
7) Скачайте Volume license - Activate.zip
8) Разархивируйте и запустите скрипт Volume license - Activate.cmd (требуется подключение к интернет не более 5 минут)
9) Выбираете версию Windows (в нашем случае Windows Enterprice)
10) Выбираете ваш UTC, в соответствии с пунктом 6 данного мануала
Если у вас UTC отличается от времени kms серверов, на время активации поставьте принудительно одно из предлагаеммых значений UTC
11) Дождитесь завершения активации, надпись об активации появляется через несколько минут после окончания работы скрипта.

19. Как сделать чтобы Windows при установке активировался автоматически?

Открываете образ с Windows 7, например программой UltraIso.
В папку sources копируете папку $OEM$, сохраняете образ и всё, при установке винда сама активируется.
Ссылка на готовую папку $OEM$

Настройки

1. Чтобы сохранялись настройки программ (сайдбара, расположение значков на панели и т.д.).

Hужно установить пароль на учетную запись администратора и работать из под нее.

2. Отображение (скрытие) значков в области уведомлений.

Отобразить значок в области уведомлений можно гораздо проще без использования кнопки Настроить: просто перетащите нужный значок из скрытой области в область уведомлений. Чтобы скрыть значок, перетащите его в скрытую область.

3. Как изменить параметры загрузки, где в Windows 7 файл boot.ini?

Начиная с Windows Vista такого файла больше нет, однако вы можете изменить все необходимые вам параметры
Панель управления > Администрирование > Конфигурация системы > Загрузка

4. Увеличение скорости загрузки ОС для многоядерных процессоров.

Измените значение здесь.
Панель управления > Администрирование > Конфигурация системы > Загрузка > Дополнительные параметры > Число процессоров > 2(или 4)
(По умолчанию 1).

5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны. К примеру, чтобы изменить временную зону на время по Гринвичу, нужно использовать следующую команду:
tzutil /s “gmt standard time”
» “tzutil /g” покажет текущие установки временной зоны;
» “tzutil /l” выводит список всех возможных временных зон;
» “tzutil /?” выводит справку по работе утилиты.

6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны
Пуск => Все программы=> Стандартные => "Ножницы" => Правый клик мыши=> Свойства
В Свойствах, в поле Быстрый вызов пытаемся набрать любую комбинацию клавиш. Заметим что нам сразу выдаются первые две клавишы Ctrl+Alt+, выбор третьей клавишы за вами, как вам удобнее. Например, Ctrl+Alt+S.

7. Отключение (включение) неиспользуемых компонентов Windows.
В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева "Включение или отключение компонентов Windows"
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но вами не используются

8. Как отменить (изменить) ассоциирование типов файлов с определенными программами?

Если вы выбрали неправильную программу в диалоговом окне "Открыть с помощью" и установили параметр "Использовать выбранную программу для всех файлов такого типа". А также если программа удалилась некорректно, оставив в системе ассоциации на себя с поддерживаемыми ею типами файлов. Есть несколько способов это исправить.

Способ 1: Попробуйте ассоциировать нужные файлы с нужными программами используя все тот же диалог "Открыть с помощью"
Способ 2: Панель управления\Все элементы панели управления\Программы по умолчанию\Задать сопоставления "Изменить программу"
Способ 3: Искать в реестре в ветке [HKEY_CLASSES_ROOT]
Способ 4: Используйте утилиту Unassociate File Types, которая позволяет как убрать ассоциацию, так и удалить тип файла из реестра.

9. Как отключить всплывающие подсказки?

Отключить всплывающие подсказки можно используя редактор групповой политики.
Нажмите Пуск, в поле Начать поиск напишите gpedit.msc и нажмите ОК.
Перейдите в раздел Конфигурация пользователя - Административные шаблоны - Меню Пуск и Панель задач.
Откройте параметр "Удалить всплывающие подсказки для элементов главного меню", выберите пункт Включен и нажмите ОК

10. Изменение функции кнопки питания на корпусе вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии «Завершение работы». Если вы перезагружаете компьютер по несколько раз в день, вам наверное было бы удобнее переключить кнопку выключения в состояние «Перезагрузка». Для этого выполняем правый клик по кнопке Пуск, выбираем пункт меню Свойства и переключаем “Действие кнопки питания” в состояние “Перезагрузка”. Также вы можете выбрать функции “Блокировка”, “Смена пользователя” и “Завершение сеанса”.

11. Как быстро перейти к часто используемой папке?

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки проводника.

12. Как изменить строку в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР"?

Запустите cmd.exe от имени администратора, и пишете следующую строчку:
bcdedit /set {ntldr} description "Microsoft Windows XP Professional SP3"
bcdedit /set {current} description "Microsoft Windows 7 Ultimate x64"

Администрирование

1. Активировал учетную запись администратора, но некоторые папки\файлы все равно не удаляются.

Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду
net user Администратор /active:yes
В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:
net user Administrator /active:yes
Команду необходимо выполнять в командной строке с повышенными правами пользователя. Для этого нажмите кнопку Пуск, выберите пункт Стандартные, щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора.

2. Как разрешить запуск "Диспетчера задач"?

Запустите редактор системных политик: Пуск > Выполнить > gpedit.msc.
Слева в дереве политик выберите Конфигурация пользователя > Административные шаблоны > Система > Возможности Ctrl+Alt+Del.
В правом окне двойным щелчком откройте свойства политики Удалить диспетчер задач, выберите Отключен и нажмите ОК.
Изменения вступят в действие после перезагрузки.

3. Как добавить свою иконку в список рисунков учетных записей?

По умолчанию рисунки учетных записей располагаются в следующей папке:
C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

4. Автоматический вход в систему(авто-ввод пароля).

Если вы хотите ускорить процесс загрузки Windows 7, то вы можете настроить автоматический вход в систему. Эта возможность создана для тех ситуаций, когда компьютером пользуется один человек. Настроив автоматический вход, вам не нужно будет вводить пароль каждый раз, когда загружается ваша операционная система.
Чтобы настроить автоматический вход в Windows 7, сделайте следующее:

1. Нажмите на клавиатуре Win+R (или пункт Run в меню Start).
2. В появившемся окне введите “control userpasswords2” (без кавычек) и нажмите Ввод.
3. В окне User Accounts на закладке Users выделите свою учетную запись и уберите галочку с “Users must enter a user name and password to use this computer”.
4. Нажмите Apply.
5. В открывшемся окне Automatically Log On будут три поля - User name, Password и Confirm Password. Введите свой пароль в поле Password и еще раз - в поле Confirm Password.

Всё. Со следующей перезагрузки системы вам больше не нужно будет вводить свой пароль. Вход в Windows будет происходить автоматически.
(Возможен побочный эффект: после перезагрузки панель "Quick Launch" не сохраняется - после рестарта её нет.)

5. Как ограничить пользователей в наборе программ, которые они могут запускать?

Контроль за приложениями сводится к настройке правил. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные определенным издателем (например, Microsoft). Запустите GPEDIT.MSC и перейдите к функции AppLocker() через Computer Configuration > Windows Settings > Security Settings > Application Control Policies или Конфигурация компьютера > Конфигурация Windows > Параметры безопасности > Политики управления приложениями, чтобы посмотреть, как это работает.

6. Как быстро запустить программу с правами администратора?

Удерживайте Ctrl+Shift и нажмите на иконку приложения (у вашей учетной записи, конечно, должны быть соответствующие права).

7. Как убрать значки запрета доступа на папках?

Для этого надо в свойствах назначения прав папкам и файлам, добавить пользователя Администратор, и дать ему все разрешения, после чего значек с папки или файла будет убран.

8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer или Sysinternals Autoruns, и вовсе лучше всегда запускать с повышенными привилегиями.
Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl+Shift+Enter.
3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

1) Запускаете планировщик заданий (Пуск ---> Все программы ---> Стандартные ---> Служебные ---> Планировщик заданий)
2) Нажимаете "Создать задачу"
3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
5) Указываете путь к нужному приложению и нажимаете "Открыть"
6) Нажимаете "ОК", затем снова "ОК"
7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" ---> "Ярлык")
8) В поле Расположение объекта введите:
schtasks /run /tn mytask_admin
где mytask_admin - имя созданной нами задачи. Если в имеми содержаться робелы, обязательно укажите его в кавычках.
9) Введите имя ярлыка и нажмите Готово

Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

Скачать можно здесь или здесь

Интерфейс

1. Как открыть диспетчер задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту?

Вариант 1

Используйте ctrl+shift+esc.

Вариант 2

Правой кнопкой на панели задач --> Start Task Manager

2. Использование средней кнопкой мыши при работе с панелью задач.

Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

3. Как уменьшить размер иконки на рабочем столе ?

1) Правый клик на рабочем столе - Вид - Мелкие значки;
2) Нажимаем Сtrl и крутим колесико.

4. Управление заготовками положений размеров окон.

Чтобы легко управлять заготовками положений размеров окон (любых) просто кликните на активное окно и жмите:(win+влево,вниз,вправо,вверх).

5. Дополнительные темы и обои для Windows находятся в скрытой папке - C:\Windows\Globalization\MCT

Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
Для этого, запустите диалоговое окно "Выполнить" (Win + R) и наберите в нем:
C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

6. Как перезапустить рабочий стол?

Откройте Task Manager - вкладка Applications - нажимаете кнопку New task - далее кнопку Browse - переходите в папку Windows и выбираете explorer.exe, затем нажимаете ОК (это же действие можно выполнить через ярлык).

7. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

1) Щелкаем правой кнопкой на Компьютер (например в Пуске) и выбираем Управление
2) В левом окне выбираем Управление дисками
3) Посередине вверху смотрим, какие из томов не имеют букву. Среди них должен быть раздел размером 200 МБ. Его НЕ трогать!!!
4) Присваиваем букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкаем на нем правой кнопкой и в контекстном меню выбираем Изменить букву диска или путь к диску. Жмем Добавить. Выбираем букву. Жмем OK.
5) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
Также должна стоять галочка в Панель управления-Параметры папок-Вид "Отображать буквы дисков"

8. Включение и отключение Области переходов.

Область переходов – это специальная панель (дерево папок), которая находится слева в каждой папке.
Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

Включить или отключить Область переходов можно так:

1) Нажмите вверху слева Упорядочить->Представление
2) Поставьте или уберите галочку в пункте Область переходов

9. Изменение ширины меню Пуск.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Resources\Themes\Aero\ru-RU\aero.msstyles.mui и изменяете значения в строковой таблице в строках с 113 по 121 включительно, делаете их такими же, как в C:\Windows\Resources\Themes\Aero\en-US\aero.msstyles.mui
113, "0, 0, 406, 440"
114, "0, 0, 145, 75"
115, "0, 0, 64, 64"
116, "0, 0, 145, 44"
117, "0, 0, 261, 30"
118, "0, 0, 145, 332"
119, "0, 0, 261, 383"
120, "0, 0, 261, 37"
121, "0, 0, 400, 50"

10. Изменение прозрачности окон в Windows 7.

До | После
Рисунок 1 из 2 | Рисунок 2 из 2

Выключить матовый-стеклянный (Blur эффект) и включить прозрачный эффект можно при помощи небольшого скрипта: HideBlur Tool for Windows 7

Инструкция:

1. Распакуйте и запустите файл "Patch Blur x86.bat". Если у вас x64 битная версия, запустите файл "Patch Blur x64.bat".
2. Это займет немного времени и вы увидите окно без эффекта матовости.
3. Если захотите вернуть эффект матовости, запустите файл "Enable Blur.bat". А если снова захотите убрать матовость запустите файл "Disable Blur.bat".
4. Если вы решите восстановить системные файлы запустите файл "Unpatch Blur.bat".
Изменения становятся видимыми после перезагрузки.

Сайт автора скрипта

11. Открытие коммандной строки из конкретной папки.

Одной из самых популярных утилит в наборе Windows XP Power Toys был пункт контекстного меню проводника «Открыть командную строку отсюда» (“Open Command Prompt Here”).
В Windows 7 этот пункт есть в контекстном меню, для его использования при вызове меню нужно удерживать клавишу Shift, вследствие чего в меню появляется пункт "Открыть окно команд".

12. Как улучшить качество передачи цветов монитором?

Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова мастера кликните Start, введите DCCW и нажмите <Enter>.

13. Включение Flip3D — отображение окон под углом.

1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

14. Как расширить функциональность часов в трее или изменить их вид?

Скачайте программу Stoic Joker's T-Clock x32/x64. Данная программа позволяет вам расширить функциональность часов в трее или изменить внешний вид часов в трее. Вы сможете добавить секунды к часам, изменить внешний вид часов, даты или добавить созданные вами значки для запуска конкретных приложений в трей.

15. Быстрый переход к папкам и программам, используя переменные окружения (Например: %SystemRoot% - C:\Windows).

Чтобы узнать какие из них присутствуют в вашей системе запустите cmd.exe и в нем команду set. Получите полный список переменных окружения вашей Windows.

%AllUsersProfile% - C:\ProgramData
%AppData% - C:\Users\%UserName%\AppData\Roaming
%CommonFavorites% - C:\Documents and Settings\All Users\Избранное
%CommonFiles% - C:\Program Files\Common Files
%CommonProgramFiles% - C:\Program Files\Common Files
%CommonProgramFiles(x86)% - C:\Program Files (x86)\Common Files
%ComSpec% - Запустит cmd.exe из папки, в которой будет употреблен
%HomePath% - C:\Users\Administrator
%LOCALAPPDATA% - C:\Users\%UserName%\AppData\Local
%ProgramData% - C:\ProgramData
%ProgramFiles% - C:\Program Files
%ProgramFiles(x86)% - C:\Program Files (x86)
%PSModulePath% - C:\Windows\System32\WindowsPowerShell\v1.0\Modules
%SystemDir% - C:\Windows\System32
%SystemDrive% - C:\
%SystemRoot% - C:\Windows
%Temp% - C:\Documents and Settings\%UserName%\Local Settings\Temp; C:\Users\%UserName%\AppData\Local\Temp
%Tmp% - C:\Users\%UserName%\AppData\Local\Temp
%UserProfile% - C:\Users\%UserName%
%windir% - C:\Windows

Если вы решите создать собственную переменную типа:
%MyFolder%=C:\MyFolder

1) Пройдите:
Компьютер -> Свойства -> Дополнительные параметры системы ->Дополнительно -> Переменные среды
2) Нажмите Создать...
3) Укажите Имя перменной и Значение переменной
4) Нажмите на каждое Ок
5) Перезагрузите компьютер (иначе она не будет работать)

И в качестве дополнения.

В Windows 7 есть возможность быстрого перехода в системные папки и оснастки Панели управления, используя команду shell. Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет открыто окно проводника в папке C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

Список доступных комманд
shell:cookies | shell:ChangeRemoveProgramsFolder | shell:CommonDownloads
shell:nethood | shell:Common Administrative Tools | shell:CommonMusic
shell:PrintersFolder | shell:Common AppData | shell:CommonPictures
shell:System | shell:Common Desktop | shell:CommonVideo
shell:AddNewProgramsFolder | shell:ConflictFolder | shell:ConnectionsFolder
shell:Administrative Tools | shell:Common Documents | shell:Contacts
shell:AppData | shell:Common Programs | shell:ControlPanelFolder
shell:AppUpdatesFolder | shell:Common Start Menu | shell:CredentialManager
shell:Cache | shell:Common Startup | shell:CryptoKeys
shell:CD Burning | shell:Common Templates | shell:CSCFolder
shell:Default Gadgets | shell:Desktop | shell:Downloads
shell:DpapiKeys | shell:Favorites | shell:Fonts
shell:Gadgets | shell:Games | shell:GameTasks
shell:History | shell:InternetFolder | shell:Links
shell:Local AppData | shell:LocalAppDataLow | shell:LocalizedResourcesDir
shell:MAPIFolder | shell:My Music | shell:My Pictures
shell:My Video | shell:MyComputerFolder | shell:NetHood
shell:NetworkPlacesFolder | shell:OEM Links | shell:Original Images
shell:Personal | shell:PhotoAlbums | shell:Playlists
shell:PrintersFolder | shell:PrintHood | shell:Profile
shell:ProgramFiles | shell:ProgramFilesCommon | shell:ProgramFilesCommonX86
shell:ProgramFilesX86 | shell:Programs | shell:Public
shell:PublicGameTasks | shell:Quick Launch | shell:Recent
shell:RecycleBinFolder | shell:ResourceDir | shell:SampleMusic
shell:SamplePictures | shell:SamplePlaylists | shell:SampleVideos
shell:SavedGames | shell:Searches | shell:SendTo
shell:Start Menu | shell:Startup | shell:SyncCenterFolder
shell:SyncResultsFolder | shell:SyncSetupFolder | shell:SystemCertificates
shell:SystemX86 | shell:Templates | shell:TreePropertiesFolder
shell:UserProfiles | shell:UsersFilesFolder | shell:Windows

16. Использование флажков для выделения (выбора) файлов и папок.

В Windows есть удобная возможность помечать для выделения фалы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
Откройте Проводник и нажмите один раз клавишу Alt - таким образом мы инициализируем отображение стандартного меню вверху окна проводника, которое срыто по умолчанию.
Запустите Пуск\Панель Управления\Параметры Папок и перейдите на вкладку Вид
Отметьте параметр "Использовать флажки для выбора элементов" и нажмите ОК
Теперь слева возле каждого файла и папки появилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

17. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок. Исправить это пожно с помощью бесплатной программы 7Stacks.

Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д. Для работы с программой надо создать папку и сложить туда ярлыки приложений, нужных нам в создаваемом меню. Потом запускаем 7Stacks, выбираем эту папку, настраиваем оформление и создаем ярлык на рабочем столе. Перетаскиваем его в панель задач. Вот и все.

18. Добавление дополнительных операций к окнам.
К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет данная программа.

Добавляет дополнительные функции для окон:
  • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
  • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
  • cвернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
  • и многие другие.
Скачать программу

Сети (Интернет и Локальная)

1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

Установите, как минимум, пониженый уровень UAC.

2. У сетевого адаптера Marvell Yukon сеть отключается через каждые 5 минут.

Отменить в настройках Marvell Yukon "Разрешить этому устройству откл. для экономии энергии".

3. Где можно объединить и удалить сети?

Нажмите на скамейку.

4. Как сделать так, чтобы интернет включался при запуске Windows в "невидимом режиме"?

Control Panel\Network and Internet\Сетевые подключения\свойства ADSL. Во вкладке параметры сними галочки: отображать ход подключения, запрашивать имя и пароль. Ярлык ADSL поместите в папку автозагрузки.

5. Как сделать, чтобы VPN подключение интернет происходило автоматически при запуске Windows?

Вариант 1

Также можно добавить задачу в Планировщик заданий.
1) Откройте планировщик задний из меню Пуск - Администрирование - Планировщик заданий или выполнив команду taskschd.msc из меню Пуск - Поиск.
2) Нажмите создать задачу

Вкладка Имя - Имя подключения
Размещение оставляем как есть.

Вкладка Триггеры-Создать-Начать задачу: При входе в систему

Вкладка Действия-Создать
Действие:Запуск программы
Программа или сценарий: rasdial "имя подключения" пользователь пароль

Вкладка Параметры-Создать
Поставить галочки:
Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.
Убрать галочку:
Останавливать задачу выполняемую дольше

Вариант 2

Наличие скриптов в одной папке connect.bat обязательно.
1) По ссылке ниже берете скрипт (bat-файл)
2) Настраиваете его под себя (имя соединения, логин,пароль)
3) Сохраняете(выкладываете) исправленный файл на рабочий стол, называете его "connect.bat"
connect1.zip
4) Затем берете архив со скриптом скрытого запуска отсюда
hs_exec.zip
hide_programm.zip
5) Извлекаем файлы из архива и кладем в ту же самую папку где лежит файл "connect.bat" запускаем либо "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd.
6) Для автоматической загрузки добавляем в Автозагрузка ярлык (не сам файл скрипта) для "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd

Вариант 3

Создайте маленький bat-файл(типа Connect.bat) следующего содержания, положите его на рабочий стол и запускайте через него при случайном разрыве (имя подключения должно быть на английском иначе может быть ошибка 623):
@echo off

set conn="Golden Telecom"
:: название вашего подключения к интернету

set login="loginname@golden.ru"
:: ваш логин подключения к интернету

set pass="12345678"
:: ваш пароль подключения к интернету

set pause=10
:: пауза в секундах между проверкой соединения, если соединение разорвалось произойдет подключение

rasdial %conn% %login% %pass%

exit

6. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

Переименуйте имя соединения на английский язык и всё должно заработать.

7. Как просмотреть исходный код любой страницы в интернете.

Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

В Firefox

Установите расширение Web Developer.
Затем в меню Web Developer -> Код -> Сгенерированный код.
Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл -> Сохранить страницу как -> page.htm

В Internet Explorer

Меню Сервис -> Средства разработчика
Можете нажать на стрелочку и выбрать нужный элемент на странице и увидите его код или нажать на значок дискетки и сохранить исходный код в текстовый файл, а затем скопировать из него в html.

8. Как сменить поиск по умолчанию в Firefox?

Бывает, что программы без вашего спроса меняют в Firefox поисковик по умолчанию на свой. Чтобы его заменить сделайте следующее:

1) Пишете в адресной строке Firefox такой адрес: "about:config", без кавычек
2) Подтверждаете, что будете осторожны, получаете доступ к многочисленным настройкам Firefox и находите среди них параметр keyword.url
3) Меняете его значение (без кавычек) на:

"http://www.google.com/search?&q=" - Google.Com
"http://yandex.ru/yandsearch?text=" - Yandex.Ru
"http://www.bing.com/search?q=" - Bing.Com

Тонкие настройки

1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново.
Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

Отключаем ее:
1. Создайте пустой текстовый файл,
2. Скопируйте в него powercfg -h off,
3. При сохранении изменить расширение "TXT" на "CMD",
4. Запустите его как обычную программу,
5. Перезагрузка.

Также Вы можете запустить командную строку с правами администратора (Нажать Win+R, ввести Cmd и нажать Ok) и выполнить в ней данную комманду:
powercfg /h off

2. Как скрыть значок "Центр действий" в трее возле часов?

1) Пройдите Пуск\Панель управления\Значки области уведомлений
2) Выберите значки которые хотите скрыть и нажмите Ok

3. Как убрать текст под значком ярлыка или файла?

1) Щелкните правой кнопкой мыши на иконке.
2) Кликните Переименовать.
3) Удерживая клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5 и 5 (Alt+255).
Данная комбинация позволяет добавить невидимый символ в название ярлыка или файла.
Если вы захотите переименовать несколько ярлыков, то, когда вы будете переименовывать следующий, вам потребуется нажать Alt и ввести 255 дважды. Так для третьего значка вам потребуется ввести ALT+255, ALT+255, ALT+255.

4. Создаем (восстанавливаем) панель быстрого запуска (Quick Launch).

1) Правой кнопкой по панели задач ->Панели(Toolbars )-->Создать панель инструментов(New Toolbar)-->
2) Выберите папку: %appdata%\Microsoft\Internet Explorer\Quick Launch
3) Нажмите кнопку выбора папки “Select Folder”.
4) Правой кнопкой на панели задач -> снять галку "Закрепить панель задач";
5) Правой кнопкой мыши на появившемся "quick launch"--->убираем галки с "Показывать подписи" и "Показывать заголовок"
6) Перетаскиваем в левую сторону и закрепляем обратно панель --->Все!

5. Удаление или разблокирование любого файла защищённого Windows.

1. Качаем и устанавливаем программу Unlocker
2. Копируем файл(ы) в буфер обмена, для дальнейшей замены.
3. С помощью программы Unlocker, удаляем заменяемый(е) файл(ы).
4. После удаления файла(ов), вставляем заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления) и перезагружаем компьютер.
P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, переходим к папке C:\Windows\rescache и с помощью этой хе программы Unlocker удаляем её содержимое. Перезагружаемся.

Для 64-битных систем аналогом является программа LockHunter 64-bit.

6. Убираем лишние надписи на рабочем столе.

Открываете с помощью Restorator или PE Explorer файлы C:\Windows\System32\ru-RU\user32.dll.mui и C:\Windows\System32\en-US\user32.dll.mui и в строковой таблице удаляем строчки с 715 по 718 включительно, для того чтобы лишних надписей на рабочем столе не было.

7. Смена названия операционной системы из Максимальная на Ultimate.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Branding\Basebrd\ru-RU\basebrd.dll.mui и правите в нем название операционной системы из Максимальная на Ultimate. Также можно скопировать файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US\ в папку C:\Windows\Branding\Basebrd\ru-RU\ если данной папки нет, то файлы можно скачать тут: для x86, для x64

8. Использование всей оперативной памяти в 32-битных Windows.

1) Скачать здесь автоскрипт от deepxw.
2) 3апустить ReadyFor4GB.exe
3) Нажать на кнопку Check, затем на кнопку Apply.
4) Перезагрузить компьютер и вам станут доступны все 4 ГБ оперативки на вашей установленной ОС Windows 7 (x86), или если у вас установлено более >4ГБ, то ваш объем Оперативной памяти также станет доступен в полном объеме без ограничений...

Примечание: Файлы обязательно запускать как администратор, запускайте этот скрипт строго в операционной системе Windows 7 x86 (32-Bit) для которой вам нужно снять ограничение.

9. Запускаем Windows Explorer с папки My Computer, вместо Libraries.

Настраиваем нажатие на кнопку Windows Explorer, чтобы оно приводило в паку My Computer, вместо Libraries:

Просто измените в свойствах ярлыка Windows Explorer поле Target (Объект) на %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Чтобы это изменение затронуло и ссылку в меню Start, то вам потребуется изменить поле Target в свойствах ярлыка Windows Explorer и в папке Accessories из меню Start.
Чтобы в панеле задач иконка Проводника, так же выходила в Мой компьютер, а не библиотеки, для этого нужно удалить ее с панели задачи, правый клик и Unpin. Возвращаемся в Accessories находим знакомую иконку, правый клик по ней и выбираем Pin to Taskbar.
Комбинация клавиш Win+E также откроет Проводник в «Компьютере»

10. Добавление или прямой запуск папки Все задачи (для разработчиков и тестеров), и других системных папок.

Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

Список системных папок, возможных для создания:

Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

Список команд для прямого запуска:

Все задачи - shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Все элементы панели управления - shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Компьютер - shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Панель управления - shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Персонализация - shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - shell:::{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - shell:::{60632754-c523-4b62-b45c-4172da012619}

Также, вы можете самостоятельно поискать в ветке реестра HKEY_CLASSES_ROOT\CLSID наименования других системных папок, для их создания или прямого запуска. Для создания папки к её реестровому наименованию, добавьте необходимое Вам название, а для прямого запуска перед названием папки добавьте shell::: .

11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.
Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Нажмите кнопку "Пуск",
2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

В выпадающем списке выберите подходящее для Вас значение.

12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".
У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

Если в настройках фонового рисунка рабочего стола, вызываемых:
1) ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола
2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win+R –> Regedit –> OK) по адресу:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

Вы можете создать новую библиотеку и добавить в неё Ваши папками.

1) Открываете папку Библиотеки. У кого она удалена из проводника, тот может открыть её введя в адресную строку Windows Explorer:
shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
2) Нажимаете ПКМ -> Создать -> Библиотека
3) Переименовываете её. Например: Обои для рабочего стола
4) Щелкаете ПКМ и выбираете Свойства
5) Добавляете отдельно каждую папку
6) В графе Оптимизировать эту библиотеку: выбираете Изображения
7) Нажимаете применить, затем Ок.
8) После этого открываем раздел Персонализация –> Фон рабочего стола -> и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалиться из системы(из той папки,в которой он находится).

Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

Её ключевые возможности:
- Создание библиотеки из произвольного набора папок.
- Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
- Переименование библиотеки.
- Указание типа содержимого новой или редактируемой библиотеки.
- Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
- Управление отображением библиотеки в панели навигации проводника.
- Отображение библиотеки в виде XML-файла.
- Отображение системного диалога папок, включенных в библиотеку.

Скачать данную программу можно здесь или здесь

Твики Реестра

Твики Реестра - Добавление

1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@="\"%1\" /X:\"%1_unpacked\""
В итоге, при распаковке WindowsXP-KB922582-x86-RUS.exe, на выходе получаем папку WindowsXP-KB922582-x86-RUS.exe_unpacked с извлечёнными файлами. Минус один - команда Unpack HotFix встраивается в контекстное меню всех екзешников, а не только файлов от MS.

Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix]
[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@=-

Готовые reg-файлы Вы можете скачать по ссылке: Unpack_HotFix.zip

2. Как задать полный доступ к файлу или папке?

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"

3. Автоматическое VPN подключение к интернет при запуске Windows (реестр).

1. Создайте ваше VPN подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
2. В реестре Windows (Пуск->Выполнить->"regedit") найдите следующую ветку:
"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск только для текущего пользователя) или
"HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск для всех пользователей)
В этой ветке создайте "строковый параметр" (правой кнопкой мыши -> «Создать» -> «строковый параметр») с произвольным именем.
2. В качестве значения созданного параметра внесите строку вида:
rasdial "имя_вашего соединения" <логин> <пароль> (Например: rasdial "VPN connection" nz15vl 1234)
3. Закройте реестр и перезагрузите компьютер.

4. Добавляем пункт "Открыть в блокноте" в контекстное меню файлов.

Для того, чтобы добавить в контекстное меню файлов пункт "Открыть в Блокноте" текст кода сохраните в текстовый файл, присвойте ему расширение *.reg, запустите и согласитесь с добавлением данных в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте]
@=""

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте\command]
@="notepad.exe %1"

5. Как добавить дополнительные функции в папку Компьютер?

Администрирование

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{D20EA4E1-3957-11d2-A40B-0C5020524153}]

Корзина

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{645FF040-5081-101B-9F08-00AA002F954E}]

Панель управления

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\Controls]
@="{21EC2020-3AEA-1069-A2DD-08002B30309D}"

Принтеры и факсы

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{2227A280-3AEA-1069-A2DE-08002B30309D}]

Учетные записи пользователей

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{7A9D77BD-5403-11d2-8785-2E0420524153}]
В итоге получаем:

6. Добавляем произвольную команду в контекстное меню рабочего стола.

Для этого создаем файл fix.txt
Открываем блокнот и копируем туда это содержимое, сохраняем и меняем разширение на .reg
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name]
@="Свойства папки"
"Icon"="imageres.dll,200"
"Position"="Top"

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name\command]
@="control folders"
Сохраняем файл и выполняем его.
В параметре "Icon"="imageres.dll,200" цифра 200 отвечает за номер иконки. Вы можете указать свою.
Таким образом можно добавить практически любую команду (управление учетными записями Control userpasswords).

7. Конвертирование reg файлов в inf формат из контекстного меню, с помощью утилиты.
1) Скачиваете утилиту Reg2inf (необходим Framework 2 или 3)
2) Помешаете её в System32
3) Добавление в реестр добавляется следующее:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\command]
@="Reg2Inf.exe \"%1\" \"%1.inf\" /RepVars"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Application]
@="Reg2Inf"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Topic]
@="System"
В итоге, в контекстное меню reg файлов добавляется команда reg2inf и, к примеру, файл test.reg конвертируется в test.reg.inf

8. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".
Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB. С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\Shell]

[HKEY_CLASSES_ROOT\*\Shell\astext]
@="Как текст..."

[HKEY_CLASSES_ROOT\*\Shell\astext\command]
@="notepad.exe \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\Expand]
@="Распаковать .cab"

[HKEY_CLASSES_ROOT\*\Shell\Expand\command]
@="expand -r \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\MakeCab]
@="Запаковать в .cab"

[HKEY_CLASSES_ROOT\*\Shell\MakeCab\command]
@="makecab /D CompressionType=LZX /D CompressionMemory=21 \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\UpperCase]
@="Имя в ВЕРХНИЙ РЕГИСТР"

[HKEY_CLASSES_ROOT\*\Shell\UpperCase\command]
@="FILECASE /U \"%1\""

[HKEY_CLASSES_ROOT\Directory\shell\CabPack]
@="Запаковать папку в .cab"

[HKEY_CLASSES_ROOT\Directory\shell\CabPack\command]
@="cabs.cmd %L"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs]
@="Создать список файлов папки"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs\command]
@="dirs.cmd %L"

Твики Реестра - Изменение

1. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

1) Запустите меню Выполнить(Win+R) или командную строку от имени Администратора
2) Введите команду
unregmp2.exe /SwapTo:64
(команда чувствительна к регистру)
3) Откройте редактор реестра: Win+R --> regedit
4) Перейдите к ветке
HKLM\Software\Microsoft\Windows\CurrentVersion\App Paths\wmplayer.exe\
и кликните два раза по значению Path
5) Измените
"%ProgramFiles(x86)%\Windows Media Player"
на
"%ProgramFiles%\Windows Media Player"
6) Закройте реестр и наслаждайтесь Windows Media Player х64

Готовые bat-файлы Вы можете скачать по ссылке: Windows_Media_Player_x64.zip

2. Ускорение выключения компьютера.

Измените задержку перед выключением компьютера в реестре в разделе:
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WaitToKillServiceTimeout" - отвечает за задержку перед выключением.
По умолчанию установлено значение (20000)=20 сек., но вы можете установить его значение, намного меньше номинального (минимум 100), и система будет закрываться намного быстрее.
Рекомендуемые значения (2000-5000)=2-5 сек. (меньше не рекомендуется, иначе система будет понимать неадекватно отсутсвие откликов от служб, и завершать их в "неподходящий" момент времени, например когда они сохраняют свои последние настройки)

3. Отмена автозапуска у устройства (DVD диска, Flash диска и т.д.)

1) Пуск -> выполнить -> regedit
2) открыть ветку HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) В этом разделе создать ключ(Параметр DWORD) NoDriveTypeAutoRun

Допустимые значения ключа:

0x1 - отключить автозапуск на приводах неизвестных типов
0x4 - отключить автозапуск сьемных устройств
0x8 - отключить автозапуск НЕсьемных устройств
0x10 - отключить автозапуск сетевых дисков
0x20 - отключить автозапуск CD-приводов
0x40 - отключить автозапуск RAM-дисков
0x80 - отключить автозапуск на приводах неизвестных типов
0xFF - отключить автозапуск вообще всех дисков.

4. Смена фона в экране авторизации.

1) Создайте ключ типа DWORD с названием OEMBackground в ветке реестра
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background

2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
4) Поместите сюда свой файл
5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

background768x1280.jpg
background900x1440.jpg
background960x1280.jpg
background1024x1280.jpg
background1280x1024.jpg
background1024x768.jpg
background1280x960.jpg
background1600x1200.jpg
background1440x900.jpg
background1920x1200.jpg
background1280x768.jpg
background1360x768.jpg
backgroundDefault.jpg - в случае нестандартного расширения монитора

Размер изображений не должен превышать 256Кб.
Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

5. Ускорение анимации всплывающего меню в меню Пуск и появления окна предварительного просмотра в панели задач.

При наведении на значок приложения в панели задач окно предварительного просмотра появляется с задержкой.

1.Запускаем редактор реестра (Пуск –> Выполнить –> regedit)
2.Находим ключ HKEY_CURRENT_USER –> Control Panel –> Mouse
3.В этом ключе находим значение MouseHoverTime
Выбираем желательное время в миллисекундах, по прошествии которого после наведения указателя мыши будет показываться эскиз окна.
Чтобы случайно при проведении мыши, окно не выскочило, но при наведении целенаправленно, окно появилось практически мгновенно поставьте значения не меньше 50.
4. Находим ключ HKEY_CURRENT_USER\Control Panel\Desktop
5. В этом ключе находим значение MenuShowDelay
Выбираем желательное значение от 1 до 4000, означающее задержку в милисекундах, до показа всплывающего меню.
6. Закрываем regedit и перезагружаем систему.

6. Как продлевать срок начального льготного доактивационного периода?

Эта процедура не хакерская уловка и не требует никаких инструментов или утилит вообще и, более того, документирована Microsoft, на ее сайте Technet.
1. В запущенной Windows 7, которая не была еще активирована, щелкните кнопку Start, напечатайте regedit в строке Поиска, затем нажмите ENTER, чтобы запустить Редактор реестра.
2. Перейдите к ключу реестра:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform
3. Щёлкните правой кнопкой мыши на SkipRearm и выберите Edit. Установленное значение по умолчанию - Dword с значением 00000000.
Измените это значение на любое положительное целое число, например, 00000001, сохраните и закройте редактор реестра.
4. Запустите командную строку с правами администратора.
5. Напечатайте одну из следующих двух команд и нажмите ENTER:
slmgr -rearm или rundll32 slc.dll,SLReArmWindows
Эти команды используют встроенный в Windows 7 Менеджер лицензий (SLMGR), который по умолчанию дает 30 дней доактивационного периода.
Изменение ключа SkipRearm с 0 на 1 (с 00000000 на 00000001) позволяет менеджеру лицензий SLMGR проделывать процедуру сброса счетчика неограниченное количество раз!
Изменение значения ключа SkipRearm с 1 на 0 возвращает SLMGR к исходному состоянию. 6. Перезагрузите компьютер, чтобы изменения вступили в силу.

7. Переназначение гнезд звуковой карты Realtek используя реестр.
На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

1) Установите драйвера звуковой карты
2) Запустите редактор реестра (Win+К -> regedit -> Ok)
3) Пройдите к папке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\
4) Откройте папку Drv6013_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
5) Создайте двоичный параметр(Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

Рисунок 1 из 2

Имя(вставлять без кавычек):

"Pin01" = Заднее зеленое гнездо
"Pin02" = Заднее черное гнездо
"Pin03" = Заднее коричневое гнездо
"Pin04" = Заднее серое гнездо
"Pin05" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
"Pin07" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

"Pin06" = Переднее розовое гнездо
"Pin08" = Переднее зеленое гнездо

Значение(вставлять без кавычек):

"00 00 00 00" = Линейный вход
"01 00 00 00" = Микрофон
"02 00 00 00" = Наушники
"04 00 00 00" = Передние динамики
"05 00 00 00" = Тыловые динамики
"06 00 00 00" = Центральный канал/Сабвуфер
"07 00 00 00" = Боковые динамики

Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

Drv6013_DevType_0888_SS10438357 - на версию вашего драйвера
(имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
Pin04 - на любое значение из списка Имя
hex:02,00,00,00 - на любое значение из списка Значение(просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\Drv6013_DevType_0888_SS10438357]
"Pin04"=hex:02,00,00,00

Рисунок 2 из 2

8. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Запустите редактор реестра (Нажмите Win+R, введите команду regedit.exe и нажмите Ок)
2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
3) Измените значение параметра MessageDuration.

9. Настройка диалога переключения между окнами ("Alt"+"Tab").

1) Запустите Редактор Реестра (Win+R -> Regedit -> Ok)
2) Откройте ветку реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если она отсутствует, то создайте её (щелкните на папке Explorer правой кнопкой мыши, выберите Создать -> Раздел и назовите её AltTab).
В данной папке создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Для создания твика, воспользуйтесь инструкцией:

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Параметры, отвечающие за количество отображаемых столбцов и строк

Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"Columns"=dword:00000005
"Rows"=dword:00000003
Параметры, отвечающие за отступы в диалоге переключения между окнами

Упомянутые ниже параметры указываются в пикселях.

TopMarginPx - величина верхнего поля, добавляемого в диалог
SideMarginPx - величина бокового поля, добавляемого в диалог
BottomMarginPx - величина нижнего поля, добавляемого в диалог
MinWidthPx - минимальная возможная ширина диалога AltTab
ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"TopMarginPx"=dword:00000027
"SideMarginPx"=dword:00000005
"BottomMarginPx"=dword:00000003
"MinWidthPx"=dword:00000050
"ThumbSpacingXPx"=dword:00000006
"ThumbSpacingYPx"=dword:00000015
Параметры, отвечающие за значки эскизов окон

Упомянутые ниже параметры указываются в пикселях.

OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"OverlayIconDYPx"=dword:00000008
"OverlayIconDXPx"=dword:00000008
"OverlayIconPx"=dword:00000030
Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

Упомянутые ниже параметры указываются в пикселях.
MaxThumbSizePx - максимальный размер эскизов окон
MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
TextButtomPx - высота заголовка диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"MinThumbSizePcent"=dword:00000010
"MaxThumbSizePx"=dword:00000085
"TextButtomPx"=dword:00000010
Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

StartAlpha - начальная прозрачность диалога переключения между окнами
FinalAlpha - конечная прозрачность диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"FadeOut_ms"=dword:00000100
"FadeIn_ms"=dword:00000100
"StartAlpha"=dword:00000002
"FinalAlpha"=dword:00000004
Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt+Tab, создайте DWORD-параметр AltTabSettings в ветви реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

Твики Реестра - Удаление

1. Как убрать цифру при пересоздании адаптера сети в Диспетчере устройств?

Вариант 1

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" установите значение адаптера сети на 0.
3) Создайте драйвер сетевого адаптера

Вариант 2

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" удалите ваш сетевой адаптер.
3) Создайте драйвер сетевого адаптера.

2. Как отключить проверку подписи для загруженных программ?

Избавляет от этого:

1) В Панель управления -> Свойства браузера-> вкладка Дополнительно -> снять галочку "Проверка подписи для загруженных программ" и поставить галочку "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
2) Создайте и примените reg-файл следующего содержания.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"DefaultFileTypeRisk"=dword:00006152

;Отключить предупреждение при открытии файлов, загруженных из Интернета
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments]
"HideZoneInfoOnProperties"=dword:00000001
"SaveZoneInformation"=dword:00000002

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000095

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"LowRiskFileTypes"=".zip;.rar;.nfo;.txt;.exe;.bat;.com;.cmd;.reg;.msi;.htm;.html;.gif;.bmp;.jpg;.avi;.mpg;.mpeg;.mov;.mp3;.m3u;.wav;"

3. Как удалить (вернуть) стрелки с ярлыков Windows?

Готовые файлы для убирания стрелок вы можете скачать по ссылке:
Shortcut_Arrows.rar
1) Распакуйте и откройте папку нужного вам варианта
2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat
3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat

Вариант 1

Для удаления стрелок с ярлыков:

1) Запустите диалоговое окно "Выполнить" (Win + R)
2) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %WINDIR%\system32\shell32.dll,50 /f
Для восстановления стрелок на ярлыках:
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f

Вариант 2

Для удаления стрелок с ярлыков:

1) Создайте пустой файл иконки назовите его Blank.ico
2) Скопируйте его в папку C:\Windows
3) Запустите диалоговое окно "Выполнить" (Win + R)
4) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %SystemRoot%\Blank.ico,0 /f
Для восстановления стрелок на ярлыках:

1) Удалите файл Blank.ico из папки C:\Windows
2) Запустите диалоговое окно "Выполнить" (Win + R)
3) Скопируйте код указанный ниже и нажмите OK
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f

4. Как отключить или переназначить клавишу Caps Lock?

Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра. Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

Клавиша Caps Lock будет выполнять действие клавиши Ctrl
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,1d,00,3a,00,00,00,00,00
Клавиша Caps Lock будет выполнять действие клавиши Shift

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,2a,00,3a,00,00,00,00,00
Отключает Caps Lock и переназначает действие клавиши Scroll Lock на выполнение Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,3A,00,46,00,00,00,00,00
Отключает клавишу Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,00,00,00,00
Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=-

5. Удаление просроченных элементов в области уведомления панели задач.

1. Запустите редактор реестра: Win+R --> regedit
2. Перейдите в следующий раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify
3. Удалите параметры "IconStreams" и "PastIconsStream"
4. Запустите диспетчер задач Ctrl+Shift+Esc
5. Остановите процесс explorer.exe
6. File --> New Task (Run...) --> explorer --> ОК.
7. Установите необходимые параметры отображения области уведомления панели задач.

6. Удаление папок из Рабочего стола в Проводнике.

Если вы хотите, удалить папки из Рабочего стола в Проводнике.

Вариант 1

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
3) Пройдите к ветке реестра "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace"
4) Сделайте себе её экспорт, на случай восстановления(ПКМ на данной ветке-Экспортировать).
5) Удалите следующие ветки:
Favorites(Избранное)             = {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки)            = {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа)       = {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Папки)    = {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер)              = {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть)                    = {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) = {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина)             = {645FF040-5081-101B-9F08-00AA002F954E}

Вариант 2

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
Для удаления Favorites(Избранное), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a9400100
Для восстановления Favorites(Избранное) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a0900100
Для удаления Libraries(Библиотеки), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b090010d
Для восстановления Libraries(Библиотеки) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b080010d
Для удаления Homegroup(Домашняя группа), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Homegroup(Домашняя группа) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Computer(Компьютер), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Computer(Компьютер) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Network(Сеть), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0940064
Для восстановления Network(Сеть) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0040064
Для удаления Recycle Bin(Корзина), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:70,01,00,20
Для восстановления Recycle Bin(Корзина) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:40,01,00,20

7. Очистка устаревших значков из диалога выбора значков и уведомлений.

После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify]
"PastIconsStream"=-
"IconStreams"=-
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Скачать готовый reg-файл Вы можете по ссылке: Clean_TrayNotify.zip

8. Очистка истории расположений фонов рабочего стола в Windows 7.

В окне настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев Рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

1. Фоны рабочего стола Windows;
2. Библиотека изображений;
3. Самые популярные фотографии;
4. Сплошные цвета.

Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

Твики Реестра - Восстановление

1. Принудительное включение Windows Aero (только для Standard Administrator).

1) Нажмите Win+R и введите regedit
2) Установите следующие значения в регистре:
HKCU\Software\Microsoft\Windows\DWM\Composition равный 1 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy равынй 2 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\ColorizationOpaqueBlend равный 1 (32-bit DWORD)
Готовый reg-файл enableaero.reg
3) Перезапустите DWM из command prompt, запущенного с правами администратора:
net stop UxSms
net start UxSms

2. Как исправить высокий пинг в Windows 7?

1. Пуск - Выполнить - regedit
2. Ищем там HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
3. Ищем там интерфейс по которому у вас работает интернет, если не в курсе то делаем следующий шаг во всех
4. Правой кнопкой в поле справа, там создать строчку DWORD, называем ее TcpAckFrequency потом правой кнопкой на ней, изменить, ставим шестнадцатиричную галочку, и пишем значение 1
5. Идем в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
Если такого пункта в реестре нет, а его скорее всего нет, то делаем следующие шаги:
Открываем - Пуск- Панель управления - Программы и Компоненты-(слева)Включение и отключение компонентов Windows.
Там находим пункт - Сервер очереди сообщений Майкрософт (MSMQ), и ставим галочку напротив него и все галочки внутри в выпадающем списке компонентов. Перегружаемся, идем в реестр и видим там нужную нам запись.

6. В месте указанном в пункте 5 ищем TCPNoDelay, если нету создаем DWORD параметр с таким названием. значение 1.

3. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"
Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

Необходимо восстановить через реестр значение по умолчанию "JSFile" .

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.JS]
@="JSFile"

4. Решение проблемы, когда вместо русских букв возникают ???? (реестр).
1) Замените в реестре в ветке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage С "1252"="c_1252.nls" на "1252"="c_1251.nls"
2) В папке \WINDOWS\system32\ найдите файлы С_1251 и С_1252. С_1251 куда-нибудь копируем и переименовываем в С_1252.
3) Оригинальный С_1252 переименовываем или удаляем (потребуется изменить права доступа). Возвращаем новую версию 1252 на место. В итоге файл С_1252, должен быть переименованной копией С_1251
4) Пуск-Панель управления-Язык и региональные установки-Дополнительно. Выбрать в пункте Текущий язык программ не поддерживающий Юникод: Русский (Россия)
5) Перезагружаемся.

5. Гаджеты или их настройки отказываются запускаться.

Для нормального функционирования гаджетов не отключайте UAC системы полностью. Выставьте минимальный уровень.
В случае если вы хотите восстановить работоспособность гаджетов при отключенном UAC, понимая уязвимость такого решения, вы можете применить твик реестра, указанный ниже. После перезагрузки гаджеты будут работать.
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings"
"AllowElevatedProcess"=dword:00000001

6. Восстановление пункта "Закрепить программу в панели задач".

Если у вас пропал пункт "Закрепить программу в панели задач":
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
"IsShortCut"=""
"IsNotShortCut"=-

7. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

Удаление кэша эскизов может понадобиться при возникновении проблем с их отображением. После удаления кэша эскизов они вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов, таким образом пересоздастся кэш и возможно удастся решить проблему с отображением некоторых эскизов.
Для очистки кэша эскизов сделайте следующее.

1) Нажмите комбинацию клавишь WinKey+R, в поле Открыть напишите cleanmgr и нажмите OK
2) Выберите диск C: и после оценки объема отметьте "Эскизы" и нажмите OK
3) В папке %USERPROFILE%\AppData\Local\ стереть файл IconCache.db

Еще можно попробовать увеличить размер этого кеша, создав в реестре в ключе [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer] новый параметр Max Cached Icons типа строки (REG_SZ) и занеся в него 4096 (а если такой параметр уже был, увеличить его вдвое).

8. Пользовательские папки отображаются обычными иконками.

Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
IconResource=%SystemRoot%\system32\imageres.dll,-112
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-235
Изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21779
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\imageres.dll,-113
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-236
[LocalizedFileNames]
Sample Pictures.lnk=@%SystemRoot%\system32\shell32.dll,-21805
Музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21790
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\imageres.dll,-108
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-237
[LocalizedFileNames]
Sample Music.lnk=@%SystemRoot%\system32\shell32.dll,-21806
Видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21791
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\imageres.dll,-189
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-238
[LocalizedFileNames]
Sample Videos.lnk=@%SystemRoot%\system32\shell32.dll,-21807
Поиски
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-9031
IconResource=%SystemRoot%\system32\imageres.dll,-18
[LocalizedFileNames]
Indexed Locations.search-ms=@shell32.dll,-32811
Everywhere.search-ms=@shell32.dll,-32814
Shared By Me.search-ms=@shell32.dll,-32802
Recent Music.search-ms=@shell32.dll,-32803
Recent Documents.search-ms=@shell32.dll,-32804
Recent Pictures and Videos.search-ms=@shell32.dll,-32806
Recent E-mail.search-ms=@shell32.dll,-32807
Recently Changed.search-ms=@shell32.dll,-3281
Загрузка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21798
IconResource=%SystemRoot%\system32\imageres.dll,-184
Избранное
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21796
IconResource=%SystemRoot%\system32\imageres.dll,-115
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-173
Контакты
[.ShellClassInfo]
LocalizedResourceName=@%CommonProgramFiles%\system\wab32res.dll,-10100
InfoTip=@%CommonProgramFiles%\system\wab32res.dll,-10200
IconResource=%SystemRoot%\system32\imageres.dll,-181
Рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183
Ссылки
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21810
IconResource=%SystemRoot%\system32\imageres.dll,-185
DefaultDropEffect=4
[LocalizedFileNames]
Public.lnk=@shell32.dll,-21816
Searches.lnk=@shell32.dll,-9031
Recently Changed.lnk=@shell32.dll,-32813
Music.lnk=@shell32.dll,-21790
Pictures.lnk=@shell32.dll,-21779
Documents.lnk=@shell32.dll,-21770
Сохраненные игры
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21814
IconResource=%SystemRoot%\system32\imageres.dll,-186
Общий рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21799
Общие документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21801
IconResource=%SystemRoot%\system32\shell32.dll,-235
Общая музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21803
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\shell32.dll,-237
Общие изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21802
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\shell32.dll,-236
Общее видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21804
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\shell32.dll,-238

9. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

Internet Explorer не удается загрузить / из help
Не удается открыть этот узел Интернета. Узел не доступен или не найден. Повторите попытку позднее.

Это может происходить по причине неправильного сопоставления программам типа файлов .xml
Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.xml]
@="xmlfile"
"Content Type"="text/xml"
"PerceivedType"="text"

[HKEY_CLASSES_ROOT\.xml\OpenWithList]

[HKEY_CLASSES_ROOT\.xml\OpenWithList\winword.exe]
@=""

[HKEY_CLASSES_ROOT\.xml\PersistentHandler]
@="{7E9D8D44-6926-426F-AA2B-217A819A5CCE}"

Устранение неполадок

1. Перестали запускаться анимированые обои. Ошибка:"Windows DreamScene can only run when Windows Aero scheme is selected."

Вероятно, аэро - отключено.
Щелкаете правой кнопкой на монитор - Персонализация - выберите тему с прозрачными окнами (они вверху). Или C:\Windows\Resources\Themes выбрать aero.

2. Решение проблемы с анимацией DWM (Desktop Window Manager).

1) Нажимаете "Пуск" на панели задач
2) Нажимаете правой кнопкой на Компьютер
3) Выбираете Свойства -> Дополнительные параметры системы
4) В открытом окне выбираете вкладку Дополнительно-Быстродействие-Параметры
5) На вкладке Визуальные эффекты, уберите галочку - Анимация окон при свертывании и развертывании.

3. Создаете панель быстрого запуска, но после перезагрузки она исчезает.

Возможная причина - отсутствие пароля учетной записи.

4. Если гаджет погоды пишет service unavailable for your region.

Для нормальной работы гаджетов не отключайте UAC полностью, а ставьте на минимум.
Если отключить UAC совсем (крайне нижнее положение - Never Notify), то гаджеты могут пропасть.
А панель настройки гаджетов может стать недоступной.

Вариант 1

Завершите процесс sidebar.exe и перезапустите его (правой кнопкой мыши на рабочем столе --> Gadgets)

Также добавьте в папке %WINDIR%\system32\driverc\etc в файл hosts следующие строки:
207.68.172.246 www.msnweather.com
198.78.215.126 blst.msn.com
65.55.228.63 weather.msn.com
65.55.17.39 weather.service.msn.com

Вариант 2

Если перезапуск не помогает, то вы можете поставить другой гаджет погоды, например: AccuWeather.com® Forecast Gadget

5. Решение проблемы, когда вместо русских букв возникают ????.

При новой установке с компакт-диска выводится окно, там три строчки.
В верхней - язык, на котором работает система (в нашем случае - английский US).
Вторая строчка - месторасположение компьютера - там куча стран - начиная от Афганистана и заканчивая Ямайкой. Там надо найти страну - RUSSIAN FEDERATION.
Третья строка - язык раскладки клавиатуры по умолчанию. При выборе во второй строке нашей страны (РФ), там автоматом ставится русский.

6. В Windows Update при попытке обновления появляется error 80072ee7.

Если во время проверки наличия обновлений Центр обновления Windows выдает сообщение об ошибке 80072ee7, возможно, следует изменить или удалить статические IP-адреса для службы Центра обновления Windows . Адреса хранятся в файле операционной системы Hosts.

IP-адрес для службы Центра обновления Windows может изменяться во время каждой проверки наличия обновлений, однако некоторые программы-надстройки Windows добавляют в файл Hosts статические адреса. Статический IP-адрес для службы Центра обновления Windows не позволит компьютеру получать обновления.

Удаление статического IP-адреса для веб-сайта службы Центра обновления Windows

1. Откройте компонент Компьютер. Для этого нажмите кнопку Пуск и выберите пункт Компьютер.
2. Дважды щелкните значок локального жесткого диска, на котором установлена система Windows (обычно диск С).
3. Дважды щелкните папку Windows, а затем - папку System32.
4. Дважды щелкните папку драйверы, а затем - папку и т. д..
5. В папке etc щелкните правой кнопкой мыши файл hosts и нажмите Открыть. После того как вам будет предложено выбрать программу, с помощью которой следует открывать данный файл, выберите Блокнот.
6. Проверьте, стоит ли в файле hosts знак # около всех записей IP-адресов и имен узлов Центра обновления Windows. Если это не так, вставьте значок # или удалите запись целиком.
7. Откройте меню Файл, выберите команду Сохранить и повторно выполните проверку наличия обновлений.

7. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.
На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
Скачать исправление KB977178 : для x86 или для x64

8. Как восстановить стандартный бутскрин Windows 7?

Вариант 1

Выполнить - C:\Windows\System32\sysprep\sysprep.exe выбрать OOBE и ОК. Не забываем о разрешении экрана (17" -1280*1024)

Вариант 2

1. Откройте меню Start и в поле для ввода наберите "cmd" (без кавычек). Щелкните правой кнопкой на найденном элементе и из выпавшего меню выберите Run As Administrator. При необходимости введите пароль.
2. В открытом окне консоли введите команду:

bcdedit /set {current} locale en-US
Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Выйдите из консоли, перезагрузите систему и вуаля - пред вами снова анимированный экран загрузки Windows 7.

9. При использовании сторонних плееров для видео выкидывает синий экран.

Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

10. Исправление сбоев в Проводнике и Windows Installer (msiexec.exe).

Вариант 1

Запустите командную строку от имени Администратора (Пуск->Все программы->Стандартные->Командная строка) и скопируйте следущую строчку:
reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\Disabled Sessions /va /f

Вариант 2

1) В меню Выполнить введите "gpedit.msc" перейдите по адресу:
Конфигурация компьютера->Административные шаблоны->Система->Управление связью через Интернет->Параметры связи через Интернет.
2) Щелкните на строчку "Отключить программу по улучшению качества программного обеспечения Windows"
3) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

11. Как восстановить стандартный бутскрин Windows 7?

В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, когда пользователь пытается внести различного рода изменения в загрузчик ОС.
Если вы столкнулись с этой проблемой, вот вам простое и действенное решение:
1. Откройте меню Start и в поле для ввода наберите "cmd" (без кавычек). Щелкните правой кнопкой на найденном элементе и из выпавшего меню выберите Run As Administrator. При необходимости введите пароль.
2. В открытом окне консоли введите команду:
bcdedit /set {current} locale en-US
Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Выйдите из консоли, перезагрузите систему и вуаля - пред вами снова анимированный экран загрузки Windows 7.

12. В Мой Компьютер не показывают DVD-дисководы.

Уберите галочку в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

13. Как получить полный доступ к NTFS-томам, системному реестру, параметрам настройки и драйверам в случае тотального повреждения существующей на диске ОС или для перезаписи исправлений к русификации поверх оригинальных файлов?

Для этой функции можно использовать программу Microsoft ERD Commander входящую в состав Microsoft Diagnostics and Recovery Toolset.
Вы можете создать свой загрузочный образ на основе имеющегося у вас дистрибутива или скачать готовый образ Microsoft ERD Commander.
Программа для создания своего образа, на основе дистрибутива Windows 7. Запускается только в Windows 7.

ERD Commander для x86 или x64

14. Решение проблемы с punkbuster на Windows 7.

Вариант 1

Решение проблемы вылетов игр (COD 5 и battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136). Лечится так:
1. обновляем punkbuster - качаем это запускаем и добавляем туда игру, pb которой нужно обновить и жмем check for updates. в конце появится сообщение об окончании.
2. находим на диске с windows два файла: PnkBstrA.exe и PnkBstrB.exe оба лежат в C:\Windows\SysWOW64 (для х64) и C:\Windows\System32 (для х86) (PnkBstrB.exe еще есть в папке с игрой C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb (думаю аналогично и в cod5). У этих файлов в свойствах выставить совместимость с XP и Vista.

Вариант 2

1. в %WINDIR%\system32\ файлам PnkBstrA.exe, PnkBstrB.exe поставить совместимость с Вистой и Права администратора.
2.На рабочем столе создать батник с следующим содержанием :
:start

sc config PnkBstrA type= own type= interact

sc config PnkBstrB type= own type= interact

timeout 60

goto start
3. Запускать батник перед запуском игр.
4. Играть

15. Моргание игр в режиме OpenGL.

Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

16. Восстановление пункта "Выполнить" в меню "Пуск".

Если у вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает вы можете восстановить его так:
1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
2) В левой части открывшегося окна пройти к вкладке:
Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

17. В Windows и Nero не стираются диски DVD RW и CD RW.

Если при попытке стереть данные диски вы получаете ответ "Не перезаписываемый диск" или "Диск защищён от записи". По всей видимости была сделана метка на диске и программы определяют его как DVD-R. Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис -> Настройки -> Эмуляция -> Игнорировать тип носителя, в Daemon Tools Спрятать CD-R.
Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.

18. Как убрать появляющуюся в меню "Пуск" полоску справа, которая пропадает при следующем открытии.

1) Переключаете язык интерфейса в английскую версию Windows: Панель управления->Язык и Региональные Стандарты->Языки и Клавиатуры->Язык интерфейса->выбираете английский
2) Перелогиниваетесь или перезапускаете комп
3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
5) Возвращаете язык интерфейса на русский
6) Радуетесь!
Для тех у кого изначально русская, выкладываю данный файлик отдельно для x64: aero.msstyles.mui и для x86: aero.msstyles.mui

19. Как восстановить ассоциацию с файлами *.cpl?

Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

1) Щелкаете ПКМ на любом файле *.cpl
2) Выбираете Свойства -> Приложение -> Изменить
3) Заходим в папку C:\Windows\System32 и выбираем там control.exe
4) Жмем Ок

20. Исправление вылета проводника при нажатии правой клавиши на файле.

Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
1) Скачайте небольшую утилиту ShellExView: с оффициального сайта или с зеркала.
2) После установки и запуска программы, найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
4) Перезагрузите компьютер.

21. Запись последовательности действий пользователя для анализа их разработчиком.

Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести имя файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

22. Восстановление исчезнувшей языковой панели.

Вариант 1

1) Идем в Панель управления - Язык и региональные стандарты
2) Смотрим скриншот и делаем все по пунктам

Рисунок 1 из 2

3) Жмем OK, OK
4) Щелкаем правой кнопкой на панели задач, выбираем Свойства.
5) В пункте Область уведомлений щелкаем кнопку Настроить

Рисунок 2 из 2

6) В открывшемся окне ставим галочку "Всегда показывать все значки и уведомления на панели задач" и нажимаем OK, OK

Вариант 2

Найдите файл ctfmon.exe и добавьте его в Атозагрузку или создайте reg-файл со следующим содержанием:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
"CTFMon"="C:\Windows\system32\ctfmon.exe"

23. Определение драйвера, вызвавшего BSOD.

Включение записи дампов памяти

1) Нажимаете комбинацию клавиш Win+Pause
2) Щелкаете ссылку Дополнительные параметры системы
3) Переходите на вкладку Дополнительно
4) Нажимаете кнопку Параметры в Загрузка и восстановление

Рисунок 1 из 2

5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

Рисунок 2 из 2

Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

Вариант 1

1) Загрузите и установите Debugging Tools for Windows.
2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
3) Распакуйте архив в любую папку.
Примечание: Если папка Debugging Tools for Windows находиться у вас не в папке Program Files, то в файле kdfe.cmd необходимо указать другой путь к папке, в которую установлены средства Debugging Tools for Windows.
Путь к папке указан после параметра set dbgpath=
4) Откройте командную строку и перейдите в папку, в которую вы распаковали kdfe.cmd.
5) Запустите файл, указав в качестве параметра путь к файлу дампа памяти (в примере ниже файл называется Mini1110307-01.dmp)
kdfe.cmd "%systemroot%\Minidump\Mini1110307-01.dmp"
6) Дождитесь завершениия анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

Вариант 2

1) Скачиваете утилиту BlueScreenView.
2) Устанавливаете BlueScreenView.
3) Распаковываете bluescreenview_russian.zip и кладете файл bluescreenview_lng.ini в туже папку куда установлена BlueScreenView.
4) Запускаете BlueScreenView.

Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options –> Advanced).
Для найденных дампов памяти утилита отображает:
  • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
  • В нижней панели – (в зависимости от настроек в Options –> Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы.

24. Расшифровка значений ошибок синего экрана смерти(BSOD) и способы их устранения.

Порой, получив какую-либо ошибку синего экрана смерти, вы задумываетесь из-за чего же она произошла. Для этого случая, скачайте подборку с разъяснениями значений часто встречающихся ошибок и способами устранения многих из них.
Скачать: BSOD.rar

25. В Windows x64 стало показывать меньше памяти, чем есть.

Зайдите:
Панель управления->Администрирование->Конфигурация системы>вкладка Загрузка->Дополнительные параметры
Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

Также посмотрите значение функций в биосе:

1. HPET Mode должно быть 64-bit (если есть такая функция)
или
2. Memory Remap Feature должно быть Enabled
3. Memory Hole должно быть Disabled

Разное

1. Где можно скачать последнюю версию DirectX?

Оффициальный сайт для скачивания последних версий DirectX находится по ссылке ниже:

Оффициальный сайт DirectX

2. Как открыть файлы с расширением .hlp?

Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe. Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
Оффициальная ссылка: здесь

3. Как свернуть все неактивные окна, кроме текущего активного, при помощи функции Aero Shake?

В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

4. Список клавиатурных сокращений.
Основные:

Win+Up - Развернуть окно
Win+Down - Восстановить / Минимизировать окно
Win+Left - Прикрепить окно к левому краю экрана
Win+Right - Прикрепить окно к правому краю экрана
Win+Shift+Left - Переключиться на левый монитор
Win+Shift+Right - Переключиться на правый монитор
Win+Home - Минимизировать / Восстановить все неактивные окна
Win+M - Минимизировать все окна
Win+Т - Выбрать первый элемент в панели задач (Повторное нажатие переключает на следующий элемент, Win+Shift+T - прокручивает в обратном порядке)
Win+Space - Показать рабочий стол
Win+B - Переход в область уведомлений(трей)
Win+G - Отобразить гаджеты поверх всех окон
Win+P - Отобразить дополнительные опции дисплея (расширить рабочий стол на 2 монитор и т.п.)
Win+X - Запустить Mobility Center
Win+ цифра- Запустить приложение с панели задач (Win+1 запускает первое приложения слева, Win+2, второе, и т.к.)
Win + "+" - Увеличить масштаб
Win + "-" - Уменьшить масштаб
Ctrl + колесо мыши (вверх\вниз) на рабочем столе - увеличить\уменьшить иконки рабочего стола.

Windows Explorer:
Alt+P - Показать / Скрыть Область предпросмотра

Панель задач:
Shift + щелчок на иконке - Открыть новое окно приложения
Ctrl + Shift + щелчок по иконке - Открыть новое окно приложения с привилегиями администратора
Shift + щелчок правой кнопкой на иконке - Показать меню приложения
Shift + щелчок правой кнопкой на группе иконок - Показать меню, восстановить все / cвернуть все / Закрыть все
Ctrl + щелчок по группе икнонок - Развернуть все окна группы

5. Включение Aero Glass в Windows на VirtualPC.
1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
5. Установить Сетевое соединение между двумя компьютерами.

На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
Жмите Connect и вводите логин.

Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

Грубо говоря, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

6. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

1) Закройте *.chm файл
2) Зайдите в Internet Explorer
3) Нажмите правую кнопку мыши
4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
5) Запустите ваш *.chm и система сама определит кодировку.

7. Автоматическое переключение русской и английской раскладок клавиатуры.
Часто бывает, что напечатав какой-то текст, вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".
Для того чтобы сохранить ваше терпение и нервы, существуют две замечательные программы: Punto Switcher(если вы в основном работаете с русской или английской клавиатурой) и Key Switcher(если вы работаете с несколькими европейскими языками).

Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером. Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

8. Удаление Windows 7 без форматирования раздела и без потери данных.
Для удаления Windows 7 описанным здесь способом вам потребуются:

а) ERD Commander;
б) Установочный диск Windows 7;

Шаг I. Удаление загрузочной информации Windows 7.

1) Загрузитесь в ERD Commader и вставьте установочный диск Windows 7 в свой DVD-привод.
2) Запустите Command Prompt
3) В открывшемся окне введите команду
E:\boot\bootsect.exe /nt60 ALL C: /force
Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

Шаг II. Удаление файлов и папок Windows 7.

1) Запустите Micosoft Diagnostics and Recovery Toolset -> Explorer
2) Как в обычном Explorer, тем же способом удалите следующие папки:
  • PerfLogs
  • Users
  • Windows
  • Recycle.Bin
  • Documents and Settings
  • ProgramData
  • Recovery

9. Создание образа и использование ERD Commander (необходим для получения полного доступа к файлам и папкам).

Скачиваете и устанавливаете сборщик образа ERD Commander для x86 или x64
Запускаете Пуск -> Все программы -> Microsoft Diagnostics and Recovery Toolset -> Мастер создания загрузочных носителей ERD Commander

По инструкции ниже создаете свой образ ERD Commander:

1) Монтируете образ дистрибутива Windows 7 в виртуальный дисковод
2) На вкладке Выбор образа загрузки указываете наш смонтированный виртуальный диск Windows 7

Рисунок 1 из 3

3) Щелкаете Ок, затем несколько раз кнопку Далее
4) На вкладке Выбор программных средств снова нажимаете Далее
5) В Мастер анализа сбоев выбираете Найти средства отладки для Windows в восстанавливаемой системе ...

Рисунок 2 из 3

6) На вкладке Загрузка определения автономного средства проверки системы Далее выбираете Нет, загрузить определения вручную позднее, затем Далее
7) На вкладке Дополнительные драйверы добавьте драйвера в образ, если необходимо, затем Далее
8) На вкладке Дополнительные файлы добавьте файлы в образ, если необходимо, затем Далее
9) На вкладке Создание образа загрузки укажите куда сохранить готовый образ ISO.
10) Оставляете галочку на пункте Записать готовый образ с помощью следующего устройства записи компакт-дисков, вставляете чистый диск в дисковод или убираете галочку с данного пункта, для дальнейшей записи на флэшку и нажимаете Далее.

Рисунок 3 из 3

На флэшку образ записывается через программу UltraISO так:
1) Открывате образ в UltraISO.
2) Выбираете Самозагрузка -> Записать образ жесткого диска...
3) Нажимаете Записать)

11) Перезагружаемся в ERD Commander.
12) Would you like to initialize network connectivity in the background?
Если собираетесь восстанавливать настройки сети (Интернет или Локальной) выбираете Yes жмете Enter, если не собираетесь, то выбираете No и жмете Enter
13) Would you like to remap the drive letters to match the mappings from the target operating system?
Для сопоставления букв дисков целевой операционной системе выбираете выбираете Yes и жмете Enter, в противоположном случае выбираете No и жмете Enter
14) Select a keyboard input method
Выбираете нужную раскладку, нажимаете Next
15) В окне для выбора операционной системы:

Для работы с восстановительными программами Windows, выбирате пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. И выбираете вашу операционную систему.

Для работы с системными файлами и папками(удаление, переименование или их замена) не выбираете никакую систему(должно сняться выделение с какой-либо системы). Для этого выберите пункт: Restore your computer using a system image that you created earlier, а затем снова выберите пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. и выделение само снимется.
16) Нажимаете Next.

10. Активация Windows 7 по телефону.

1) Пуск - правой кнопкой мыши по Компьютер - Свойства.
2) Изменить ключ продукта
3) Вводим ключ: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX .
4) Жмем Активировать.
5) Ждем. Затем выбираем Другие способы активации - Активация по телефону. Выбираете свой регион.
6) Звоним по бесплатному номеру (можно через Скайп) .
7) Девушка робот начнет перечислять варианты активации.
8) Жмем 1(активировать продукт майкрософт).
9) На вопрос на скольких компьютерах установлен продукт, нажимаем 1.
10) Затем вас попросят ввести код. Вводите, в ответ другая девушка-робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
11) Вносим цифры в окно активации.
12) Жмем Далее. Интернет, может быть отключен (без разницы). Windows 7 активирована.

11. Как быстро переключиться с одного монитора на другой или с монитора на проектор?
Данное действие осуществляется нажатием клавиш Win+P. Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей. Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

12. Как быстро открыть ещё одну копию приложения?

Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добиться кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

13. Как разместить любое окно Windows поверх других?

При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl+F12 и окно становится OnTop по отношению ко всем открытым.

14. Автоматическая очистка временных папок при выходе из Windows.

Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

1) Создайте командный файл сценария:

Инструкция:

1. Скопируйте код в любой текстовый редактор (например, Блокнот).
2. Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd
3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
PUSHD %TEMP% 2>Nul RD /S/Q "%TEMP%" POPD PUSHD %WinDir%\TEMP 2>Nul RD /S/Q "%WinDir%\TEMP" POPD
2) Скопируйте его для удобства в корневую папку диска С:
3) Запустите редактор групповых политик: Пуск -> Выполнить -> gpedit.msc или Win+R -> gpedit.msc
4) Откройте ветвь Конфигурация пользователя > Конфигурация Windows > Сценарии (вход/выход из системы).
5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами коммандного файла c:\tempdirclean.cmd
7) Нажмите Ок, затем снова Ок
Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

Внимание: Если по указанной выше схеме Вы добавите коммандный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера > Конфигурация Windows > Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

15. Блокирование прямого соединения с серверами проверки активации Windows.

Как бы Вы не пытались активировать Windows, если в активатор не встроено блокирование соединений с серверами проверки активации, то при появлении соединения с интернетом, Ваша Windows будет постоянно соединяться с данными серверами. При этом она передает сведения о вашей системе, об активации и используемом ключе.
Для блокировки соединения, выполните следующее в фаерволле: закройте порт 443 и адрес mpa.one.microsoft.com (IP=131.107.115.40).

Затем в файл hosts, находящийся в папке C:\Windows\System32\drivers\etc\ копируете указанные строчки:

127.0.0.1 mpa.microsoft.com
127.0.0.1 sls.microsoft.com
127.0.0.1 genuine.microsoft.com

Учитывая, что Microsoft знает о возможном блокировании её серверов проверки активации пользователями, то данное решение не защитит Вас от проверок активаций встроенных в обновления для Windows, но может продлить действие активации Вашей системы, если Вы не устанавливаете обновления.
Естественно, ничего этого не нужно делать, если у Вас честно купленная лицензия. Данное решение также позволит Вам высвободить интернет-траффик, если Вы активировали или планируете активировать Windows по телефону.


Установка

1. Как добавить новое устройство(драйвер) вручную?

1) Нажимаем Windows + R
2) В открывшемся окне набираем hdwwiz, жмём OK
3) В открывшемся окне, жмем Далее(Next)
4) В следующем окне выбираем Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list), жмём Далее(Next)
5) Выбираем в списке самую верхнюю строчку Показать все устройства(Show all devices), жмём Далее(Next)
6) В следующем окне нажимаем на кнопку Установить с диска(Install From Disk), в нижнем правом углу
7) В открывшемся окне нажимаем кнопку Обзор(Browse) и указываем путь к файлу драйвера (inf-файл), нажимаем Ok, а затем Далее(Next)
8) Подтверждаем желание установить нажатием Далее(Next)

2. Где в 7-ке хранятся скачанные с Winupdate обновления?

C:\Windows\SoftwareDistribution\Download. После установки эту папку можно смело очистить.

3. Как определить неизвестное устройство?

Узнаем VendorID(VEN) или HardwareID(DEV) устройства. В диспетчере устройств нажимаем у неизвестного устройства Свойства. Далее Сведения-Проматываем до ID оборудования.
Теперь идем на http://www.pcidatabase.com/. И вводим одно из найденных значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:
Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные
там тоже это указывается.

4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Здесь

5. Во время инсталяции, после копирования файлов, установщик (сама система) виснет.

Она не висит. Попробуйте выбрать другой монитор в персонализации - параметры дисплея. Это бывает, если у видеокарты два выхода. Такое состояние "зависания" может иметь разное время: от 2-3 минут до 25-30.

6. Как установить с флешки?

Вариант 1

1) Открываем образ Windows программой UltraISO, заходим в меню Самозагрузка - Записать образ Жесткого диска.
2) Вставляем флешку в USB-порт (она должна появиться вверху). Выбираем ее. Выбираем в пункте Метод записи USB-HDD и жмем Записать.
3) Выскакивает предупреждение об уничтожении информации, жмем Да. Ждем, когда завершится запись (от 5 до 20 минут).
4) Заходим в BIOS со вставленной флешкой и ставим загрузку в первую очередь с USB-HDD.
5) Если все сделали правильно, то после рестарта компьютера, если вставлена флешка с записанным образом, загрузка пойдет с нее безусловно, то есть без фразы "Press any key to boot from...".
6) Сама по себе установка мало чем отличается от установки с загрузочного DVD-диска, но есть один момент. Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, нужно снова идти в BIOS и ставить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку. Иначе, возможно, загрузка снова пойдет с флешки.

Вариант 2

Подготовка USB-флеш для будущей загрузки и установки Windows 7:

1) Берете USB-драйв размером не менее 4ГБ, подключаем его к USB-порту.
2) Запустите командную строку CMD.EXE с правами администратора
3) Запустите утилиту управления дисками diskpart, дождаться приглашения DISKPART>
4) Выполняете команду list disk (отображает список всех дисков ПК)
5) Ищете среди них наш диск USB, в нашем примере это Disk 1
6) Выполняете команду select disk # (где # – это номер нашего USB-драйва, полученного в предыдущей команде). Для нашего случая – select disk 1. Данная команда указывает diskpart, что все дальнейшие операции будут проводиться с данным диском.
7) Выполняете команду clean (стирает все данные и разделы на USB диске)
8) Выполняете команду create partition primary (создание нового раздела на диске)
9) Выполняете команду select partition 1 (выбор раздела, как дальнейшего объекта для манипуляций)
10) Выполняете команду active – делаем выбранный раздел активным
11) Выполняете команду format fs=NTFS – форматируем раздел в файловую систему NTFS
12) Выполняете команду assign – активируем процесс подключения устройства, получения букв для созданных разделов (если автостарт опция включена – всплывает окно, как будто вы только что подключили USB-драйв)
13) exit – выходим из diskpart в командную строку.
14) USB-драйв готов

Рисунок 1 из 2

Берем имеющийся у вас дистрибутив Windows 7, допустим, на DVD-диске, установленной в DVD-rom G:
В командной строке (не в diskpart !!! ) выполняем следующие команды:
1) G:
2) cd boot – переходим в каталог boot дистрибутива
3) Выполняете команду bootsect /nt60 I: – где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
4) Копируем на него со стандартного инсталляционного пакета все файлы. Можно использовать как системный Windows Explorer, так и команды xcopy или robocopy
Всё, USB-драйв готов. Загружаем ПК с полученного USB-драйва.

Рисунок 2 из 2

7. Интеграция LIP в дистрибутив Windows 7.

Вариант 1 вручную с помощью WAIK.

Для работы нам потребуются WAIK, GimageX

1) Скачайте и установите Windows® Automated Installation Kit (AIK) for Windows® 7
2) Перезагрузите компьютер.

Русификация установщика install.Wim
1) Создаёте на диске D: папки Lip, Mount и mWim
2) В папку Lip копируете lp_x86.cab и создаёте в ней подпапку uLip
3) При помощи GimageX экспортируете из папки \Sources\install.wim в папку D:\mWim образ Ultimate (индекс 5) как install.wim
4) Выполняете перезагрузку вашего ПК.
5) Монтируете файл D:\mWim\install.wim в папку D:\Mount выполнив в консоли команду:
(команды копируете, и вставляете в консоль по правому клику)
dism /Mount-Wim /WimFile:D:\mWim\install.wim /index:1 /MountDir:D:\Mount
6) Интегрируете LIP
dism /image:D:\Mount\ /Add-Package /PackagePath:D:\Lip\lp_x86.cab
7) Применяем все настройки для русского языка командой:
dism /image:D:\Mount /Set-AllIntl:ru-RU
Примеры запуска команд DISM:
dism /image:D:\Mount /Set-UILang:ru-RU (язык интерфейса системы)
dism /image:D:\Mount /Set-SysLocale:ru-RU (язык системной локали для не Unicode)
dism /image:D:\Mount /Set-UserLocale:ru-RU (денежный формат, формат времени)
dism /image:D:\Mount /Set-InputLocale:0419:00000419 (настройки ввода с клавиатуры)
dism /image:D:\Mount /Set-TimeZone:"Russian Standard Time" (временная зона)
8) Демонтируете образ с сохранением изменений:
dism /Unmount-Wim /MountDir:D:\Mount /commit
Демонтаж без сохранения:
dism /Unmount-Wim /MountDir:D:\Mount /discard
9) Заменяете файл sources\install.wim в дистрибутиве, файлом D:\mWim\install.wim 10) Там же правите текст файла sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
Русификация установщика Boot.Wim
1) Распаковываете lp.cab в папку D:\Lip\uLip
expand D:\Lip\lp_x86.cab -f:* D:\Lip\uLip
2) Очищаете папку D:\Mount
3) При помощи GimageX экспортируем из файла \Sources\boot.wim (индекс 2 !!!) в папку D:\mWim\ как boot.wim.
4) Монтируете файл boot.wim в папку D:\Mount
dism /Mount-Wim /WimFile:D:\mWim\boot.wim /index:1 /MountDir:D:\Mount
5) Добавляете в boot.wim русский язык:
xcopy D:\Lip\uLip\setup\* D:\Mount\ /cheryki
6) Добавляете в boot.wim файлы лицензий:
xcopy D:\Lip\uLip\sources\license\* D:\Mount\sources\license\ /cheryki
7) Правите текст файла D:\Mount\sources\lang.ini так же, как описано выше. 8) Демонтируете с сохранением файл boot.wim, папку uLip можно удалить.
dism /Unmount-Wim /MountDir:D:\Mount /commit
9) Заменяете файл sources\boot.wim в дистрибутиве, файлом D:\mWim\boot.wim

Вариант 2 с помощью интегратора

1) Скачайте Интегратор обновлений и языковых пакетов Windows 7
2) Запустите его
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дожидаетесь успешного выполнения и видите результат.

8. Установка Language Interface Pack (LIP).

1. Заходите в Control Panel >> раздел Clock, Language and Region.
2. В разделе Regional and Language Options >> Keyboards and Languages >> нажимаете Install or uninstall display languages.
3. В появившемся окне нажимаете Install Languages и указываете путь к папке с lp.cab
Можно просто набрать lpksetup в командной строке или в поле Выполнить и сразу переходите к третьему пункту.

9. Как не вводить ключ при инсталляции Windows?

Вариант 1

по материалам technet.microsoft.com:
EI.cfg is a Windows Setup-specific configuration file used to determine what edition and license will be used during installation. This file replaces PID.txt and is located on the product media under the \sources folder.
Добавьте в файл EI.cfg находящийся в папке \sources строку:
[PID]
Value="xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"

Вариант 2

Создаете файл Autounattend.xml со следующим текстом и кладете в \sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.

<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<UserData>
<AcceptEula>true</AcceptEula>
<FullName>MyName</FullName>
<Organization>Microsoft</Organization>
<ProductKey>
<Key>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
</UserData>
</component>
</settings>
</unattend>

10. Создание загрузочного образа ISO Windows 7 из VHD образа + интеграция LIP.

Для работы нам потребуются WAIK, GimageX (русская старая) или GimageX (английская новая), WinImage и ERD Commander для x86 или x64

Вариант 1

1) Скачайте и установите Windows® Automated Installation Kit (AIK) for Windows® 7
2) Перезагрузите компьютер.
3) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
4) Запускаете утилиту WinImage, открываете в ней извлеченный VHD-образ. В открывшемся диалоге щелкаем ОК. Выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем папку VHD. Чуть ниже выбираем Extract with pathname. Ждем завершения процесса распаковки. Если появится ошибка, просто нажимаем продолжить.

Рисунок 1 из 5

5) Распакуйте образ дистрибутива(ваш ISO) в папку C:\DVD
6) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
7) Распакуйте lp.cab в папку C:\Lip\uLip
expand C:\Lip\lp.cab -f:* C:\Lip\uLip
8) При помощи GimageX узнаете индекс Ultimate

Рисунок 2 из 5

9) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

Рисунок 3 из 5

10) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

Рисунок 4 из 5

11) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

Рисунок 5 из 5

12) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:
dism /Mount-Wim /WimFile:C:\mWim\install.wim /index:1 /MountDir:C:\Mount
14) Интегрируете LIP в install.wim
dism /image:C:\Mount\ /Add-Package /PackagePath:C:\Lip\lp.cab /ScratchDir:C:\Temp
15) Применяете все настройки для русского языка командой:
dism /image:C:\Mount /Set-AllIntl:ru-RU
16) Копируете через Micosoft Diagnostics and Recovery Toolset -> Explorer все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr 17) Демонтируете install.wim с сохранением изменений из C:\Mount:
dism /Unmount-Wim /MountDir:C:\Mount /commit
18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount
dism /Mount-Wim /WimFile:C:\mWim\boot.wim /index:1 /MountDir:C:\Mount
19) Добавляете в boot.wim русский язык:
xcopy C:\Lip\uLip\setup\* C:\Mount\ /cheryki
20) Добавляете в boot.wim файлы лицензий:
xcopy C:\Lip\uLip\sources\license\* C:\Mount\sources\license\ /cheryki
21) Правите текст файла (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\Mount\sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
22) Демонтируете boot.wim с сохранением изменений из C:\Mount:
dism /Unmount-Wim /MountDir:C:\Mount /commit
23) Правите текст файла (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
24) Заменяете файл (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
25) Заменяете файл (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
26) Перезагружаетесь в Windows
27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
29) Сохраняете в другое место или под другим именем.

Вариант 2

Создание английской Windows 7 (быстро и легко)

1) Идёте в меню Пуск, пишите diskmgmt.msc и нажимаете Enter
2) В верхнем меню нажимаете Действие -> Присоединить виртуальный жесткий диск.
3) Указываете его местонахождение, жмете ОК

Рисунок 1 из 2

4) Выбираете нужную вам букву для данного диска
5) Установите Windows AIK
6) Запустите программу GImageX и укажите в параметрах как на рисунке:

Source: - путь к виртуальному диску
Destination - путь куда будет сохранен готовый install.wim файл
Name - Имя образа (Windows 7 Ultimate)
Description - Описание образа (Windows 7 Ultimate)
Compression - Сжатие полученного install.wim файла (Maximum)

Рисунок 2 из 2

7) Открываете с помощью UltraISO образ дистрибутива Windows 7
8) Удаляете в папке \Sources файл install.wim
9) Добавляете созданный вами новый install.wim вместо старого.
10) Сохраняете образ под новым именем.
11) Записываете образ на флэшку или DVD.

11. Как установить Windows 7 из VHD-образа?

Вариант 1

Первое, что потребуется - это сам образ, извлеченный из RAR-архива. Второе - необходимо подготовить логический диск. Желательно выделить под установку чистый диск с размером 15-25Гб. И, наконец, потребуется утилита WinImage.

1) Запускаем утилиту WinImage, открываем в ней извлеченный VHD-образ. В открывшемся диалоге щелкаем ОК. Выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем предварительно подготовленный диск. Чуть ниже выбираем Extract with pathname. Ждем завершения процесса распаковки.

Рисунок 1 из 2

2) По завершении распаковки скачиваем утилиту EasyBCD. В окне приложения нажимаем Add/Remove Entries, затем внизу в поле Add entries выбираем имя для нашей новой ОС (к примеру, Windows 7 build XXXX), указываем тип (Windows Vista/Longhorn) и выбираем тот диск, в который мы извлекли содержимое образа. Щелкаем Add entry, а затем вверху щелкаем Save. В списке ОС теперь должно быть два пункта. Затем идем в раздел Change Settings и выбираем в качестве ОС, загружаемой по умолчанию, выбираем Windows 7 build XXXX. Нажимаем Save settings и перезагружаемся.

Рисунок 2 из 2

3) Наслаждаемся сборкой Windows 7 build XXXX с разлоченными функциями.

Вариант 2 как основная система.

1) Создаем папку VHD на любом разделе диска. Образ VHD, извлеченный из RAR-архива, открываем утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем папку VHD. Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
3) Выбираем Micosoft Diagnostics and Recovery Toolset -> Explorer и удаляем все файлы с диска C:\ (Диск с уже установленной Windows 7).Процесс может быть длительным, ждите.
4) Переносим все файлы из папки VHD на диск C:/. Папка VHD-> выделяем все файлы-> щелкаем правой кнопкой-> параметр move to-> выбираем диск С:\
5) Удаляем папку VHD.
6) Перезагружаемся снова в ERD. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
7) Радуемся установленной Windows 7.

Вариант 3 как вторая система

1) Образ VHD, извлеченный из RAR-архива, открываем утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем любой логический диск (необязательно форматированный, у меня например там фильмы лежат). Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
3) После выбора языка раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
4) После перезагрузки нам становиться доступен выбор из двух ОС. Нас интерисует вторая Windows 7 Ultimate(recovered). Выбираем её и ждем пока закончится настройка системы. В процессе, компьютер будет два раза перезагружен, незабываем после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered). Всё, VHD установлен.
5) Если загружаетесь через Windows 7 Ultimate(recovered), то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все).Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить -> compmgmt.msc).Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкаем правой кнопкой на диске, выбираем Change Drive Letter and Paths, нажимаем Add, выбираем любую букву для диска, ОК, диск доступен.

12. Повышение оценки производительности жесткого диска.
Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

13. Автоматическая установка OEM-информации.

Представляем вашему вниманию небольшой скрипт, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создаете файл Autounattend.xml со следующим текстом и кладете в \sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
Не забудьте заменить серийный ключ (product key) на ваш и назовите файл autounattend.xml.
<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0409:00000409</InputLocale>
<SystemLocale>en-US</SystemLocale>
<UILanguage>en-US</UILanguage>
<UILanguageFallback>en-US</UILanguageFallback>
<UserLocale>en-US</UserLocale>
</component>
<component name=”Microsoft-Windows-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<DiskConfiguration>
<Disk wcm:action=”add”>
<CreatePartitions>
<CreatePartition wcm:action=”add”>
<Extend>false</Extend>
<Type>Primary</Type>
<Order>1</Order>
<Size>40000</Size>
</CreatePartition>
</CreatePartitions>
<ModifyPartitions>
<ModifyPartition wcm:action=”add”>
<Order>1</Order>
<PartitionID>1</PartitionID>
<Format>NTFS</Format>
<Letter>C</Letter>
<Extend>true</Extend>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass=”oobeSystem”>
<component name=”Microsoft-Windows-Shell-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<OEMInformation>
<Logo>E:\oemlogo.bmp</Logo>
<Manufacturer>Fabrikam</Manufacturer>
<Model>Superfast1000</Model>
<SupportHours>Anytime, day or night</SupportHours>
<SupportPhone>1-800-SUPPORT</SupportPhone>
<SupportURL>www.fabrikam.com</SupportURL>
</OEMInformation>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>1</ProtectYourPC>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
<AutoLogon>
<Password>
<Value>Password</Value>
<PlainText>true</PlainText>
</Password>
<Username>Administrator</Username>
<Enabled>true</Enabled>
<LogonCount>5</LogonCount>
</AutoLogon>
<UserAccounts>
<AdministratorPassword>
<Value>Password</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>
</component>
</settings>
<cpi:offlineImage cpi:source=”wim:c:/documents%20and%20settings/vmux/desktop/sourceos/install.wim#Windows 7 ULTIMATE” xmlns:cpi=”urn:schemas-microsoft-com:cpi” />
</unattend>

Внимание!!!
Не используйте данный метод, если имеете важную информацию на жестком диске или же сделайте резервную копию системы. Дело в том, что файл ответов в данном совете стирает все разделы и логические диски при установке.
Если же вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам 9 и 14 данного раздела.

14. Автоматическая установка OEM-Logo.

Создаете файл Autounattend.xml со следующим текстом и кладете в \sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass=”windowsPE”>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OEMInformation>
<HelpCustomized>false</HelpCustomized>
<Manufacturer>Hewlett-Packard</Manufacturer>
<Model>Compaq Presario SR1610IL</Model>
<Logo>C:\Windows\Sytem32\oemlogo.bmp</Logo>
<SupportHours>9 AM to 9 PM (Mon-Sat)</SupportHours>
<SupportPhone>1-600-114772 (Toll free), 0124-2346992 (Toll Number)</SupportPhone>
<SupportURL>http://www.hp.com/in/support</SupportURL>
</OEMInformation>
</component>
</settings>
</unattend>
oemlogo.bmp
положите ваше лого в папку " \Sources\$OEM$\$$\System32\oemlogo.bmp"

15. Как установить LocalPack-RU?

Нужно в командной строке от имени Администратора выполнить команду: DISM /Online /Add-Package /PackagePath:<полный_путь_к_локал-паку>.CAB
Если не сработает - значит, нужно проделать почти то же самое, но загрузившись с установочного носителя.
Тогда /Online нужно будет заменить на /image:<буква_диска_с_установленной_системой>:.
Этим способом, кстати, MVE, можно установить лангпак на любую редакцию Windows 7
После установки нужно зайти в C:\Windows\Globalization\MCT\MCT-...\Theme

16. Автономная установка обновлений Windows.

1. Создаем батник (обычный текстовый документ, у которого потом меняем расширение на .bat) с именем, например Update, и с текстом:
@Echo Off
Title Installing Windows7 Updates
For %%F In (MSU\*.msu) Do Call :msin %%F
For %%A In (CAB\*.cab) Do Call :kbin %%A
Exit
:msin
Start /Wait %1 /quiet /norestart
:kbin
Start /Wait pkgmgr /ip /m:%1 /quiet /norestart
GoTo :EOF
Exit

2. Рядом с батником cоздаем папки CAB и MSU.
3. Кладём обновления .msu в папку MSU и .cab в папку CAB.
4. Запускаем Update.bat и ждем когда закроется окно командной строки. Готовый Update.bat

17. Как добавить подпись к драйверам?

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер нне устанавливается, ибо нет подписи Microsoft.На помощь пришли энтузиасты со своей программой Driver Signature Enforcement Overrider (DSEO). Она позволяет создавать свои собственные непроверенные свидетельства.

Таким образом, суть метода относительно проста. Требуется лишь включить тестовый режим в операционной системе и для всех драйверов устройств, не имеющих цифровой подписи, при помощи программы Driver Signature Enforcement Overrider получить свидетельства. Радует то, что при этом полностью отсутствуют риски привести операционную систему к нерабочему состоянию. Ведь от нас не требуется изменение загрузчика или других ее системных файлов. Используется штатный метод, специально предусмотренный Microsoft. Иногда на рабочем столе возле часов может появиться маленькая надпись, сообщающая версию билда операционной системы. (Надпись можно убрать используя рекомендации из совета 6 в "Тонких настройках")
Программа Driver Signature Enforcement Overrider работает как с 32-битными, так и с 64-битными операционными системами. Перед использованием необходимо обязательно отключить контроль учетных записей пользователей (UAC). Инсталляция программы не требуется, просто скачайте ее и запустите. Интерфейс предельно прост, и вся работа осуществляется в виде мастера.
Порядок действий:
1) Включите тестовый режим, установив переключатель в положение "Enable Test Mode". Кстати, сразу отмечу, что здесь же предусмотрено обратное действие "Disable Test Mode", отключающее тестовый режим.
2) Теперь нужно добавить подписи для непроверенных системных файлов. Для этого выберите "Sign a System File" и введите имя файла, включая полный путь. Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
3) Перезагрузите компьютер. Вот собственно и все. После перезапуска компьютера драйверы будут работать.

Скачать:
С оффициального сайта
С зеркала

18. Windows 7 Enterprice = Windows 7 Ultimate + активация без подмены загрузчика.
Для желающих установить версию Windows 7 Ultimate, но не считающих нужным использовать активаторы из-за возможности возникновения проблем с восстановлением загрузчика после применения активаторов, есть замечательное решение.

Активация через KMS-Server(автоскрипт от alexfire74):

1) Скачиваете архив Microsoft.Windows.7.Enterprice.RTM.x86-x64.eng-rus-wzt.zip с 4 торрентами для закачки Windows 7 Enterprice RTM Volume OEM.
2) Выбираете нужную вам версию и скачиваете её.
3) Устанавливаете её. Далее уже действуем в установленном Windows.
4) Нажимаете левой кнопкой мыши на часы на панели задач
5) Нажимаете Изменение настроек даты и времени
6) Запоминаете вашу разницу от Гринвича (Например: (UTC+02:00) или (UTC+03:00))
7) Скачайте Volume license - Activate.zip
8) Разархивируйте и запустите скрипт Volume license - Activate.cmd (требуется подключение к интернет не более 5 минут)
9) Выбираете версию Windows (в нашем случае Windows Enterprice)
10) Выбираете ваш UTC, в соответствии с пунктом 6 данного мануала
Если у вас UTC отличается от времени kms серверов, на время активации поставьте принудительно одно из предлагаеммых значений UTC
11) Дождитесь завершения активации, надпись об активации появляется через несколько минут после окончания работы скрипта.

19. Как сделать чтобы Windows при установке активировался автоматически?

Открываете образ с Windows 7, например программой UltraIso.
В папку sources копируете папку $OEM$, сохраняете образ и всё, при установке винда сама активируется.
Ссылка на готовую папку $OEM$


1. Как добавить новое устройство(драйвер) вручную?

1) Нажимаем Windows + R
2) В открывшемся окне набираем hdwwiz, жмём OK
3) В открывшемся окне, жмем Далее(Next)
4) В следующем окне выбираем Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list), жмём Далее(Next)
5) Выбираем в списке самую верхнюю строчку Показать все устройства(Show all devices), жмём Далее(Next)
6) В следующем окне нажимаем на кнопку Установить с диска(Install From Disk), в нижнем правом углу
7) В открывшемся окне нажимаем кнопку Обзор(Browse) и указываем путь к файлу драйвера (inf-файл), нажимаем Ok, а затем Далее(Next)
8) Подтверждаем желание установить нажатием Далее(Next)

Назад на страницу раздела Установка.


2. Где в 7-ке хранятся скачанные с Winupdate обновления?

C:\Windows\SoftwareDistribution\Download. После установки эту папку можно смело очистить.

Назад на страницу раздела Установка.


3. Как определить неизвестное устройство?

Узнаем VendorID(VEN) или HardwareID(DEV) устройства. В диспетчере устройств нажимаем у неизвестного устройства Свойства. Далее Сведения-Проматываем до ID оборудования.
Теперь идем на http://www.pcidatabase.com/. И вводим одно из найденных значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:
Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные
там тоже это указывается.

Назад на страницу раздела Установка.


4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Здесь

Назад на страницу раздела Установка.


5. Во время инсталяции, после копирования файлов, установщик (сама система) виснет.

Она не висит. Попробуйте выбрать другой монитор в персонализации - параметры дисплея. Это бывает, если у видеокарты два выхода. Такое состояние "зависания" может иметь разное время: от 2-3 минут до 25-30.

Назад на страницу раздела Установка.


6. Как установить с флешки?

Вариант 1

1) Открываем образ Windows программой UltraISO, заходим в меню Самозагрузка - Записать образ Жесткого диска.
2) Вставляем флешку в USB-порт (она должна появиться вверху). Выбираем ее. Выбираем в пункте Метод записи USB-HDD и жмем Записать.
3) Выскакивает предупреждение об уничтожении информации, жмем Да. Ждем, когда завершится запись (от 5 до 20 минут).
4) Заходим в BIOS со вставленной флешкой и ставим загрузку в первую очередь с USB-HDD.
5) Если все сделали правильно, то после рестарта компьютера, если вставлена флешка с записанным образом, загрузка пойдет с нее безусловно, то есть без фразы "Press any key to boot from...".
6) Сама по себе установка мало чем отличается от установки с загрузочного DVD-диска, но есть один момент. Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, нужно снова идти в BIOS и ставить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку. Иначе, возможно, загрузка снова пойдет с флешки.

Вариант 2

Подготовка USB-флеш для будущей загрузки и установки Windows 7:

1) Берете USB-драйв размером не менее 4ГБ, подключаем его к USB-порту.
2) Запустите командную строку CMD.EXE с правами администратора
3) Запустите утилиту управления дисками diskpart, дождаться приглашения DISKPART>
4) Выполняете команду list disk (отображает список всех дисков ПК)
5) Ищете среди них наш диск USB, в нашем примере это Disk 1
6) Выполняете команду select disk # (где # – это номер нашего USB-драйва, полученного в предыдущей команде). Для нашего случая – select disk 1. Данная команда указывает diskpart, что все дальнейшие операции будут проводиться с данным диском.
7) Выполняете команду clean (стирает все данные и разделы на USB диске)
8) Выполняете команду create partition primary (создание нового раздела на диске)
9) Выполняете команду select partition 1 (выбор раздела, как дальнейшего объекта для манипуляций)
10) Выполняете команду active – делаем выбранный раздел активным
11) Выполняете команду format fs=NTFS – форматируем раздел в файловую систему NTFS
12) Выполняете команду assign – активируем процесс подключения устройства, получения букв для созданных разделов (если автостарт опция включена – всплывает окно, как будто вы только что подключили USB-драйв)
13) exit – выходим из diskpart в командную строку.
14) USB-драйв готов

Берем имеющийся у вас дистрибутив Windows 7, допустим, на DVD-диске, установленной в DVD-rom G:
В командной строке (не в diskpart !!! ) выполняем следующие команды:
1) G:
2) cd boot – переходим в каталог boot дистрибутива
3) Выполняете команду bootsect /nt60 I: – где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
4) Копируем на него со стандартного инсталляционного пакета все файлы. Можно использовать как системный Windows Explorer, так и команды xcopy или robocopy
Всё, USB-драйв готов. Загружаем ПК с полученного USB-драйва.

Назад на страницу раздела Установка.


7. Интеграция LIP в дистрибутив Windows 7.

Вариант 1 вручную с помощью WAIK.

Для работы нам потребуются WAIK, GimageX

1) Скачайте и установите Windows® Automated Installation Kit (AIK) for Windows® 7
2) Перезагрузите компьютер.

Русификация установщика install.Wim
1) Создаёте на диске D: папки Lip, Mount и mWim
2) В папку Lip копируете lp_x86.cab и создаёте в ней подпапку uLip
3) При помощи GimageX экспортируете из папки \Sources\install.wim в папку D:\mWim образ Ultimate (индекс 5) как install.wim
4) Выполняете перезагрузку вашего ПК.
5) Монтируете файл D:\mWim\install.wim в папку D:\Mount выполнив в консоли команду:
(команды копируете, и вставляете в консоль по правому клику)
dism /Mount-Wim /WimFile:D:\mWim\install.wim /index:1 /MountDir:D:\Mount
6) Интегрируете LIP
dism /image:D:\Mount\ /Add-Package /PackagePath:D:\Lip\lp_x86.cab
7) Применяем все настройки для русского языка командой:
dism /image:D:\Mount /Set-AllIntl:ru-RU
Примеры запуска команд DISM:
dism /image:D:\Mount /Set-UILang:ru-RU (язык интерфейса системы)
dism /image:D:\Mount /Set-SysLocale:ru-RU (язык системной локали для не Unicode)
dism /image:D:\Mount /Set-UserLocale:ru-RU (денежный формат, формат времени)
dism /image:D:\Mount /Set-InputLocale:0419:00000419 (настройки ввода с клавиатуры)
dism /image:D:\Mount /Set-TimeZone:"Russian Standard Time" (временная зона)
8) Демонтируете образ с сохранением изменений:
dism /Unmount-Wim /MountDir:D:\Mount /commit
Демонтаж без сохранения:
dism /Unmount-Wim /MountDir:D:\Mount /discard
9) Заменяете файл sources\install.wim в дистрибутиве, файлом D:\mWim\install.wim 10) Там же правите текст файла sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
Русификация установщика Boot.Wim
1) Распаковываете lp.cab в папку D:\Lip\uLip
expand D:\Lip\lp_x86.cab -f:* D:\Lip\uLip
2) Очищаете папку D:\Mount
3) При помощи GimageX экспортируем из файла \Sources\boot.wim (индекс 2 !!!) в папку D:\mWim\ как boot.wim.
4) Монтируете файл boot.wim в папку D:\Mount
dism /Mount-Wim /WimFile:D:\mWim\boot.wim /index:1 /MountDir:D:\Mount
5) Добавляете в boot.wim русский язык:
xcopy D:\Lip\uLip\setup\* D:\Mount\ /cheryki
6) Добавляете в boot.wim файлы лицензий:
xcopy D:\Lip\uLip\sources\license\* D:\Mount\sources\license\ /cheryki
7) Правите текст файла D:\Mount\sources\lang.ini так же, как описано выше. 8) Демонтируете с сохранением файл boot.wim, папку uLip можно удалить.
dism /Unmount-Wim /MountDir:D:\Mount /commit
9) Заменяете файл sources\boot.wim в дистрибутиве, файлом D:\mWim\boot.wim

Вариант 2 с помощью интегратора

1) Скачайте Интегратор обновлений и языковых пакетов Windows 7
2) Запустите его
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дожидаетесь успешного выполнения и видите результат.

Назад на страницу раздела Установка.


8. Установка Language Interface Pack (LIP).

1. Заходите в Control Panel >> раздел Clock, Language and Region.
2. В разделе Regional and Language Options >> Keyboards and Languages >> нажимаете Install or uninstall display languages.
3. В появившемся окне нажимаете Install Languages и указываете путь к папке с lp.cab
Можно просто набрать lpksetup в командной строке или в поле Выполнить и сразу переходите к третьему пункту.

Назад на страницу раздела Установка.


9. Как не вводить ключ при инсталляции Windows?

Вариант 1

по материалам technet.microsoft.com:
EI.cfg is a Windows Setup-specific configuration file used to determine what edition and license will be used during installation. This file replaces PID.txt and is located on the product media under the \sources folder.
Добавьте в файл EI.cfg находящийся в папке \sources строку:
[PID]
Value="xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"

Вариант 2

Создаете файл Autounattend.xml со следующим текстом и кладете в \sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<UserData>
<AcceptEula>true</AcceptEula>
<FullName>MyName</FullName>
<Organization>Microsoft</Organization>
<ProductKey>
<Key>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
</UserData>
</component>
</settings>
</unattend>

Назад на страницу раздела Установка.


10. Создание загрузочного образа ISO Windows 7 из VHD образа + интеграция LIP.

Для работы нам потребуются WAIK, GimageX (русская старая) или GimageX (английская новая), WinImage и ERD Commander для x86 или x64

Вариант 1

1) Скачайте и установите Windows® Automated Installation Kit (AIK) for Windows® 7
2) Перезагрузите компьютер.
3) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
4) Запускаете утилиту WinImage, открываете в ней извлеченный VHD-образ. В открывшемся диалоге щелкаем ОК. Выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем папку VHD. Чуть ниже выбираем Extract with pathname. Ждем завершения процесса распаковки. Если появится ошибка, просто нажимаем продолжить.

5) Распакуйте образ дистрибутива(ваш ISO) в папку C:\DVD
6) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
7) Распакуйте lp.cab в папку C:\Lip\uLip
expand C:\Lip\lp.cab -f:* C:\Lip\uLip
8) При помощи GimageX узнаете индекс Ultimate

9) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

10) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

11) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

12) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:
dism /Mount-Wim /WimFile:C:\mWim\install.wim /index:1 /MountDir:C:\Mount
14) Интегрируете LIP в install.wim
dism /image:C:\Mount\ /Add-Package /PackagePath:C:\Lip\lp.cab /ScratchDir:C:\Temp
15) Применяете все настройки для русского языка командой:
dism /image:C:\Mount /Set-AllIntl:ru-RU
16) Копируете через Micosoft Diagnostics and Recovery Toolset -> Explorer все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr 17) Демонтируете install.wim с сохранением изменений из C:\Mount:
dism /Unmount-Wim /MountDir:C:\Mount /commit
18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount
dism /Mount-Wim /WimFile:C:\mWim\boot.wim /index:1 /MountDir:C:\Mount
19) Добавляете в boot.wim русский язык:
xcopy C:\Lip\uLip\setup\* C:\Mount\ /cheryki
20) Добавляете в boot.wim файлы лицензий:
xcopy C:\Lip\uLip\sources\license\* C:\Mount\sources\license\ /cheryki
21) Правите текст файла (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\Mount\sources\lang.ini
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
22) Демонтируете boot.wim с сохранением изменений из C:\Mount:
dism /Unmount-Wim /MountDir:C:\Mount /commit
23) Правите текст файла (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:
[Available UI Languages]
ru-RU = 2
en-US = 3

[Fallback Languages]
ru-RU = ru-ru
en-US = en-us
24) Заменяете файл (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
25) Заменяете файл (через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
26) Перезагружаетесь в Windows
27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
29) Сохраняете в другое место или под другим именем.

Вариант 2

Создание английской Windows 7 (быстро и легко)

1) Идёте в меню Пуск, пишите diskmgmt.msc и нажимаете Enter
2) В верхнем меню нажимаете Действие -> Присоединить виртуальный жесткий диск.
3) Указываете его местонахождение, жмете ОК

4) Выбираете нужную вам букву для данного диска
5) Установите Windows AIK
6) Запустите программу GImageX и укажите в параметрах как на рисунке:

Source: - путь к виртуальному диску
Destination - путь куда будет сохранен готовый install.wim файл
Name - Имя образа (Windows 7 Ultimate)
Description - Описание образа (Windows 7 Ultimate)
Compression - Сжатие полученного install.wim файла (Maximum)

7) Открываете с помощью UltraISO образ дистрибутива Windows 7
8) Удаляете в папке \Sources файл install.wim
9) Добавляете созданный вами новый install.wim вместо старого.
10) Сохраняете образ под новым именем.
11) Записываете образ на флэшку или DVD.

Назад на страницу раздела Установка.


11. Как установить Windows 7 из VHD-образа?

Вариант 1

Первое, что потребуется - это сам образ, извлеченный из RAR-архива. Второе - необходимо подготовить логический диск. Желательно выделить под установку чистый диск с размером 15-25Гб. И, наконец, потребуется утилита WinImage.

1) Запускаем утилиту WinImage, открываем в ней извлеченный VHD-образ. В открывшемся диалоге щелкаем ОК. Выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем предварительно подготовленный диск. Чуть ниже выбираем Extract with pathname. Ждем завершения процесса распаковки.

2) По завершении распаковки скачиваем утилиту EasyBCD. В окне приложения нажимаем Add/Remove Entries, затем внизу в поле Add entries выбираем имя для нашей новой ОС (к примеру, Windows 7 build XXXX), указываем тип (Windows Vista/Longhorn) и выбираем тот диск, в который мы извлекли содержимое образа. Щелкаем Add entry, а затем вверху щелкаем Save. В списке ОС теперь должно быть два пункта. Затем идем в раздел Change Settings и выбираем в качестве ОС, загружаемой по умолчанию, выбираем Windows 7 build XXXX. Нажимаем Save settings и перезагружаемся.

3) Наслаждаемся сборкой Windows 7 build XXXX с разлоченными функциями.

Вариант 2 как основная система.

1) Создаем папку VHD на любом разделе диска. Образ VHD, извлеченный из RAR-архива, открываем утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем папку VHD. Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
3) Выбираем Micosoft Diagnostics and Recovery Toolset -> Explorer и удаляем все файлы с диска C:\ (Диск с уже установленной Windows 7).Процесс может быть длительным, ждите.
4) Переносим все файлы из папки VHD на диск C:/. Папка VHD-> выделяем все файлы-> щелкаем правой кнопкой-> параметр move to-> выбираем диск С:\
5) Удаляем папку VHD.
6) Перезагружаемся снова в ERD. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
7) Радуемся установленной Windows 7.

Вариант 3 как вторая система

1) Образ VHD, извлеченный из RAR-архива, открываем утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем любой логический диск (необязательно форматированный, у меня например там фильмы лежат). Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
3) После выбора языка раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
4) После перезагрузки нам становиться доступен выбор из двух ОС. Нас интерисует вторая Windows 7 Ultimate(recovered). Выбираем её и ждем пока закончится настройка системы. В процессе, компьютер будет два раза перезагружен, незабываем после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered). Всё, VHD установлен.
5) Если загружаетесь через Windows 7 Ultimate(recovered), то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все).Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить -> compmgmt.msc).Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкаем правой кнопкой на диске, выбираем Change Drive Letter and Paths, нажимаем Add, выбираем любую букву для диска, ОК, диск доступен.

Назад на страницу раздела Установка.


12. Повышение оценки производительности жесткого диска.

Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

Назад на страницу раздела Установка.


13. Автоматическая установка OEM-информации.

Представляем вашему вниманию небольшой скрипт, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создаете файл Autounattend.xml со следующим текстом и кладете в \sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
Не забудьте заменить серийный ключ (product key) на ваш и назовите файл autounattend.xml.
<?xml version=”1.0? encoding=”utf-8??>
<unattend xmlns=”urn:schemas-microsoft-com:unattend”>
<settings pass=”windowsPE”>
<component name=”Microsoft-Windows-International-Core-WinPE” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0409:00000409</InputLocale>
<SystemLocale>en-US</SystemLocale>
<UILanguage>en-US</UILanguage>
<UILanguageFallback>en-US</UILanguageFallback>
<UserLocale>en-US</UserLocale>
</component>
<component name=”Microsoft-Windows-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<DiskConfiguration>
<Disk wcm:action=”add”>
<CreatePartitions>
<CreatePartition wcm:action=”add”>
<Extend>false</Extend>
<Type>Primary</Type>
<Order>1</Order>
<Size>40000</Size>
</CreatePartition>
</CreatePartitions>
<ModifyPartitions>
<ModifyPartition wcm:action=”add”>
<Order>1</Order>
<PartitionID>1</PartitionID>
<Format>NTFS</Format>
<Letter>C</Letter>
<Extend>true</Extend>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass=”oobeSystem”>
<component name=”Microsoft-Windows-Shell-Setup” processorArchitecture=”x86? publicKeyToken=”31bf3856ad364e35? language=”neutral” versionScope=”nonSxS” xmlns:wcm=”http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>
<OEMInformation>
<Logo>E:\oemlogo.bmp</Logo>
<Manufacturer>Fabrikam</Manufacturer>
<Model>Superfast1000</Model>
<SupportHours>Anytime, day or night</SupportHours>
<SupportPhone>1-800-SUPPORT</SupportPhone>
<SupportURL>www.fabrikam.com</SupportURL>
</OEMInformation>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>1</ProtectYourPC>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
<AutoLogon>
<Password>
<Value>Password</Value>
<PlainText>true</PlainText>
</Password>
<Username>Administrator</Username>
<Enabled>true</Enabled>
<LogonCount>5</LogonCount>
</AutoLogon>
<UserAccounts>
<AdministratorPassword>
<Value>Password</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>
</component>
</settings>
<cpi:offlineImage cpi:source=”wim:c:/documents%20and%20settings/vmux/desktop/sourceos/install.wim#Windows 7 ULTIMATE” xmlns:cpi=”urn:schemas-microsoft-com:cpi” />
</unattend>

Внимание!!!
Не используйте данный метод, если имеете важную информацию на жестком диске или же сделайте резервную копию системы. Дело в том, что файл ответов в данном совете стирает все разделы и логические диски при установке.
Если же вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам 9 и 14 данного раздела.

Назад на страницу раздела Установка.


14. Автоматическая установка OEM-Logo.

Создаете файл Autounattend.xml со следующим текстом и кладете в \sources
Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass=”windowsPE”>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OEMInformation>
<HelpCustomized>false</HelpCustomized>
<Manufacturer>Hewlett-Packard</Manufacturer>
<Model>Compaq Presario SR1610IL</Model>
<Logo>C:\Windows\Sytem32\oemlogo.bmp</Logo>
<SupportHours>9 AM to 9 PM (Mon-Sat)</SupportHours>
<SupportPhone>1-600-114772 (Toll free), 0124-2346992 (Toll Number)</SupportPhone>
<SupportURL>http://www.hp.com/in/support</SupportURL>
</OEMInformation>
</component>
</settings>
</unattend>
oemlogo.bmp
положите ваше лого в папку " \Sources\$OEM$\$$\System32\oemlogo.bmp"

Назад на страницу раздела Установка.


15. Как установить LocalPack-RU?

Нужно в командной строке от имени Администратора выполнить команду: DISM /Online /Add-Package /PackagePath:<полный_путь_к_локал-паку>.CAB
Если не сработает - значит, нужно проделать почти то же самое, но загрузившись с установочного носителя.
Тогда /Online нужно будет заменить на /image:<буква_диска_с_установленной_системой>:.
Этим способом, кстати, MVE, можно установить лангпак на любую редакцию Windows 7
После установки нужно зайти в C:\Windows\Globalization\MCT\MCT-...\Theme

Назад на страницу раздела Установка.


16. Автономная установка обновлений Windows.

1. Создаем батник (обычный текстовый документ, у которого потом меняем расширение на .bat) с именем, например Update, и с текстом:
@Echo Off
Title Installing Windows7 Updates
For %%F In (MSU\*.msu) Do Call :msin %%F
For %%A In (CAB\*.cab) Do Call :kbin %%A
Exit
:msin
Start /Wait %1 /quiet /norestart
:kbin
Start /Wait pkgmgr /ip /m:%1 /quiet /norestart
GoTo :EOF
Exit

2. Рядом с батником cоздаем папки CAB и MSU.
3. Кладём обновления .msu в папку MSU и .cab в папку CAB.
4. Запускаем Update.bat и ждем когда закроется окно командной строки. Готовый Update.bat

Назад на страницу раздела Установка.


17. Как добавить подпись к драйверам?

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер нне устанавливается, ибо нет подписи Microsoft.На помощь пришли энтузиасты со своей программой Driver Signature Enforcement Overrider (DSEO). Она позволяет создавать свои собственные непроверенные свидетельства.

Таким образом, суть метода относительно проста. Требуется лишь включить тестовый режим в операционной системе и для всех драйверов устройств, не имеющих цифровой подписи, при помощи программы Driver Signature Enforcement Overrider получить свидетельства. Радует то, что при этом полностью отсутствуют риски привести операционную систему к нерабочему состоянию. Ведь от нас не требуется изменение загрузчика или других ее системных файлов. Используется штатный метод, специально предусмотренный Microsoft. Иногда на рабочем столе возле часов может появиться маленькая надпись, сообщающая версию билда операционной системы. (Надпись можно убрать используя рекомендации из совета 6 в "Тонких настройках")
Программа Driver Signature Enforcement Overrider работает как с 32-битными, так и с 64-битными операционными системами. Перед использованием необходимо обязательно отключить контроль учетных записей пользователей (UAC). Инсталляция программы не требуется, просто скачайте ее и запустите. Интерфейс предельно прост, и вся работа осуществляется в виде мастера.
Порядок действий:
1) Включите тестовый режим, установив переключатель в положение "Enable Test Mode". Кстати, сразу отмечу, что здесь же предусмотрено обратное действие "Disable Test Mode", отключающее тестовый режим.
2) Теперь нужно добавить подписи для непроверенных системных файлов. Для этого выберите "Sign a System File" и введите имя файла, включая полный путь. Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
3) Перезагрузите компьютер.
Вот собственно и все. После перезапуска компьютера драйверы будут работать.

Скачать:
С оффициального сайта
С зеркала

Назад на страницу раздела Установка.


18. Windows 7 Enterprice = Windows 7 Ultimate + активация без подмены загрузчика.

Для желающих установить версию Windows 7 Ultimate, но не считающих нужным использовать активаторы из-за возможности возникновения проблем с восстановлением загрузчика после применения активаторов, есть замечательное решение.

Активация через KMS-Server:

1) Скачиваете архив Microsoft.Windows.7.Enterprice.RTM.x86-x64.eng-rus-wzt.zip с 4 торрентами для закачки Windows 7 Enterprice RTM Volume OEM.
2) Выбираете нужную вам версию и скачиваете её.
3) Устанавливаете её. Далее уже действуем в установленном Windows.
4) Нажимаете левой кнопкой мыши на часы на панели задач
5) Нажимаете Изменение настроек даты и времени
6) Запоминаете вашу разницу от Гринвича (Например: (UTC+02:00) или (UTC+03:00))
7) Скачайте Volume license - Activate.zip
8) Разархивируйте и запустите скрипт Volume license - Activate.cmd (требуется подключение к интернет не более 5 минут)
9) Выбираете версию Windows (в нашем случае Windows Enterprice)
10) Выбираете ваш UTC, в соответствии с пунктом 6 данного мануала
Если у вас UTC отличается от времени kms серверов, на время активации поставьте принудительно одно из предлагаеммых значений UTC
11) Дождитесь завершения активации, надпись об активации появляется через несколько минут после окончания работы скрипта.

Назад на страницу раздела Установка.


19. Как сделать чтобы Windows при установке активировался автоматически?

Открываете образ с Windows 7, например программой UltraIso.
В папку sources копируете папку $OEM$, сохраняете образ и всё, при установке винда сама активируется.
Ссылка на готовую папку $OEM$

Назад на страницу раздела Установка.


Настройки

1. Чтобы сохранялись настройки программ (сайдбара, расположение значков на панели и т.д.).

Hужно установить пароль на учетную запись администратора и работать из под нее.

2. Отображение (скрытие) значков в области уведомлений.

Отобразить значок в области уведомлений можно гораздо проще без использования кнопки Настроить: просто перетащите нужный значок из скрытой области в область уведомлений. Чтобы скрыть значок, перетащите его в скрытую область.

3. Как изменить параметры загрузки, где в Windows 7 файл boot.ini?

Начиная с Windows Vista такого файла больше нет, однако вы можете изменить все необходимые вам параметры
Панель управления > Администрирование > Конфигурация системы > Загрузка

4. Увеличение скорости загрузки ОС для многоядерных процессоров.

Измените значение здесь.
Панель управления > Администрирование > Конфигурация системы > Загрузка > Дополнительные параметры > Число процессоров > 2(или 4)
(По умолчанию 1).

5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны. К примеру, чтобы изменить временную зону на время по Гринвичу, нужно использовать следующую команду:
tzutil /s “gmt standard time”
» “tzutil /g” покажет текущие установки временной зоны;
» “tzutil /l” выводит список всех возможных временных зон;
» “tzutil /?” выводит справку по работе утилиты.

6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны
Пуск => Все программы=> Стандартные => "Ножницы" => Правый клик мыши=> Свойства
В Свойствах, в поле Быстрый вызов пытаемся набрать любую комбинацию клавиш. Заметим что нам сразу выдаются первые две клавишы Ctrl+Alt+, выбор третьей клавишы за вами, как вам удобнее. Например, Ctrl+Alt+S.

7. Отключение (включение) неиспользуемых компонентов Windows.
В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева "Включение или отключение компонентов Windows"
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но вами не используются

8. Как отменить (изменить) ассоциирование типов файлов с определенными программами?

Если вы выбрали неправильную программу в диалоговом окне "Открыть с помощью" и установили параметр "Использовать выбранную программу для всех файлов такого типа". А также если программа удалилась некорректно, оставив в системе ассоциации на себя с поддерживаемыми ею типами файлов. Есть несколько способов это исправить.

Способ 1: Попробуйте ассоциировать нужные файлы с нужными программами используя все тот же диалог "Открыть с помощью"
Способ 2: Панель управления\Все элементы панели управления\Программы по умолчанию\Задать сопоставления "Изменить программу"
Способ 3: Искать в реестре в ветке [HKEY_CLASSES_ROOT]
Способ 4: Используйте утилиту Unassociate File Types, которая позволяет как убрать ассоциацию, так и удалить тип файла из реестра.

9. Как отключить всплывающие подсказки?

Отключить всплывающие подсказки можно используя редактор групповой политики.
Нажмите Пуск, в поле Начать поиск напишите gpedit.msc и нажмите ОК.
Перейдите в раздел Конфигурация пользователя - Административные шаблоны - Меню Пуск и Панель задач.
Откройте параметр "Удалить всплывающие подсказки для элементов главного меню", выберите пункт Включен и нажмите ОК

10. Изменение функции кнопки питания на корпусе вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии «Завершение работы». Если вы перезагружаете компьютер по несколько раз в день, вам наверное было бы удобнее переключить кнопку выключения в состояние «Перезагрузка». Для этого выполняем правый клик по кнопке Пуск, выбираем пункт меню Свойства и переключаем “Действие кнопки питания” в состояние “Перезагрузка”. Также вы можете выбрать функции “Блокировка”, “Смена пользователя” и “Завершение сеанса”.

11. Как быстро перейти к часто используемой папке?

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки проводника.

12. Как изменить строку в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР"?

Запустите cmd.exe от имени администратора, и пишете следующую строчку:
bcdedit /set {ntldr} description "Microsoft Windows XP Professional SP3"
bcdedit /set {current} description "Microsoft Windows 7 Ultimate x64"


1. Чтобы сохранялись настройки программ (сайдбара, расположение значков на панели и т.д.).

Hужно установить пароль на учетную запись администратора и работать из под нее.

Назад на страницу раздела Настройки.


2. Отображение (скрытие) значков в области уведомлений.

Отобразить значок в области уведомлений можно гораздо проще без использования кнопки Настроить: просто перетащите нужный значок из скрытой области в область уведомлений. Чтобы скрыть значок, перетащите его в скрытую область.

Назад на страницу раздела Настройки.


3. Как изменить параметры загрузки, где в Windows 7 файл boot.ini?

Начиная с Windows Vista такого файла больше нет, однако вы можете изменить все необходимые вам параметры
Панель управления > Администрирование > Конфигурация системы > Загрузка

Назад на страницу раздела Настройки.


4. Увеличение скорости загрузки ОС для многоядерных процессоров.

Измените значение здесь.
Панель управления > Администрирование > Конфигурация системы > Загрузка > Дополнительные параметры > Число процессоров > 2(или 4)
(По умолчанию 1).

Назад на страницу раздела Настройки.


5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны. К примеру, чтобы изменить временную зону на время по Гринвичу, нужно использовать следующую команду:
tzutil /s “gmt standard time”
» “tzutil /g” покажет текущие установки временной зоны;
» “tzutil /l” выводит список всех возможных временных зон;
» “tzutil /?” выводит справку по работе утилиты.

Назад на страницу раздела Настройки.


6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны
Пуск => Все программы=> Стандартные => "Ножницы" => Правый клик мыши=> Свойства
В Свойствах, в поле Быстрый вызов пытаемся набрать любую комбинацию клавиш. Заметим что нам сразу выдаются первые две клавишы Ctrl+Alt+, выбор третьей клавишы за вами, как вам удобнее. Например, Ctrl+Alt+S.

Назад на страницу раздела Настройки.


7. Отключение(включение) неиспользуемых компонентов Windows.

В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева "Включение или отключение компонентов Windows"
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но вами не используются

Назад на страницу раздела Настройки.


8. Как отменить (изменить) ассоциирование типов файлов с определенными программами?

Если вы выбрали неправильную программу в диалоговом окне "Открыть с помощью" и установили параметр "Использовать выбранную программу для всех файлов такого типа". А также если программа удалилась некорректно, оставив в системе ассоциации на себя с поддерживаемыми ею типами файлов. Есть несколько способов это исправить.

Способ 1: Попробуйте ассоциировать нужные файлы с нужными программами используя все тот же диалог "Открыть с помощью"
Способ 2: Панель управления\Все элементы панели управления\Программы по умолчанию\Задать сопоставления "Изменить программу"
Способ 3: Искать в реестре в ветке [HKEY_CLASSES_ROOT]
Способ 4: Используйте утилиту Unassociate File Types, которая позволяет как убрать ассоциацию, так и удалить тип файла из реестра.

Назад на страницу раздела Настройки.


9. Как отключить всплывающие подсказки?

Отключить всплывающие подсказки можно используя редактор групповой политики.
Нажмите Пуск, в поле Начать поиск напишите gpedit.msc и нажмите ОК.
Перейдите в раздел Конфигурация пользователя - Административные шаблоны - Меню Пуск и Панель задач.
Откройте параметр "Удалить всплывающие подсказки для элементов главного меню", выберите пункт Включен и нажмите ОК

Назад на страницу раздела Настройки.


10. Изменение функции кнопки питания на корпусе вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии «Завершение работы». Если вы перезагружаете компьютер по несколько раз в день, вам наверное было бы удобнее переключить кнопку выключения в состояние «Перезагрузка». Для этого выполняем правый клик по кнопке Пуск, выбираем пункт меню Свойства и переключаем “Действие кнопки питания” в состояние “Перезагрузка”. Также вы можете выбрать функции “Блокировка”, “Смена пользователя” и “Завершение сеанса”.

Назад на страницу раздела Настройки.


11. Как быстро перейти к часто используемой папке?

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки проводника.

Назад на страницу раздела Настройки.


12. Как изменить строку в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР"?

Запустите cmd.exe от имени администратора, и пишете следующую строчку:
bcdedit /set {ntldr} description "Microsoft Windows XP Professional SP3"
bcdedit /set {current} description "Microsoft Windows 7 Ultimate x64"

Назад на страницу раздела Настройки.


Администрирование

1. Активировал учетную запись администратора, но некоторые папки\файлы все равно не удаляются.

Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду
net user Администратор /active:yes
В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:
net user Administrator /active:yes
Команду необходимо выполнять в командной строке с повышенными правами пользователя. Для этого нажмите кнопку Пуск, выберите пункт Стандартные, щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора.

2. Как разрешить запуск "Диспетчера задач"?

Запустите редактор системных политик: Пуск > Выполнить > gpedit.msc.
Слева в дереве политик выберите Конфигурация пользователя > Административные шаблоны > Система > Возможности Ctrl+Alt+Del.
В правом окне двойным щелчком откройте свойства политики Удалить диспетчер задач, выберите Отключен и нажмите ОК.
Изменения вступят в действие после перезагрузки.

3. Как добавить свою иконку в список рисунков учетных записей?

По умолчанию рисунки учетных записей располагаются в следующей папке:
C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

4. Автоматический вход в систему(авто-ввод пароля).

Если вы хотите ускорить процесс загрузки Windows 7, то вы можете настроить автоматический вход в систему. Эта возможность создана для тех ситуаций, когда компьютером пользуется один человек. Настроив автоматический вход, вам не нужно будет вводить пароль каждый раз, когда загружается ваша операционная система.
Чтобы настроить автоматический вход в Windows 7, сделайте следующее:

1. Нажмите на клавиатуре Win+R (или пункт Run в меню Start).
2. В появившемся окне введите “control userpasswords2” (без кавычек) и нажмите Ввод.
3. В окне User Accounts на закладке Users выделите свою учетную запись и уберите галочку с “Users must enter a user name and password to use this computer”.
4. Нажмите Apply.
5. В открывшемся окне Automatically Log On будут три поля - User name, Password и Confirm Password. Введите свой пароль в поле Password и еще раз - в поле Confirm Password.

Всё. Со следующей перезагрузки системы вам больше не нужно будет вводить свой пароль. Вход в Windows будет происходить автоматически.
(Возможен побочный эффект: после перезагрузки панель "Quick Launch" не сохраняется - после рестарта её нет.)

5. Как ограничить пользователей в наборе программ, которые они могут запускать?

Контроль за приложениями сводится к настройке правил. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные определенным издателем (например, Microsoft). Запустите GPEDIT.MSC и перейдите к функции AppLocker() через Computer Configuration > Windows Settings > Security Settings > Application Control Policies или Конфигурация компьютера > Конфигурация Windows > Параметры безопасности > Политики управления приложениями, чтобы посмотреть, как это работает.

6. Как быстро запустить программу с правами администратора?

Удерживайте Ctrl+Shift и нажмите на иконку приложения (у вашей учетной записи, конечно, должны быть соответствующие права).

7. Как убрать значки запрета доступа на папках?

Для этого надо в свойствах назначения прав папкам и файлам, добавить пользователя Администратор, и дать ему все разрешения, после чего значек с папки или файла будет убран.

8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer или Sysinternals Autoruns, и вовсе лучше всегда запускать с повышенными привилегиями.
Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl+Shift+Enter.
3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

1) Запускаете планировщик заданий (Пуск ---> Все программы ---> Стандартные ---> Служебные ---> Планировщик заданий)
2) Нажимаете "Создать задачу"
3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
5) Указываете путь к нужному приложению и нажимаете "Открыть"
6) Нажимаете "ОК", затем снова "ОК"
7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" ---> "Ярлык")
8) В поле Расположение объекта введите:
schtasks /run /tn mytask_admin
где mytask_admin - имя созданной нами задачи. Если в имеми содержаться робелы, обязательно укажите его в кавычках.
9) Введите имя ярлыка и нажмите Готово

Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

Скачать можно здесь или здесь


1. Активировал учетную запись администратора, но некоторые папки\файлы все равно не удаляются.

Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду

net user Администратор /active:yes
В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:
net user Administrator /active:yes
Команду необходимо выполнять в командной строке с повышенными правами пользователя. Для этого нажмите кнопку Пуск, выберите пункт Стандартные, щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора.

Назад на страницу раздела Администрирование.


2. Как разрешить запуск "Диспетчера задач"?

Запустите редактор системных политик: Пуск > Выполнить > gpedit.msc.
Слева в дереве политик выберите Конфигурация пользователя > Административные шаблоны > Система > Возможности Ctrl+Alt+Del.
В правом окне двойным щелчком откройте свойства политики Удалить диспетчер задач, выберите Отключен и нажмите ОК.
Изменения вступят в действие после перезагрузки.

Назад на страницу раздела Администрирование.


3. Как добавить свою иконку в список рисунков учетных записей?

По умолчанию рисунки учетных записей располагаются в следующей папке:
C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

Назад на страницу раздела Администрирование.


4. Автоматический вход в систему(авто-ввод пароля).

Если вы хотите ускорить процесс загрузки Windows 7, то вы можете настроить автоматический вход в систему. Эта возможность создана для тех ситуаций, когда компьютером пользуется один человек. Настроив автоматический вход, вам не нужно будет вводить пароль каждый раз, когда загружается ваша операционная система.
Чтобы настроить автоматический вход в Windows 7, сделайте следующее:

1. Нажмите на клавиатуре Win+R (или пункт Run в меню Start).
2. В появившемся окне введите “control userpasswords2” (без кавычек) и нажмите Ввод.
3. В окне User Accounts на закладке Users выделите свою учетную запись и уберите галочку с “Users must enter a user name and password to use this computer”.
4. Нажмите Apply.
5. В открывшемся окне Automatically Log On будут три поля - User name, Password и Confirm Password. Введите свой пароль в поле Password и еще раз - в поле Confirm Password.

Всё. Со следующей перезагрузки системы вам больше не нужно будет вводить свой пароль. Вход в Windows будет происходить автоматически.
(Возможен побочный эффект: после перезагрузки панель "Quick Launch" не сохраняется - после рестарта её нет.)

Назад на страницу раздела Администрирование.


5. Как ограничить пользователей в наборе программ, которые они могут запускать?

Контроль за приложениями сводится к настройке правил. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные определенным издателем (например, Microsoft). Запустите GPEDIT.MSC и перейдите к функции AppLocker() через Computer Configuration > Windows Settings > Security Settings > Application Control Policies или Конфигурация компьютера > Конфигурация Windows > Параметры безопасности > Политики управления приложениями, чтобы посмотреть, как это работает.

Назад на страницу раздела Администрирование.


6. Как быстро запустить программу с правами администратора?

Удерживайте Ctrl+Shift и нажмите на иконку приложения (у вашей учетной записи, конечно, должны быть соответствующие права).

Назад на страницу раздела Администрирование.


7. Как убрать значки запрета доступа на папках?

Для этого надо в свойствах назначения прав папкам и файлам, добавить пользователя Администратор, и дать ему все разрешения, после чего значек с папки или файла будет убран.

Назад на страницу раздела Администрирование.


8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer или Sysinternals Autoruns, и вовсе лучше всегда запускать с повышенными привилегиями.
Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl+Shift+Enter.
3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

1) Запускаете планировщик заданий (Пуск ---> Все программы ---> Стандартные ---> Служебные ---> Планировщик заданий)
2) Нажимаете "Создать задачу"
3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
5) Указываете путь к нужному приложению и нажимаете "Открыть"
6) Нажимаете "ОК", затем снова "ОК"
7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" ---> "Ярлык")
8) В поле Расположение объекта введите:
schtasks /run /tn mytask_admin
где mytask_admin - имя созданной нами задачи. Если в имеми содержаться робелы, обязательно укажите его в кавычках.
9) Введите имя ярлыка и нажмите Готово

Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

Скачать можно здесь или здесь

Назад на страницу раздела Администрирование.


Интерфейс

1. Как открыть диспетчер задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту?

Вариант 1

Используйте ctrl+shift+esc.

Вариант 2

Правой кнопкой на панели задач --> Start Task Manager

2. Использование средней кнопкой мыши при работе с панелью задач.

Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

3. Как уменьшить размер иконки на рабочем столе ?

1) Правый клик на рабочем столе - Вид - Мелкие значки;
2) Нажимаем Сtrl и крутим колесико.

4. Управление заготовками положений размеров окон.

Чтобы легко управлять заготовками положений размеров окон (любых) просто кликните на активное окно и жмите:(win+влево,вниз,вправо,вверх).

5. Дополнительные темы и обои для Windows находятся в скрытой папке - C:\Windows\Globalization\MCT

Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
Для этого, запустите диалоговое окно "Выполнить" (Win + R) и наберите в нем:
C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

6. Как перезапустить рабочий стол?

Откройте Task Manager - вкладка Applications - нажимаете кнопку New task - далее кнопку Browse - переходите в папку Windows и выбираете explorer.exe, затем нажимаете ОК (это же действие можно выполнить через ярлык).

7. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

1) Щелкаем правой кнопкой на Компьютер (например в Пуске) и выбираем Управление
2) В левом окне выбираем Управление дисками
3) Посередине вверху смотрим, какие из томов не имеют букву. Среди них должен быть раздел размером 200 МБ. Его НЕ трогать!!!
4) Присваиваем букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкаем на нем правой кнопкой и в контекстном меню выбираем Изменить букву диска или путь к диску. Жмем Добавить. Выбираем букву. Жмем OK.
5) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
Также должна стоять галочка в Панель управления-Параметры папок-Вид "Отображать буквы дисков"

8. Включение и отключение Области переходов.

Область переходов – это специальная панель (дерево папок), которая находится слева в каждой папке.
Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

Включить или отключить Область переходов можно так:

1) Нажмите вверху слева Упорядочить->Представление
2) Поставьте или уберите галочку в пункте Область переходов

9. Изменение ширины меню Пуск.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Resources\Themes\Aero\ru-RU\aero.msstyles.mui и изменяете значения в строковой таблице в строках с 113 по 121 включительно, делаете их такими же, как в C:\Windows\Resources\Themes\Aero\en-US\aero.msstyles.mui
113, "0, 0, 406, 440"
114, "0, 0, 145, 75"
115, "0, 0, 64, 64"
116, "0, 0, 145, 44"
117, "0, 0, 261, 30"
118, "0, 0, 145, 332"
119, "0, 0, 261, 383"
120, "0, 0, 261, 37"
121, "0, 0, 400, 50"

10. Изменение прозрачности окон в Windows 7.

До | После
Рисунок 1 из 2 | Рисунок 2 из 2

Выключить матовый-стеклянный (Blur эффект) и включить прозрачный эффект можно при помощи небольшого скрипта: HideBlur Tool for Windows 7

Инструкция:

1. Распакуйте и запустите файл "Patch Blur x86.bat". Если у вас x64 битная версия, запустите файл "Patch Blur x64.bat".
2. Это займет немного времени и вы увидите окно без эффекта матовости.
3. Если захотите вернуть эффект матовости, запустите файл "Enable Blur.bat". А если снова захотите убрать матовость запустите файл "Disable Blur.bat".
4. Если вы решите восстановить системные файлы запустите файл "Unpatch Blur.bat".
Изменения становятся видимыми после перезагрузки.

Сайт автора скрипта

11. Открытие коммандной строки из конкретной папки.

Одной из самых популярных утилит в наборе Windows XP Power Toys был пункт контекстного меню проводника «Открыть командную строку отсюда» (“Open Command Prompt Here”).
В Windows 7 этот пункт есть в контекстном меню, для его использования при вызове меню нужно удерживать клавишу Shift, вследствие чего в меню появляется пункт "Открыть окно команд".

12. Как улучшить качество передачи цветов монитором?

Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова мастера кликните Start, введите DCCW и нажмите <Enter>.

13. Включение Flip3D — отображение окон под углом.

1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

14. Как расширить функциональность часов в трее или изменить их вид?

Скачайте программу Stoic Joker's T-Clock x32/x64. Данная программа позволяет вам расширить функциональность часов в трее или изменить внешний вид часов в трее. Вы сможете добавить секунды к часам, изменить внешний вид часов, даты или добавить созданные вами значки для запуска конкретных приложений в трей.

15. Быстрый переход к папкам и программам, используя переменные окружения (Например: %SystemRoot% - C:\Windows).

Чтобы узнать какие из них присутствуют в вашей системе запустите cmd.exe и в нем команду set. Получите полный список переменных окружения вашей Windows.

%AllUsersProfile% - C:\ProgramData
%AppData% - C:\Users\%UserName%\AppData\Roaming
%CommonFavorites% - C:\Documents and Settings\All Users\Избранное
%CommonFiles% - C:\Program Files\Common Files
%CommonProgramFiles% - C:\Program Files\Common Files
%CommonProgramFiles(x86)% - C:\Program Files (x86)\Common Files
%ComSpec% - Запустит cmd.exe из папки, в которой будет употреблен
%HomePath% - C:\Users\Administrator
%LOCALAPPDATA% - C:\Users\%UserName%\AppData\Local
%ProgramData% - C:\ProgramData
%ProgramFiles% - C:\Program Files
%ProgramFiles(x86)% - C:\Program Files (x86)
%PSModulePath% - C:\Windows\System32\WindowsPowerShell\v1.0\Modules
%SystemDir% - C:\Windows\System32
%SystemDrive% - C:\
%SystemRoot% - C:\Windows
%Temp% - C:\Documents and Settings\%UserName%\Local Settings\Temp; C:\Users\%UserName%\AppData\Local\Temp
%Tmp% - C:\Users\%UserName%\AppData\Local\Temp
%UserProfile% - C:\Users\%UserName%
%windir% - C:\Windows

Если вы решите создать собственную переменную типа:
%MyFolder%=C:\MyFolder

1) Пройдите:
Компьютер -> Свойства -> Дополнительные параметры системы ->Дополнительно -> Переменные среды
2) Нажмите Создать...
3) Укажите Имя перменной и Значение переменной
4) Нажмите на каждое Ок
5) Перезагрузите компьютер (иначе она не будет работать)

И в качестве дополнения.

В Windows 7 есть возможность быстрого перехода в системные папки и оснастки Панели управления, используя команду shell. Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет открыто окно проводника в папке C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

Список доступных комманд
shell:cookies | shell:ChangeRemoveProgramsFolder | shell:CommonDownloads
shell:nethood | shell:Common Administrative Tools | shell:CommonMusic
shell:PrintersFolder | shell:Common AppData | shell:CommonPictures
shell:System | shell:Common Desktop | shell:CommonVideo
shell:AddNewProgramsFolder | shell:ConflictFolder | shell:ConnectionsFolder
shell:Administrative Tools | shell:Common Documents | shell:Contacts
shell:AppData | shell:Common Programs | shell:ControlPanelFolder
shell:AppUpdatesFolder | shell:Common Start Menu | shell:CredentialManager
shell:Cache | shell:Common Startup | shell:CryptoKeys
shell:CD Burning | shell:Common Templates | shell:CSCFolder
shell:Default Gadgets | shell:Desktop | shell:Downloads
shell:DpapiKeys | shell:Favorites | shell:Fonts
shell:Gadgets | shell:Games | shell:GameTasks
shell:History | shell:InternetFolder | shell:Links
shell:Local AppData | shell:LocalAppDataLow | shell:LocalizedResourcesDir
shell:MAPIFolder | shell:My Music | shell:My Pictures
shell:My Video | shell:MyComputerFolder | shell:NetHood
shell:NetworkPlacesFolder | shell:OEM Links | shell:Original Images
shell:Personal | shell:PhotoAlbums | shell:Playlists
shell:PrintersFolder | shell:PrintHood | shell:Profile
shell:ProgramFiles | shell:ProgramFilesCommon | shell:ProgramFilesCommonX86
shell:ProgramFilesX86 | shell:Programs | shell:Public
shell:PublicGameTasks | shell:Quick Launch | shell:Recent
shell:RecycleBinFolder | shell:ResourceDir | shell:SampleMusic
shell:SamplePictures | shell:SamplePlaylists | shell:SampleVideos
shell:SavedGames | shell:Searches | shell:SendTo
shell:Start Menu | shell:Startup | shell:SyncCenterFolder
shell:SyncResultsFolder | shell:SyncSetupFolder | shell:SystemCertificates
shell:SystemX86 | shell:Templates | shell:TreePropertiesFolder
shell:UserProfiles | shell:UsersFilesFolder | shell:Windows

16. Использование флажков для выделения (выбора) файлов и папок.

В Windows есть удобная возможность помечать для выделения фалы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
Откройте Проводник и нажмите один раз клавишу Alt - таким образом мы инициализируем отображение стандартного меню вверху окна проводника, которое срыто по умолчанию.
Запустите Пуск\Панель Управления\Параметры Папок и перейдите на вкладку Вид
Отметьте параметр "Использовать флажки для выбора элементов" и нажмите ОК
Теперь слева возле каждого файла и папки появилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

17. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок. Исправить это пожно с помощью бесплатной программы 7Stacks.

Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д. Для работы с программой надо создать папку и сложить туда ярлыки приложений, нужных нам в создаваемом меню. Потом запускаем 7Stacks, выбираем эту папку, настраиваем оформление и создаем ярлык на рабочем столе. Перетаскиваем его в панель задач. Вот и все.

18. Добавление дополнительных операций к окнам.
К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет данная программа.

Добавляет дополнительные функции для окон:
  • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
  • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
  • cвернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
  • и многие другие.
Скачать программу


1. Как открыть диспетчер задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту?

Вариант 1

Используйте ctrl+shift+esc.

Вариант 2

Правой кнопкой на панели задач --> Start Task Manager

Назад на страницу раздела Интерфейс.


2. Использование средней кнопкой мыши при работе с панелью задач.

Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

Назад на страницу раздела Интерфейс.


3. Как уменьшить размер иконки на рабочем столе ?

1) Правый клик на рабочем столе - Вид - Мелкие значки;
2) Нажимаем Сtrl и крутим колесико.

Назад на страницу раздела Интерфейс.


4. Управление заготовками положений размеров окон.

Чтобы легко управлять заготовками положений размеров окон (любых) просто кликните на активное окно и жмите:(win+влево,вниз,вправо,вверх).

Назад на страницу раздела Интерфейс.


5. Дополнительные темы и обои для рабстола находятся в скрытой папке - C:\Windows\Globalization\MCT

5. Дополнительные темы и обои для Windows находятся в скрытой папке - C:\Windows\Globalization\MCT

Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
Для этого, запустите диалоговое окно "Выполнить" (Win + R) и наберите в нем:
C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

Назад на страницу раздела Интерфейс.


6. Как перезапустить рабочий стол?

Откройте Task Manager - вкладка Applications - нажимаете кнопку New task - далее кнопку Browse - переходите в папку Windows и выбираете explorer.exe, затем нажимаете ОК (это же действие можно выполнить через ярлык).

Назад на страницу раздела Интерфейс.


7. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

1) Щелкаем правой кнопкой на Компьютер (например в Пуске) и выбираем Управление
2) В левом окне выбираем Управление дисками
3) Посередине вверху смотрим, какие из томов не имеют букву. Среди них должен быть раздел размером 200 МБ. Его НЕ трогать!!!
4) Присваиваем букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкаем на нем правой кнопкой и в контекстном меню выбираем Изменить букву диска или путь к диску. Жмем Добавить. Выбираем букву. Жмем OK.
5) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
Также должна стоять галочка в Панель управления-Параметры папок-Вид "Отображать буквы дисков"

Назад на страницу раздела Интерфейс.


8. Включение и отключение Области переходов.

"Область переходов" – это специальная панель (дерево папок), которая находится слева в каждой папке.
Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

Включить или отключить "Область переходов" можно так:

1) Нажмите вверху слева Упорядочить->Представление
2) Поставьте или уберите галочку в пункте "Область переходов"

Назад на страницу раздела Интерфейс.


9. Изменение ширины меню Пуск.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Resources\Themes\Aero\ru-RU\aero.msstyles.mui и изменяете значения в строковой таблице в строках с 113 по 121 включительно, делаете их такими же, как в C:\Windows\Resources\Themes\Aero\en-US\aero.msstyles.mui
113, "0, 0, 406, 440"
114, "0, 0, 145, 75"
115, "0, 0, 64, 64"
116, "0, 0, 145, 44"
117, "0, 0, 261, 30"
118, "0, 0, 145, 332"
119, "0, 0, 261, 383"
120, "0, 0, 261, 37"
121, "0, 0, 400, 50"

Назад на страницу раздела Интерфейс.


10. Изменение прозрачности окон в Windows 7.

До | После
Выключить матовый-стеклянный (Blur эффект) и включить прозрачный эффект можно при помощи небольшого скрипта: HideBlur Tool for Windows 7

Инструкция:

1. Распакуйте и запустите файл "Patch Blur x86.bat". Если у вас x64 битная версия, запустите файл "Patch Blur x64.bat".
2. Это займет немного времени и вы увидите окно без эффекта матовости.
3. Если захотите вернуть эффект матовости, запустите файл "Enable Blur.bat". А если снова захотите убрать матовость запустите файл "Disable Blur.bat".
4. Если вы решите восстановить системные файлы запустите файл "Unpatch Blur.bat".
Изменения становятся видимыми после перезагрузки.

Сайт автора скрипта

Назад на страницу раздела Интерфейс.


11. Открытие коммандной строки из конкретной папки.

Одной из самых популярных утилит в наборе Windows XP Power Toys был пункт контекстного меню проводника «Открыть командную строку отсюда» (“Open Command Prompt Here”).
В Windows 7 этот пункт есть в контекстном меню, для его использования при вызове меню нужно удерживать клавишу Shift, вследствие чего в меню появляется пункт "Открыть окно команд".

Назад на страницу раздела Интерфейс.


12. Как улучшить качество передачи цветов монитором?

Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова мастера кликните Start, введите DCCW и нажмите <Enter>.

Назад на страницу раздела Интерфейс.


13. Включение Flip3D — отображение окон под углом.

1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

Назад на страницу раздела Интерфейс.


14. Как расширить функциональность часов в трее или изменить их вид?

Скачайте программу Stoic Joker's T-Clock x32/x64. Данная программа позволяет вам расширить функциональность часов в трее или изменить внешний вид часов в трее. Вы сможете добавить секунды к часам, изменить внешний вид часов, даты или добавить созданные вами значки для запуска конкретных приложений в трей.

Назад на страницу раздела Интерфейс.


15. Быстрый переход к папкам и программам, используя переменные окружения (Например: %SystemRoot% - C:\Windows).

Чтобы узнать какие из них присутствуют в вашей системе запустите cmd.exe и в нем команду set. Получите полный список переменных окружения вашей Windows.

%AllUsersProfile% - C:\ProgramData
%AppData% - C:\Users\%UserName%\AppData\Roaming
%CommonFavorites% - C:\Documents and Settings\All Users\Избранное
%CommonFiles% - C:\Program Files\Common Files
%CommonProgramFiles% - C:\Program Files\Common Files
%CommonProgramFiles(x86)% - C:\Program Files (x86)\Common Files
%ComSpec% - Запустит cmd.exe из папки, в которой будет употреблен
%HomePath% - C:\Users\Administrator
%LOCALAPPDATA% - C:\Users\%UserName%\AppData\Local
%ProgramData% - C:\ProgramData
%ProgramFiles% - C:\Program Files
%ProgramFiles(x86)% - C:\Program Files (x86)
%PSModulePath% - C:\Windows\System32\WindowsPowerShell\v1.0\Modules
%SystemDir% - C:\Windows\System32
%SystemDrive% - C:\
%SystemRoot% - C:\Windows
%Temp% - C:\Documents and Settings\%UserName%\Local Settings\Temp; C:\Users\%UserName%\AppData\Local\Temp
%Tmp% - C:\Users\%UserName%\AppData\Local\Temp
%UserProfile% - C:\Users\%UserName%
%windir% - C:\Windows

Если вы решите создать собственную переменную типа:
%MyFolder%=C:\MyFolder

1) Пройдите:
Компьютер -> Свойства -> Дополнительные параметры системы ->Дополнительно -> Переменные среды
2) Нажмите Создать...
3) Укажите Имя перменной и Значение переменной
4) Нажмите на каждое Ок
5) Перезагрузите компьютер (иначе она не будет работать)

И в качестве дополнения.

В Windows 7 есть возможность быстрого перехода в системные папки и оснастки Панели управления, используя команду shell. Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет открыто окно проводника в папке C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

Список доступных комманд
shell:cookies | shell:ChangeRemoveProgramsFolder | shell:CommonDownloads
shell:nethood | shell:Common Administrative Tools | shell:CommonMusic
shell:PrintersFolder | shell:Common AppData | shell:CommonPictures
shell:System | shell:Common Desktop | shell:CommonVideo
shell:AddNewProgramsFolder | shell:ConflictFolder | shell:ConnectionsFolder
shell:Administrative Tools | shell:Common Documents | shell:Contacts
shell:AppData | shell:Common Programs | shell:ControlPanelFolder
shell:AppUpdatesFolder | shell:Common Start Menu | shell:CredentialManager
shell:Cache | shell:Common Startup | shell:CryptoKeys
shell:CD Burning | shell:Common Templates | shell:CSCFolder
shell:Default Gadgets | shell:Desktop | shell:Downloads
shell:DpapiKeys | shell:Favorites | shell:Fonts
shell:Gadgets | shell:Games | shell:GameTasks
shell:History | shell:InternetFolder | shell:Links
shell:Local AppData | shell:LocalAppDataLow | shell:LocalizedResourcesDir
shell:MAPIFolder | shell:My Music | shell:My Pictures
shell:My Video | shell:MyComputerFolder | shell:NetHood
shell:NetworkPlacesFolder | shell:OEM Links | shell:Original Images
shell:Personal | shell:PhotoAlbums | shell:Playlists
shell:PrintersFolder | shell:PrintHood | shell:Profile
shell:ProgramFiles | shell:ProgramFilesCommon | shell:ProgramFilesCommonX86
shell:ProgramFilesX86 | shell:Programs | shell:Public
shell:PublicGameTasks | shell:Quick Launch | shell:Recent
shell:RecycleBinFolder | shell:ResourceDir | shell:SampleMusic
shell:SamplePictures | shell:SamplePlaylists | shell:SampleVideos
shell:SavedGames | shell:Searches | shell:SendTo
shell:Start Menu | shell:Startup | shell:SyncCenterFolder
shell:SyncResultsFolder | shell:SyncSetupFolder | shell:SystemCertificates
shell:SystemX86 | shell:Templates | shell:TreePropertiesFolder
shell:UserProfiles | shell:UsersFilesFolder | shell:Windows

Назад на страницу раздела Интерфейс.


16. Использование флажков для выделения (выбора) файлов и папок.

В Windows есть удобная возможность помечать для выделения фалы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
Откройте Проводник и нажмите один раз клавишу Alt - таким образом мы инициализируем отображение стандартного меню вверху окна проводника, которое срыто по умолчанию.
Запустите Пуск\Панель Управления\Параметры Папок и перейдите на вкладку Вид
Отметьте параметр "Использовать флажки для выбора элементов" и нажмите ОК
Теперь слева возле каждого файла и папки появилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

Назад на страницу раздела Интерфейс.


17. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок. Исправить это пожно с помощью бесплатной программы 7Stacks.

Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д. Для работы с программой надо создать папку и сложить туда ярлыки приложений, нужных нам в создаваемом меню. Потом запускаем 7Stacks, выбираем эту папку, настраиваем оформление и создаем ярлык на рабочем столе. Перетаскиваем его в панель задач. Вот и все.

Назад на страницу раздела Интерфейс.


18. Добавление дополнительных операций к окнам.

К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет данная программа.

Добавляет дополнительные функции для окон:
  • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
  • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
  • cвернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
  • и многие другие.
Скачать программу

Назад на страницу раздела Интерфейс.


Сети (Интернет и Локальная)

1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

Установите, как минимум, пониженый уровень UAC.

2. У сетевого адаптера Marvell Yukon сеть отключается через каждые 5 минут.

Отменить в настройках Marvell Yukon "Разрешить этому устройству откл. для экономии энергии".

3. Где можно объединить и удалить сети?

Нажмите на скамейку.

4. Как сделать так, чтобы интернет включался при запуске Windows в "невидимом режиме"?

Control Panel\Network and Internet\Сетевые подключения\свойства ADSL. Во вкладке параметры сними галочки: отображать ход подключения, запрашивать имя и пароль. Ярлык ADSL поместите в папку автозагрузки.

5. Автоматическое VPN подключение к интернет при запуске Windows.

Вариант 1

Также можно добавить задачу в Планировщик заданий.
1) Откройте планировщик задний из меню Пуск - Администрирование - Планировщик заданий или выполнив команду taskschd.msc из меню Пуск - Поиск.
2) Нажмите создать задачу

Вкладка Имя - Имя подключения
Размещение оставляем как есть.

Вкладка Триггеры-Создать-Начать задачу: При входе в систему

Вкладка Действия-Создать
Действие:Запуск программы
Программа или сценарий: rasdial "имя подключения" пользователь пароль

Вкладка Параметры-Создать
Поставить галочки:
Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.
Убрать галочку:
Останавливать задачу выполняемую дольше

Вариант 2

Наличие скриптов в одной папке connect.bat обязательно.
1) По ссылке ниже берете скрипт (bat-файл)
2) Настраиваете его под себя (имя соединения, логин,пароль)
3) Сохраняете(выкладываете) исправленный файл на рабочий стол, называете его "connect.bat"
connect1.zip
4) Затем берете архив со скриптом скрытого запуска отсюда
hs_exec.zip
hide_programm.zip
5) Извлекаем файлы из архива и кладем в ту же самую папку где лежит файл "connect.bat" запускаем либо "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd.
6) Для автоматической загрузки добавляем в Автозагрузка ярлык (не сам файл скрипта) для "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd

Вариант 3

Создайте маленький bat-файл(типа Connect.bat) следующего содержания, положите его на рабочий стол и запускайте через него при случайном разрыве (имя подключения должно быть на английском иначе может быть ошибка 623):
@echo off

set conn="Golden Telecom"
:: название вашего подключения к интернету

set login="loginname@golden.ru"
:: ваш логин подключения к интернету

set pass="12345678"
:: ваш пароль подключения к интернету

set pause=10
:: пауза в секундах между проверкой соединения, если соединение разорвалось произойдет подключение

rasdial %conn% %login% %pass%

exit

6. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

Переименуйте имя соединения на английский язык и всё должно заработать.

7. Как просмотреть исходный код любой страницы в интернете.

Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

В Firefox

Установите расширение Web Developer.
Затем в меню Web Developer -> Код -> Сгенерированный код.
Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл -> Сохранить страницу как -> page.htm

В Internet Explorer

Меню Сервис -> Средства разработчика
Можете нажать на стрелочку и выбрать нужный элемент на странице и увидите его код или нажать на значок дискетки и сохранить исходный код в текстовый файл, а затем скопировать из него в html.

8. Как сменить поиск по умолчанию в Firefox?

Бывает, что программы без вашего спроса меняют в Firefox поисковик по умолчанию на свой. Чтобы его заменить сделайте следующее:

1) Пишете в адресной строке Firefox такой адрес: "about:config", без кавычек
2) Подтверждаете, что будете осторожны, получаете доступ к многочисленным настройкам Firefox и находите среди них параметр keyword.url
3) Меняете его значение (без кавычек) на:

"http://www.google.com/search?&q=" - Google.Com
"http://yandex.ru/yandsearch?text=" - Yandex.Ru
"http://www.bing.com/search?q=" - Bing.Com


1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

Установите, как минимум, пониженый уровень UAC.

Назад на страницу раздела Сети (Интернет и Локальная).


2. У сетевого адаптера Marvell Yukon сеть отключается через каждые 5 минут.

Отменить в настройках Marvell Yukon "Разрешить этому устройству откл. для экономии энергии".

Назад на страницу раздела Сети (Интернет и Локальная).


3. Где можно объединить и удалить сети?

Нажмите на скамейку.

Назад на страницу раздела Сети (Интернет и Локальная).


4. Как сделать так, чтобы интернет включался при запуске Windows в "невидимом режиме"?

Control Panel\Network and Internet\Сетевые подключения\свойства ADSL. Во вкладке параметры сними галочки: отображать ход подключения, запрашивать имя и пароль. Ярлык ADSL поместите в папку автозагрузки.

Назад на страницу раздела Сети (Интернет и Локальная).


5. Автоматическое VPN подключение к интернет при запуске Windows.

Вариант 1

Также можно добавить задачу в Планировщик заданий.
1) Откройте планировщик задний из меню Пуск - Администрирование - Планировщик заданий или выполнив команду taskschd.msc из меню Пуск - Поиск.
2) Нажмите создать задачу

Вкладка Имя - Имя подключения
Размещение оставляем как есть.

Вкладка Триггеры-Создать-Начать задачу: При входе в систему

Вкладка Действия-Создать
Действие:Запуск программы
Программа или сценарий: rasdial "имя подключения" пользователь пароль

Вкладка Параметры-Создать
Поставить галочки:
Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.
Убрать галочку:
Останавливать задачу выполняемую дольше

Вариант 2

Наличие скриптов в одной папке connect.bat обязательно.
1) По ссылке ниже берете скрипт (bat-файл)
2) Настраиваете его под себя (имя соединения, логин,пароль)
3) Сохраняете(выкладываете) исправленный файл на рабочий стол, называете его "connect.bat"
connect1.zip
4) Затем берете архив со скриптом скрытого запуска отсюда
hs_exec.zip
hide_programm.zip
5) Извлекаем файлы из архива и кладем в ту же самую папку где лежит файл "connect.bat" запускаем либо "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd.
6) Для автоматической загрузки добавляем в Автозагрузка ярлык (не сам файл скрипта) для "hide_programm.js" в случае с яваскриптом, либо "load.bat" в случае с cmd

Вариант 3

Создайте маленький bat-файл(типа Connect.bat) следующего содержания, положите его на рабочий стол и запускайте через него при случайном разрыве (имя подключения должно быть на английском иначе может быть ошибка 623):
@echo off

set conn="Golden Telecom"
:: название вашего подключения к интернету

set login="loginname@golden.ru"
:: ваш логин подключения к интернету

set pass="12345678"
:: ваш пароль подключения к интернету

set pause=10
:: пауза в секундах между проверкой соединения, если соединение разорвалось произойдет подключение

rasdial %conn% %login% %pass%

exit

Назад на страницу раздела Сети (Интернет и Локальная).


6. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

Переименуйте имя соединения на английский язык и всё должно заработать.

Назад на страницу раздела Сети (Интернет и Локальная).


7. Как просмотреть исходный код любой страницы в интернете.

Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

В Firefox

Установите расширение Web Developer.
Затем в меню Web Developer -> Код -> Сгенерированный код.
Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл -> Сохранить страницу как -> page.htm

В Internet Explorer

Меню Сервис -> Средства разработчика
Можете нажать на стрелочку и выбрать нужный элемент на странице и увидите его код или нажать на значок дискетки и сохранить исходный код в текстовый файл, а затем скопировать из него в html.

Назад на страницу раздела Сети (Интернет и Локальная).


8. Как сменить поиск по умолчанию в Firefox?

Бывает, что программы без вашего спроса меняют в Firefox поисковик по умолчанию на свой. Чтобы его заменить сделайте следующее:

1) Пишете в адресной строке Firefox такой адрес: "about:config", без кавычек
2) Подтверждаете, что будете осторожны, получаете доступ к многочисленным настройкам Firefox и находите среди них параметр keyword.url
3) Меняете его значение (без кавычек) на:

"http://www.google.com/search?&q=" - Google.Com
"http://yandex.ru/yandsearch?text=" - Yandex.Ru
"http://www.bing.com/search?q=" - Bing.Com

Назад на страницу раздела Сети (Интернет и Локальная).


Тонкие настройки

1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново.
Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

Отключаем ее:
1. Создайте пустой текстовый файл,
2. Скопируйте в него powercfg -h off,
3. При сохранении изменить расширение "TXT" на "CMD",
4. Запустите его как обычную программу,
5. Перезагрузка.

Также Вы можете запустить командную строку с правами администратора (Нажать Win+R, ввести Cmd и нажать Ok) и выполнить в ней данную комманду:
powercfg /h off

2. Как скрыть значок "Центр действий" в трее возле часов?

1) Пройдите Пуск\Панель управления\Значки области уведомлений
2) Выберите значки которые хотите скрыть и нажмите Ok

3. Как убрать текст под значком ярлыка или файла?

1) Щелкните правой кнопкой мыши на иконке.
2) Кликните Переименовать.
3) Удерживая клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5 и 5 (Alt+255).
Данная комбинация позволяет добавить невидимый символ в название ярлыка или файла.
Если вы захотите переименовать несколько ярлыков, то, когда вы будете переименовывать следующий, вам потребуется нажать Alt и ввести 255 дважды. Так для третьего значка вам потребуется ввести ALT+255, ALT+255, ALT+255.

4. Создаем (восстанавливаем) панель быстрого запуска (Quick Launch).

1) Правой кнопкой по панели задач ->Панели(Toolbars )-->Создать панель инструментов(New Toolbar)-->
2) Выберите папку: %appdata%\Microsoft\Internet Explorer\Quick Launch
3) Нажмите кнопку выбора папки “Select Folder”.
4) Правой кнопкой на панели задач -> снять галку "Закрепить панель задач";
5) Правой кнопкой мыши на появившемся "quick launch"--->убираем галки с "Показывать подписи" и "Показывать заголовок"
6) Перетаскиваем в левую сторону и закрепляем обратно панель --->Все!

5. Удаление или разблокирование любого файла защищённого Windows.

1. Качаем и устанавливаем программу Unlocker
2. Копируем файл(ы) в буфер обмена, для дальнейшей замены.
3. С помощью программы Unlocker, удаляем заменяемый(е) файл(ы).
4. После удаления файла(ов), вставляем заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления) и перезагружаем компьютер.
P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, переходим к папке C:\Windows\rescache и с помощью этой хе программы Unlocker удаляем её содержимое. Перезагружаемся.

Для 64-битных систем аналогом является программа LockHunter 64-bit.

6. Убираем лишние надписи на рабочем столе.

Открываете с помощью Restorator или PE Explorer файлы C:\Windows\System32\ru-RU\user32.dll.mui и C:\Windows\System32\en-US\user32.dll.mui и в строковой таблице удаляем строчки с 715 по 718 включительно, для того чтобы лишних надписей на рабочем столе не было.

7. Смена названия операционной системы из Максимальная на Ultimate.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Branding\Basebrd\ru-RU\basebrd.dll.mui и правите в нем название операционной системы из Максимальная на Ultimate. Также можно скопировать файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US\ в папку C:\Windows\Branding\Basebrd\ru-RU\ если данной папки нет, то файлы можно скачать тут: для x86, для x64

8. Использование всей оперативной памяти в 32-битных Windows.

1) Скачать здесь автоскрипт от deepxw.
2) 3апустить ReadyFor4GB.exe
3) Нажать на кнопку Check, затем на кнопку Apply.
4) Перезагрузить компьютер и вам станут доступны все 4 ГБ оперативки на вашей установленной ОС Windows 7 (x86), или если у вас установлено более >4ГБ, то ваш объем Оперативной памяти также станет доступен в полном объеме без ограничений...

Примечание: Файлы обязательно запускать как администратор, запускайте этот скрипт строго в операционной системе Windows 7 x86 (32-Bit) для которой вам нужно снять ограничение.

9. Запускаем Windows Explorer с папки My Computer, вместо Libraries.

Настраиваем нажатие на кнопку Windows Explorer, чтобы оно приводило в паку My Computer, вместо Libraries:

Просто измените в свойствах ярлыка Windows Explorer поле Target (Объект) на %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Чтобы это изменение затронуло и ссылку в меню Start, то вам потребуется изменить поле Target в свойствах ярлыка Windows Explorer и в папке Accessories из меню Start.
Чтобы в панеле задач иконка Проводника, так же выходила в Мой компьютер, а не библиотеки, для этого нужно удалить ее с панели задачи, правый клик и Unpin. Возвращаемся в Accessories находим знакомую иконку, правый клик по ней и выбираем Pin to Taskbar.
Комбинация клавиш Win+E также откроет Проводник в «Компьютере»

10. Добавление или прямой запуск папки Все задачи (для разработчиков и тестеров), и других системных папок.

Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

Список системных папок, возможных для создания:

Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

Список команд для прямого запуска:

Все задачи - shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Все элементы панели управления - shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Компьютер - shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Панель управления - shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Персонализация - shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - shell:::{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - shell:::{60632754-c523-4b62-b45c-4172da012619}

Также, вы можете самостоятельно поискать в ветке реестра HKEY_CLASSES_ROOT\CLSID наименования других системных папок, для их создания или прямого запуска. Для создания папки к её реестровому наименованию, добавьте необходимое Вам название, а для прямого запуска перед названием папки добавьте shell::: .

11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.
Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Нажмите кнопку "Пуск",
2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

В выпадающем списке выберите подходящее для Вас значение.

12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".
У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

Если в настройках фонового рисунка рабочего стола, вызываемых:
1) ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола
2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win+R –> Regedit –> OK) по адресу:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

Вы можете создать новую библиотеку и добавить в неё Ваши папками.

1) Открываете папку Библиотеки. У кого она удалена из проводника, тот может открыть её введя в адресную строку Windows Explorer:
shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
2) Нажимаете ПКМ -> Создать -> Библиотека
3) Переименовываете её. Например: Обои для рабочего стола
4) Щелкаете ПКМ и выбираете Свойства
5) Добавляете отдельно каждую папку
6) В графе Оптимизировать эту библиотеку: выбираете Изображения
7) Нажимаете применить, затем Ок.
8) После этого открываем раздел Персонализация –> Фон рабочего стола -> и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалиться из системы(из той папки,в которой он находится).

Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

Её ключевые возможности:
- Создание библиотеки из произвольного набора папок.
- Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
- Переименование библиотеки.
- Указание типа содержимого новой или редактируемой библиотеки.
- Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
- Управление отображением библиотеки в панели навигации проводника.
- Отображение библиотеки в виде XML-файла.
- Отображение системного диалога папок, включенных в библиотеку.

Скачать данную программу можно здесь или здесь


1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново. Чтобы выключить гибернацию, запустите командную строку с правами администратора и выполните: powercfg /h off Чтобы включить: powercfg /h on
Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

Отключаем ее:
1. Создайте пустой текстовый файл,
2. Скопируйте в него powercfg -h off,
3. При сохранении изменить расширение "TXT" на "CMD",
4. Запустите его как обычную программу,
5. Перезагрузка.

Также Вы можете запустить командную строку с правами администратора (Нажать Win+R, ввести Cmd и нажать Ok) и выполнить в ней данную комманду:
powercfg /h off

Назад на страницу раздела Тонкие настройки.


2. Как скрыть значок "Центр действий" в трее возле часов?

1) Пройдите Пуск\Панель управления\Значки области уведомлений
2) Выберите значки которые хотите скрыть и нажмите Ok

Назад на страницу раздела Тонкие настройки.


3. Как убрать текст под значком ярлыка или файла?

1) Щелкните правой кнопкой мыши на иконке.
2) Кликните Переименовать.
3) Удерживая клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5 и 5 (Alt+255).
Данная комбинация позволяет добавить невидимый символ в название ярлыка или файла.
Если вы захотите переименовать несколько ярлыков, то, когда вы будете переименовывать следующий, вам потребуется нажать Alt и ввести 255 дважды. Так для третьего значка вам потребуется ввести ALT+255, ALT+255, ALT+255.

Назад на страницу раздела Тонкие настройки.


4. Создаем (восстанавливаем) панель быстрого запуска (Quick Launch).

1) Правой кнопкой по панели задач ->Панели(Toolbars )-->Создать панель инструментов(New Toolbar)-->
2) Выберите папку: %appdata%\Microsoft\Internet Explorer\Quick Launch
3) Нажмите кнопку выбора папки “Select Folder”.
4) Правой кнопкой на панели задач -> снять галку "Закрепить панель задач";
5) Правой кнопкой мыши на появившемся "quick launch"--->убираем галки с "Показывать подписи" и "Показывать заголовок"
6) Перетаскиваем в левую сторону и закрепляем обратно панель --->Все!

Назад на страницу раздела Тонкие настройки.


5. Удаление или разблокирование любого файла защищённого Windows.

1. Качаем и устанавливаем программу Unlocker
2. Копируем файл(ы) в буфер обмена, для дальнейшей замены.
3. С помощью программы Unlocker, удаляем заменяемый(е) файл(ы).
4. После удаления файла(ов), вставляем заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления) и перезагружаем компьютер.
P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, переходим к папке C:\Windows\rescache и с помощью этой хе программы Unlocker удаляем её содержимое. Перезагружаемся.

Для 64-битных систем аналогом является программа LockHunter 64-bit.

Назад на страницу раздела Тонкие настройки.


6. Убираем лишние надписи на рабочем столе.

Открываете с помощью Restorator или PE Explorer файлы C:\Windows\System32\ru-RU\user32.dll.mui и C:\Windows\System32\en-US\user32.dll.mui и в строковой таблице удаляем строчки с 715 по 718 включительно, для того чтобы лишних надписей на рабочем столе не было.

Назад на страницу раздела Тонкие настройки.


7. Смена названия операционной системы из Максимальная на Ultimate.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Branding\Basebrd\ru-RU\basebrd.dll.mui и правите в нем название операционной системы из Максимальная на Ultimate. Также можно скопировать файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US\ в папку C:\Windows\Branding\Basebrd\ru-RU\ если данной папки нет, то файлы можно скачать тут: для x86, для x64

Назад на страницу раздела Тонкие настройки.


8. Использование всей доступной оперативной памяти.

8. Использование всей оперативной памяти в 32-битных Windows.

1) Скачать здесь автоскрипт от deepxw.
2) 3апустить ReadyFor4GB.exe
3) Нажать на кнопку Check, затем на кнопку Apply.
4) Перезагрузить компьютер и вам станут доступны все 4 ГБ оперативки на вашей установленной ОС Windows 7 (x86), или если у вас установлено более >4ГБ, то ваш объем Оперативной памяти также станет доступен в полном объеме без ограничений...

Примечание: Файлы обязательно запускать как администратор, запускайте этот скрипт строго в операционной системе Windows 7 x86 (32-Bit) для которой вам нужно снять ограничение.

Назад на страницу раздела Тонкие настройки.


9. Запускаем Windows Explorer с папки My Computer, вместо Libraries.

Настраиваем нажатие на кнопку Windows Explorer, чтобы оно приводило в паку My Computer, вместо Libraries:

Просто измените в свойствах ярлыка Windows Explorer поле Target (Объект) на %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Чтобы это изменение затронуло и ссылку в меню Start, то вам потребуется изменить поле Target в свойствах ярлыка Windows Explorer и в папке Accessories из меню Start.
Чтобы в панеле задач иконка Проводника, так же выходила в Мой компьютер, а не библиотеки, для этого нужно удалить ее с панели задачи, правый клик и Unpin. Возвращаемся в Accessories находим знакомую иконку, правый клик по ней и выбираем Pin to Taskbar.
Комбинация клавиш Win+E также откроет Проводник в «Компьютере»

Назад на страницу раздела Тонкие настройки.


10. Добавление или прямой запуск папки Все задачи (для разработчиков и тестеров), и других системных папок.

Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

Список системных папок, возможных для создания:

Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

Список команд для прямого запуска:

Все задачи - shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Все элементы панели управления - shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Компьютер - shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Панель управления - shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Персонализация - shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - shell:::{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - shell:::{60632754-c523-4b62-b45c-4172da012619}

Также, вы можете самостоятельно поискать в ветке реестра HKEY_CLASSES_ROOT\CLSID наименования других системных папок, для их создания или прямого запуска. Для создания папки к её реестровому наименованию, добавьте необходимое Вам название, а для прямого запуска перед названием папки добавьте shell::: .

Назад на страницу раздела Тонкие настройки.


11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Нажмите кнопку "Пуск",
2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

В выпадающем списке выберите подходящее для Вас значение.

Назад на страницу раздела Тонкие настройки.


12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".

У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

Если в настройках фонового рисунка рабочего стола, вызываемых:
1) ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола
2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win+R –> Regedit –> OK) по адресу:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

Вы можете создать новую библиотеку и добавить в неё Ваши папками.

1) Открываете папку Библиотеки. У кого она удалена из проводника, тот может открыть её введя в адресную строку Windows Explorer:
shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
2) Нажимаете ПКМ -> Создать -> Библиотека
3) Переименовываете её. Например: Обои для рабочего стола
4) Щелкаете ПКМ и выбираете Свойства
5) Добавляете отдельно каждую папку
6) В графе Оптимизировать эту библиотеку: выбираете Изображения
7) Нажимаете применить, затем Ок.
8) После этого открываем раздел Персонализация –> Фон рабочего стола -> и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалиться из системы(из той папки,в которой он находится).

Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

Её ключевые возможности:
- Создание библиотеки из произвольного набора папок.
- Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
- Переименование библиотеки.
- Указание типа содержимого новой или редактируемой библиотеки.
- Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
- Управление отображением библиотеки в панели навигации проводника.
- Отображение библиотеки в виде XML-файла.
- Отображение системного диалога папок, включенных в библиотеку.

Скачать данную программу можно здесь или здесь

Назад на страницу раздела Тонкие настройки.


Твики Реестра

Твики Реестра - Добавление

1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@="\"%1\" /X:\"%1_unpacked\""
В итоге, при распаковке WindowsXP-KB922582-x86-RUS.exe, на выходе получаем папку WindowsXP-KB922582-x86-RUS.exe_unpacked с извлечёнными файлами. Минус один - команда Unpack HotFix встраивается в контекстное меню всех екзешников, а не только файлов от MS.

Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix]
[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@=-

Готовые reg-файлы Вы можете скачать по ссылке: Unpack_HotFix.zip

2. Как задать полный доступ к файлу или папке?

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"

3. Автоматическое VPN подключение к интернет при запуске Windows (реестр).

1. Создайте ваше VPN подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
2. В реестре Windows (Пуск->Выполнить->"regedit") найдите следующую ветку:
"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск только для текущего пользователя) или
"HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск для всех пользователей)
В этой ветке создайте "строковый параметр" (правой кнопкой мыши -> «Создать» -> «строковый параметр») с произвольным именем.
2. В качестве значения созданного параметра внесите строку вида:
rasdial "имя_вашего соединения" <логин> <пароль> (Например: rasdial "VPN connection" nz15vl 1234)
3. Закройте реестр и перезагрузите компьютер.

4. Добавляем пункт "Открыть в блокноте" в контекстное меню файлов.

Для того, чтобы добавить в контекстное меню файлов пункт "Открыть в Блокноте" текст кода сохраните в текстовый файл, присвойте ему расширение *.reg, запустите и согласитесь с добавлением данных в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте]
@=""

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте\command]
@="notepad.exe %1"

5. Как добавить дополнительные функции в папку Компьютер?

Администрирование

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{D20EA4E1-3957-11d2-A40B-0C5020524153}]

Корзина

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{645FF040-5081-101B-9F08-00AA002F954E}]

Панель управления

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\Controls]
@="{21EC2020-3AEA-1069-A2DD-08002B30309D}"

Принтеры и факсы

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{2227A280-3AEA-1069-A2DE-08002B30309D}]

Учетные записи пользователей

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{7A9D77BD-5403-11d2-8785-2E0420524153}]
В итоге получаем:

6. Добавляем произвольную команду в контекстное меню рабочего стола.

Для этого создаем файл fix.txt
Открываем блокнот и копируем туда это содержимое, сохраняем и меняем разширение на .reg
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name]
@="Свойства папки"
"Icon"="imageres.dll,200"
"Position"="Top"

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name\command]
@="control folders"
Сохраняем файл и выполняем его.
В параметре "Icon"="imageres.dll,200" цифра 200 отвечает за номер иконки. Вы можете указать свою.
Таким образом можно добавить практически любую команду (управление учетными записями Control userpasswords).

7. Конвертирование reg файлов в inf формат из контекстного меню, с помощью утилиты.
1) Скачиваете утилиту Reg2inf (необходим Framework 2 или 3)
2) Помешаете её в System32
3) Добавление в реестр добавляется следующее:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\command]
@="Reg2Inf.exe \"%1\" \"%1.inf\" /RepVars"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Application]
@="Reg2Inf"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Topic]
@="System"
В итоге, в контекстное меню reg файлов добавляется команда reg2inf и, к примеру, файл test.reg конвертируется в test.reg.inf

8. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".
Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB. С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\Shell]

[HKEY_CLASSES_ROOT\*\Shell\astext]
@="Как текст..."

[HKEY_CLASSES_ROOT\*\Shell\astext\command]
@="notepad.exe \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\Expand]
@="Распаковать .cab"

[HKEY_CLASSES_ROOT\*\Shell\Expand\command]
@="expand -r \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\MakeCab]
@="Запаковать в .cab"

[HKEY_CLASSES_ROOT\*\Shell\MakeCab\command]
@="makecab /D CompressionType=LZX /D CompressionMemory=21 \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\UpperCase]
@="Имя в ВЕРХНИЙ РЕГИСТР"

[HKEY_CLASSES_ROOT\*\Shell\UpperCase\command]
@="FILECASE /U \"%1\""

[HKEY_CLASSES_ROOT\Directory\shell\CabPack]
@="Запаковать папку в .cab"

[HKEY_CLASSES_ROOT\Directory\shell\CabPack\command]
@="cabs.cmd %L"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs]
@="Создать список файлов папки"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs\command]
@="dirs.cmd %L"

Твики Реестра - Изменение

1. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

1) Запустите меню Выполнить(Win+R) или командную строку от имени Администратора
2) Введите команду
unregmp2.exe /SwapTo:64
(команда чувствительна к регистру)
3) Откройте редактор реестра: Win+R --> regedit
4) Перейдите к ветке
HKLM\Software\Microsoft\Windows\CurrentVersion\App Paths\wmplayer.exe\
и кликните два раза по значению Path
5) Измените
"%ProgramFiles(x86)%\Windows Media Player"
на
"%ProgramFiles%\Windows Media Player"
6) Закройте реестр и наслаждайтесь Windows Media Player х64

Готовые bat-файлы Вы можете скачать по ссылке: Windows_Media_Player_x64.zip

2. Ускорение выключения компьютера.

Измените задержку перед выключением компьютера в реестре в разделе:
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WaitToKillServiceTimeout" - отвечает за задержку перед выключением.
По умолчанию установлено значение (20000)=20 сек., но вы можете установить его значение, намного меньше номинального (минимум 100), и система будет закрываться намного быстрее.
Рекомендуемые значения (2000-5000)=2-5 сек. (меньше не рекомендуется, иначе система будет понимать неадекватно отсутсвие откликов от служб, и завершать их в "неподходящий" момент времени, например когда они сохраняют свои последние настройки)

3. Отмена автозапуска у устройства (DVD диска, Flash диска и т.д.)

1) Пуск -> выполнить -> regedit
2) открыть ветку HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) В этом разделе создать ключ(Параметр DWORD) NoDriveTypeAutoRun

Допустимые значения ключа:

0x1 - отключить автозапуск на приводах неизвестных типов
0x4 - отключить автозапуск сьемных устройств
0x8 - отключить автозапуск НЕсьемных устройств
0x10 - отключить автозапуск сетевых дисков
0x20 - отключить автозапуск CD-приводов
0x40 - отключить автозапуск RAM-дисков
0x80 - отключить автозапуск на приводах неизвестных типов
0xFF - отключить автозапуск вообще всех дисков.

4. Смена фона в экране авторизации.

1) Создайте ключ типа DWORD с названием OEMBackground в ветке реестра
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background

2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
4) Поместите сюда свой файл
5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

background768x1280.jpg
background900x1440.jpg
background960x1280.jpg
background1024x1280.jpg
background1280x1024.jpg
background1024x768.jpg
background1280x960.jpg
background1600x1200.jpg
background1440x900.jpg
background1920x1200.jpg
background1280x768.jpg
background1360x768.jpg
backgroundDefault.jpg - в случае нестандартного расширения монитора

Размер изображений не должен превышать 256Кб.
Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

5. Ускорение анимации всплывающего меню в меню Пуск и появления окна предварительного просмотра в панели задач.

При наведении на значок приложения в панели задач окно предварительного просмотра появляется с задержкой.

1.Запускаем редактор реестра (Пуск –> Выполнить –> regedit)
2.Находим ключ HKEY_CURRENT_USER –> Control Panel –> Mouse
3.В этом ключе находим значение MouseHoverTime
Выбираем желательное время в миллисекундах, по прошествии которого после наведения указателя мыши будет показываться эскиз окна.
Чтобы случайно при проведении мыши, окно не выскочило, но при наведении целенаправленно, окно появилось практически мгновенно поставьте значения не меньше 50.
4. Находим ключ HKEY_CURRENT_USER\Control Panel\Desktop
5. В этом ключе находим значение MenuShowDelay
Выбираем желательное значение от 1 до 4000, означающее задержку в милисекундах, до показа всплывающего меню.
6. Закрываем regedit и перезагружаем систему.

6. Как продлевать срок начального льготного доактивационного периода?

Эта процедура не хакерская уловка и не требует никаких инструментов или утилит вообще и, более того, документирована Microsoft, на ее сайте Technet.
1. В запущенной Windows 7, которая не была еще активирована, щелкните кнопку Start, напечатайте regedit в строке Поиска, затем нажмите ENTER, чтобы запустить Редактор реестра.
2. Перейдите к ключу реестра:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform
3. Щёлкните правой кнопкой мыши на SkipRearm и выберите Edit. Установленное значение по умолчанию - Dword с значением 00000000.
Измените это значение на любое положительное целое число, например, 00000001, сохраните и закройте редактор реестра.
4. Запустите командную строку с правами администратора.
5. Напечатайте одну из следующих двух команд и нажмите ENTER:
slmgr -rearm или rundll32 slc.dll,SLReArmWindows
Эти команды используют встроенный в Windows 7 Менеджер лицензий (SLMGR), который по умолчанию дает 30 дней доактивационного периода.
Изменение ключа SkipRearm с 0 на 1 (с 00000000 на 00000001) позволяет менеджеру лицензий SLMGR проделывать процедуру сброса счетчика неограниченное количество раз!
Изменение значения ключа SkipRearm с 1 на 0 возвращает SLMGR к исходному состоянию. 6. Перезагрузите компьютер, чтобы изменения вступили в силу.

7. Переназначение гнезд звуковой карты Realtek используя реестр.
На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

1) Установите драйвера звуковой карты
2) Запустите редактор реестра (Win+К -> regedit -> Ok)
3) Пройдите к папке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\
4) Откройте папку Drv6013_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
5) Создайте двоичный параметр(Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

Рисунок 1 из 2

Имя(вставлять без кавычек):

"Pin01" = Заднее зеленое гнездо
"Pin02" = Заднее черное гнездо
"Pin03" = Заднее коричневое гнездо
"Pin04" = Заднее серое гнездо
"Pin05" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
"Pin07" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

"Pin06" = Переднее розовое гнездо
"Pin08" = Переднее зеленое гнездо

Значение(вставлять без кавычек):

"00 00 00 00" = Линейный вход
"01 00 00 00" = Микрофон
"02 00 00 00" = Наушники
"04 00 00 00" = Передние динамики
"05 00 00 00" = Тыловые динамики
"06 00 00 00" = Центральный канал/Сабвуфер
"07 00 00 00" = Боковые динамики

Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

Drv6013_DevType_0888_SS10438357 - на версию вашего драйвера
(имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
Pin04 - на любое значение из списка Имя
hex:02,00,00,00 - на любое значение из списка Значение(просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\Drv6013_DevType_0888_SS10438357]
"Pin04"=hex:02,00,00,00

Рисунок 2 из 2

8. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Запустите редактор реестра (Нажмите Win+R, введите команду regedit.exe и нажмите Ок)
2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
3) Измените значение параметра MessageDuration.

9. Настройка диалога переключения между окнами ("Alt"+"Tab").

1) Запустите Редактор Реестра (Win+R -> Regedit -> Ok)
2) Откройте ветку реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если она отсутствует, то создайте её (щелкните на папке Explorer правой кнопкой мыши, выберите Создать -> Раздел и назовите её AltTab).
В данной папке создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Для создания твика, воспользуйтесь инструкцией:

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Параметры, отвечающие за количество отображаемых столбцов и строк

Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"Columns"=dword:00000005
"Rows"=dword:00000003
Параметры, отвечающие за отступы в диалоге переключения между окнами

Упомянутые ниже параметры указываются в пикселях.

TopMarginPx - величина верхнего поля, добавляемого в диалог
SideMarginPx - величина бокового поля, добавляемого в диалог
BottomMarginPx - величина нижнего поля, добавляемого в диалог
MinWidthPx - минимальная возможная ширина диалога AltTab
ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"TopMarginPx"=dword:00000027
"SideMarginPx"=dword:00000005
"BottomMarginPx"=dword:00000003
"MinWidthPx"=dword:00000050
"ThumbSpacingXPx"=dword:00000006
"ThumbSpacingYPx"=dword:00000015
Параметры, отвечающие за значки эскизов окон

Упомянутые ниже параметры указываются в пикселях.

OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"OverlayIconDYPx"=dword:00000008
"OverlayIconDXPx"=dword:00000008
"OverlayIconPx"=dword:00000030
Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

Упомянутые ниже параметры указываются в пикселях.
MaxThumbSizePx - максимальный размер эскизов окон
MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
TextButtomPx - высота заголовка диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"MinThumbSizePcent"=dword:00000010
"MaxThumbSizePx"=dword:00000085
"TextButtomPx"=dword:00000010
Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

StartAlpha - начальная прозрачность диалога переключения между окнами
FinalAlpha - конечная прозрачность диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"FadeOut_ms"=dword:00000100
"FadeIn_ms"=dword:00000100
"StartAlpha"=dword:00000002
"FinalAlpha"=dword:00000004
Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt+Tab, создайте DWORD-параметр AltTabSettings в ветви реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

Твики Реестра - Удаление

1. Как убрать цифру при пересоздании адаптера сети в Диспетчере устройств?

Вариант 1

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" установите значение адаптера сети на 0.
3) Создайте драйвер сетевого адаптера

Вариант 2

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" удалите ваш сетевой адаптер.
3) Создайте драйвер сетевого адаптера.

2. Как отключить проверку подписи для загруженных программ?

Избавляет от этого:

1) В Панель управления -> Свойства браузера-> вкладка Дополнительно -> снять галочку "Проверка подписи для загруженных программ" и поставить галочку "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
2) Создайте и примените reg-файл следующего содержания.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"DefaultFileTypeRisk"=dword:00006152

;Отключить предупреждение при открытии файлов, загруженных из Интернета
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments]
"HideZoneInfoOnProperties"=dword:00000001
"SaveZoneInformation"=dword:00000002

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000095

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"LowRiskFileTypes"=".zip;.rar;.nfo;.txt;.exe;.bat;.com;.cmd;.reg;.msi;.htm;.html;.gif;.bmp;.jpg;.avi;.mpg;.mpeg;.mov;.mp3;.m3u;.wav;"

3. Как удалить (вернуть) стрелки с ярлыков Windows?

Готовые файлы для убирания стрелок вы можете скачать по ссылке:
Shortcut_Arrows.rar
1) Распакуйте и откройте папку нужного вам варианта
2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat
3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat

Вариант 1

Для удаления стрелок с ярлыков:

1) Запустите диалоговое окно "Выполнить" (Win + R)
2) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %WINDIR%\system32\shell32.dll,50 /f
Для восстановления стрелок на ярлыках:
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f

Вариант 2

Для удаления стрелок с ярлыков:

1) Создайте пустой файл иконки назовите его Blank.ico
2) Скопируйте его в папку C:\Windows
3) Запустите диалоговое окно "Выполнить" (Win + R)
4) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %SystemRoot%\Blank.ico,0 /f
Для восстановления стрелок на ярлыках:

1) Удалите файл Blank.ico из папки C:\Windows
2) Запустите диалоговое окно "Выполнить" (Win + R)
3) Скопируйте код указанный ниже и нажмите OK
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f

4. Как отключить или переназначить клавишу Caps Lock?

Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра. Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

Клавиша Caps Lock будет выполнять действие клавиши Ctrl
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,1d,00,3a,00,00,00,00,00
Клавиша Caps Lock будет выполнять действие клавиши Shift

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,2a,00,3a,00,00,00,00,00
Отключает Caps Lock и переназначает действие клавиши Scroll Lock на выполнение Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,3A,00,46,00,00,00,00,00
Отключает клавишу Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,00,00,00,00
Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=-

5. Удаление просроченных элементов в области уведомления панели задач.

1. Запустите редактор реестра: Win+R --> regedit
2. Перейдите в следующий раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify
3. Удалите параметры "IconStreams" и "PastIconsStream"
4. Запустите диспетчер задач Ctrl+Shift+Esc
5. Остановите процесс explorer.exe
6. File --> New Task (Run...) --> explorer --> ОК.
7. Установите необходимые параметры отображения области уведомления панели задач.

6. Удаление папок из Рабочего стола в Проводнике.

Если вы хотите, удалить папки из Рабочего стола в Проводнике.

Вариант 1

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
3) Пройдите к ветке реестра "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace"
4) Сделайте себе её экспорт, на случай восстановления(ПКМ на данной ветке-Экспортировать).
5) Удалите следующие ветки:
Favorites(Избранное)             = {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки)            = {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа)       = {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Папки)    = {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер)              = {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть)                    = {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) = {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина)             = {645FF040-5081-101B-9F08-00AA002F954E}

Вариант 2

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
Для удаления Favorites(Избранное), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a9400100
Для восстановления Favorites(Избранное) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a0900100
Для удаления Libraries(Библиотеки), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b090010d
Для восстановления Libraries(Библиотеки) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b080010d
Для удаления Homegroup(Домашняя группа), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Homegroup(Домашняя группа) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Computer(Компьютер), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Computer(Компьютер) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Network(Сеть), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0940064
Для восстановления Network(Сеть) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0040064
Для удаления Recycle Bin(Корзина), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:70,01,00,20
Для восстановления Recycle Bin(Корзина) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:40,01,00,20

7. Очистка устаревших значков из диалога выбора значков и уведомлений.

После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify]
"PastIconsStream"=-
"IconStreams"=-
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Скачать готовый reg-файл Вы можете по ссылке: Clean_TrayNotify.zip

8. Очистка истории расположений фонов рабочего стола в Windows 7.

В окне настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев Рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

1. Фоны рабочего стола Windows;
2. Библиотека изображений;
3. Самые популярные фотографии;
4. Сплошные цвета.

Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

Твики Реестра - Восстановление

1. Принудительное включение Windows Aero (только для Standard Administrator).

1) Нажмите Win+R и введите regedit
2) Установите следующие значения в регистре:
HKCU\Software\Microsoft\Windows\DWM\Composition равный 1 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy равынй 2 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\ColorizationOpaqueBlend равный 1 (32-bit DWORD)
Готовый reg-файл enableaero.reg
3) Перезапустите DWM из command prompt, запущенного с правами администратора:
net stop UxSms
net start UxSms

2. Как исправить высокий пинг в Windows 7?

1. Пуск - Выполнить - regedit
2. Ищем там HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
3. Ищем там интерфейс по которому у вас работает интернет, если не в курсе то делаем следующий шаг во всех
4. Правой кнопкой в поле справа, там создать строчку DWORD, называем ее TcpAckFrequency потом правой кнопкой на ней, изменить, ставим шестнадцатиричную галочку, и пишем значение 1
5. Идем в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
Если такого пункта в реестре нет, а его скорее всего нет, то делаем следующие шаги:
Открываем - Пуск- Панель управления - Программы и Компоненты-(слева)Включение и отключение компонентов Windows.
Там находим пункт - Сервер очереди сообщений Майкрософт (MSMQ), и ставим галочку напротив него и все галочки внутри в выпадающем списке компонентов. Перегружаемся, идем в реестр и видим там нужную нам запись.

6. В месте указанном в пункте 5 ищем TCPNoDelay, если нету создаем DWORD параметр с таким названием. значение 1.

3. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"
Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

Необходимо восстановить через реестр значение по умолчанию "JSFile" .

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.JS]
@="JSFile"

4. Решение проблемы, когда вместо русских букв возникают ???? (реестр).
1) Замените в реестре в ветке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage С "1252"="c_1252.nls" на "1252"="c_1251.nls"
2) В папке \WINDOWS\system32\ найдите файлы С_1251 и С_1252. С_1251 куда-нибудь копируем и переименовываем в С_1252.
3) Оригинальный С_1252 переименовываем или удаляем (потребуется изменить права доступа). Возвращаем новую версию 1252 на место. В итоге файл С_1252, должен быть переименованной копией С_1251
4) Пуск-Панель управления-Язык и региональные установки-Дополнительно. Выбрать в пункте Текущий язык программ не поддерживающий Юникод: Русский (Россия)
5) Перезагружаемся.

5. Гаджеты или их настройки отказываются запускаться.

Для нормального функционирования гаджетов не отключайте UAC системы полностью. Выставьте минимальный уровень.
В случае если вы хотите восстановить работоспособность гаджетов при отключенном UAC, понимая уязвимость такого решения, вы можете применить твик реестра, указанный ниже. После перезагрузки гаджеты будут работать.
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings"
"AllowElevatedProcess"=dword:00000001

6. Восстановление пункта "Закрепить программу в панели задач".

Если у вас пропал пункт "Закрепить программу в панели задач":
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
"IsShortCut"=""
"IsNotShortCut"=-

7. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

Удаление кэша эскизов может понадобиться при возникновении проблем с их отображением. После удаления кэша эскизов они вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов, таким образом пересоздастся кэш и возможно удастся решить проблему с отображением некоторых эскизов.
Для очистки кэша эскизов сделайте следующее.

1) Нажмите комбинацию клавишь WinKey+R, в поле Открыть напишите cleanmgr и нажмите OK
2) Выберите диск C: и после оценки объема отметьте "Эскизы" и нажмите OK
3) В папке %USERPROFILE%\AppData\Local\ стереть файл IconCache.db

Еще можно попробовать увеличить размер этого кеша, создав в реестре в ключе [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer] новый параметр Max Cached Icons типа строки (REG_SZ) и занеся в него 4096 (а если такой параметр уже был, увеличить его вдвое).

8. Пользовательские папки отображаются обычными иконками.

Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
IconResource=%SystemRoot%\system32\imageres.dll,-112
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-235
Изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21779
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\imageres.dll,-113
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-236
[LocalizedFileNames]
Sample Pictures.lnk=@%SystemRoot%\system32\shell32.dll,-21805
Музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21790
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\imageres.dll,-108
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-237
[LocalizedFileNames]
Sample Music.lnk=@%SystemRoot%\system32\shell32.dll,-21806
Видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21791
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\imageres.dll,-189
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-238
[LocalizedFileNames]
Sample Videos.lnk=@%SystemRoot%\system32\shell32.dll,-21807
Поиски
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-9031
IconResource=%SystemRoot%\system32\imageres.dll,-18
[LocalizedFileNames]
Indexed Locations.search-ms=@shell32.dll,-32811
Everywhere.search-ms=@shell32.dll,-32814
Shared By Me.search-ms=@shell32.dll,-32802
Recent Music.search-ms=@shell32.dll,-32803
Recent Documents.search-ms=@shell32.dll,-32804
Recent Pictures and Videos.search-ms=@shell32.dll,-32806
Recent E-mail.search-ms=@shell32.dll,-32807
Recently Changed.search-ms=@shell32.dll,-3281
Загрузка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21798
IconResource=%SystemRoot%\system32\imageres.dll,-184
Избранное
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21796
IconResource=%SystemRoot%\system32\imageres.dll,-115
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-173
Контакты
[.ShellClassInfo]
LocalizedResourceName=@%CommonProgramFiles%\system\wab32res.dll,-10100
InfoTip=@%CommonProgramFiles%\system\wab32res.dll,-10200
IconResource=%SystemRoot%\system32\imageres.dll,-181
Рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183
Ссылки
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21810
IconResource=%SystemRoot%\system32\imageres.dll,-185
DefaultDropEffect=4
[LocalizedFileNames]
Public.lnk=@shell32.dll,-21816
Searches.lnk=@shell32.dll,-9031
Recently Changed.lnk=@shell32.dll,-32813
Music.lnk=@shell32.dll,-21790
Pictures.lnk=@shell32.dll,-21779
Documents.lnk=@shell32.dll,-21770
Сохраненные игры
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21814
IconResource=%SystemRoot%\system32\imageres.dll,-186
Общий рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21799
Общие документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21801
IconResource=%SystemRoot%\system32\shell32.dll,-235
Общая музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21803
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\shell32.dll,-237
Общие изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21802
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\shell32.dll,-236
Общее видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21804
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\shell32.dll,-238

9. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

Internet Explorer не удается загрузить / из help
Не удается открыть этот узел Интернета. Узел не доступен или не найден. Повторите попытку позднее.

Это может происходить по причине неправильного сопоставления программам типа файлов .xml
Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.xml]
@="xmlfile"
"Content Type"="text/xml"
"PerceivedType"="text"

[HKEY_CLASSES_ROOT\.xml\OpenWithList]

[HKEY_CLASSES_ROOT\.xml\OpenWithList\winword.exe]
@=""

[HKEY_CLASSES_ROOT\.xml\PersistentHandler]
@="{7E9D8D44-6926-426F-AA2B-217A819A5CCE}"


Твики Реестра

Твики Реестра - Добавление

1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@="\"%1\" /X:\"%1_unpacked\""
В итоге, при распаковке WindowsXP-KB922582-x86-RUS.exe, на выходе получаем папку WindowsXP-KB922582-x86-RUS.exe_unpacked с извлечёнными файлами. Минус один - команда Unpack HotFix встраивается в контекстное меню всех екзешников, а не только файлов от MS.

Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix]
[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@=-

Готовые reg-файлы Вы можете скачать по ссылке: Unpack_HotFix.zip

2. Как задать полный доступ к файлу или папке?

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"

3. Автоматическое VPN подключение к интернет при запуске Windows (реестр).

1. Создайте ваше VPN подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
2. В реестре Windows (Пуск->Выполнить->"regedit") найдите следующую ветку:
"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск только для текущего пользователя) или
"HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск для всех пользователей)
В этой ветке создайте "строковый параметр" (правой кнопкой мыши -> «Создать» -> «строковый параметр») с произвольным именем.
2. В качестве значения созданного параметра внесите строку вида:
rasdial "имя_вашего соединения" <логин> <пароль> (Например: rasdial "VPN connection" nz15vl 1234)
3. Закройте реестр и перезагрузите компьютер.

4. Добавляем пункт "Открыть в блокноте" в контекстное меню файлов.

Для того, чтобы добавить в контекстное меню файлов пункт "Открыть в Блокноте" текст кода сохраните в текстовый файл, присвойте ему расширение *.reg, запустите и согласитесь с добавлением данных в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте]
@=""

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте\command]
@="notepad.exe %1"

5. Как добавить дополнительные функции в папку Компьютер?

Администрирование

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{D20EA4E1-3957-11d2-A40B-0C5020524153}]

Корзина

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{645FF040-5081-101B-9F08-00AA002F954E}]

Панель управления

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\Controls]
@="{21EC2020-3AEA-1069-A2DD-08002B30309D}"

Принтеры и факсы

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{2227A280-3AEA-1069-A2DE-08002B30309D}]

Учетные записи пользователей

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{7A9D77BD-5403-11d2-8785-2E0420524153}]
В итоге получаем:

6. Добавляем произвольную команду в контекстное меню рабочего стола.

Для этого создаем файл fix.txt
Открываем блокнот и копируем туда это содержимое, сохраняем и меняем разширение на .reg
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name]
@="Свойства папки"
"Icon"="imageres.dll,200"
"Position"="Top"

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name\command]
@="control folders"
Сохраняем файл и выполняем его.
В параметре "Icon"="imageres.dll,200" цифра 200 отвечает за номер иконки. Вы можете указать свою.
Таким образом можно добавить практически любую команду (управление учетными записями Control userpasswords).

7. Конвертирование reg файлов в inf формат из контекстного меню, с помощью утилиты.
1) Скачиваете утилиту Reg2inf (необходим Framework 2 или 3)
2) Помешаете её в System32
3) Добавление в реестр добавляется следующее:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\command]
@="Reg2Inf.exe \"%1\" \"%1.inf\" /RepVars"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Application]
@="Reg2Inf"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Topic]
@="System"
В итоге, в контекстное меню reg файлов добавляется команда reg2inf и, к примеру, файл test.reg конвертируется в test.reg.inf

8. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".
Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB. С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\Shell]

[HKEY_CLASSES_ROOT\*\Shell\astext]
@="Как текст..."

[HKEY_CLASSES_ROOT\*\Shell\astext\command]
@="notepad.exe \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\Expand]
@="Распаковать .cab"

[HKEY_CLASSES_ROOT\*\Shell\Expand\command]
@="expand -r \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\MakeCab]
@="Запаковать в .cab"

[HKEY_CLASSES_ROOT\*\Shell\MakeCab\command]
@="makecab /D CompressionType=LZX /D CompressionMemory=21 \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\UpperCase]
@="Имя в ВЕРХНИЙ РЕГИСТР"

[HKEY_CLASSES_ROOT\*\Shell\UpperCase\command]
@="FILECASE /U \"%1\""

[HKEY_CLASSES_ROOT\Directory\shell\CabPack]
@="Запаковать папку в .cab"

[HKEY_CLASSES_ROOT\Directory\shell\CabPack\command]
@="cabs.cmd %L"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs]
@="Создать список файлов папки"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs\command]
@="dirs.cmd %L"

Назад на страницу раздела Твики Реестра.


1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@="\"%1\" /X:\"%1_unpacked\""
В итоге, при распаковке WindowsXP-KB922582-x86-RUS.exe, на выходе получаем папку WindowsXP-KB922582-x86-RUS.exe_unpacked с извлечёнными файлами. Минус один - команда Unpack HotFix встраивается в контекстное меню всех екзешников, а не только файлов от MS.

Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:
Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix]
[-HKEY_CLASSES_ROOT\exefile\shell\Unpack HotFix\command]
@=-
Готовые reg-файлы Вы можете скачать по ссылке: Unpack_HotFix.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


2. Как задать полный доступ к файлу или папке?

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant администраторы:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Стать владельцем и задать полный доступ к объекту"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant администраторы:F /t"

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


3. Автоматическое VPN подключение к интернет при запуске Windows (реестр).

1. Создайте ваше VPN подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
2. В реестре Windows (Пуск->Выполнить->"regedit") найдите следующую ветку:
"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск только для текущего пользователя) или
"HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run"

(если хотите сделать автозапуск для всех пользователей)
В этой ветке создайте "строковый параметр" (правой кнопкой мыши -> «Создать» -> «строковый параметр») с произвольным именем.
2. В качестве значения созданного параметра внесите строку вида:
rasdial "имя_вашего соединения" <логин> <пароль> (Например: rasdial "VPN connection" nz15vl 1234)
3. Закройте реестр и перезагрузите компьютер.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


4. Добавляем пункт "Открыть в блокноте" в контекстное меню файлов.

Для того, чтобы добавить в контекстное меню файлов пункт "Открыть в Блокноте" текст кода сохраните в текстовый файл, присвойте ему расширение *.reg, запустите и согласитесь с добавлением данных в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте]
@=""

[HKEY_CLASSES_ROOT\*\shell\Открыть в Блокноте\command]
@="notepad.exe %1"

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


5. Как добавить дополнительные функции в папку Компьютер?

Администрирование

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{D20EA4E1-3957-11d2-A40B-0C5020524153}]

Корзина

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{645FF040-5081-101B-9F08-00AA002F954E}]

Панель управления

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\Controls]
@="{21EC2020-3AEA-1069-A2DD-08002B30309D}"

Принтеры и факсы

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{2227A280-3AEA-1069-A2DE-08002B30309D}]

Учетные записи пользователей

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{7A9D77BD-5403-11d2-8785-2E0420524153}]
В итоге получаем:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


6. Добавляем произвольную команду в контекстное меню рабочего стола.

Для этого создаем файл fix.txt
Открываем блокнот и копируем туда это содержимое, сохраняем и меняем разширение на .reg
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name]
@="Свойства папки"
"Icon"="imageres.dll,200"
"Position"="Top"

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\name\command]
@="control folders"
Сохраняем файл и выполняем его.
В параметре "Icon"="imageres.dll,200" цифра 200 отвечает за номер иконки. Вы можете указать свою.
Таким образом можно добавить практически любую команду (управление учетными записями Control userpasswords).

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


7. Конвертирование reg файлов в inf формат из контекстного меню, с помощью утилиты.

1) Скачиваете утилиту Reg2inf (необходим Framework 2 или 3)
2) Помешаете её в System32
3) Добавление в реестр добавляется следующее:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\command]
@="Reg2Inf.exe \"%1\" \"%1.inf\" /RepVars"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Application]
@="Reg2Inf"

[HKEY_CLASSES_ROOT\regfile\shell\reg2inf\ddeexec\Topic]
@="System"
В итоге, в контекстное меню reg файлов добавляется команда reg2inf и, к примеру, файл test.reg конвертируется в test.reg.inf

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


8. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".

Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB. С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\Shell]

[HKEY_CLASSES_ROOT\*\Shell\astext]
@="Как текст..."

[HKEY_CLASSES_ROOT\*\Shell\astext\command]
@="notepad.exe \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\Expand]
@="Распаковать .cab"

[HKEY_CLASSES_ROOT\*\Shell\Expand\command]
@="expand -r \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\MakeCab]
@="Запаковать в .cab"

[HKEY_CLASSES_ROOT\*\Shell\MakeCab\command]
@="makecab /D CompressionType=LZX /D CompressionMemory=21 \"%1\""

[HKEY_CLASSES_ROOT\*\Shell\UpperCase]
@="Имя в ВЕРХНИЙ РЕГИСТР"

[HKEY_CLASSES_ROOT\*\Shell\UpperCase\command]
@="FILECASE /U \"%1\""

[HKEY_CLASSES_ROOT\Directory\shell\CabPack]
@="Запаковать папку в .cab"

[HKEY_CLASSES_ROOT\Directory\shell\CabPack\command]
@="cabs.cmd %L"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs]
@="Создать список файлов папки"

[HKEY_CLASSES_ROOT\Directory\shell\Dirs\command]
@="dirs.cmd %L"

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Добавление.


Твики Реестра

Твики Реестра - Изменение

1. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

1) Запустите меню Выполнить(Win+R) или командную строку от имени Администратора
2) Введите команду
unregmp2.exe /SwapTo:64
(команда чувствительна к регистру)
3) Откройте редактор реестра: Win+R --> regedit
4) Перейдите к ветке
HKLM\Software\Microsoft\Windows\CurrentVersion\App Paths\wmplayer.exe\
и кликните два раза по значению Path
5) Измените
"%ProgramFiles(x86)%\Windows Media Player"
на
"%ProgramFiles%\Windows Media Player"
6) Закройте реестр и наслаждайтесь Windows Media Player х64

Готовые bat-файлы Вы можете скачать по ссылке: Windows_Media_Player_x64.zip

2. Ускорение выключения компьютера.

Измените задержку перед выключением компьютера в реестре в разделе:
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WaitToKillServiceTimeout" - отвечает за задержку перед выключением.
По умолчанию установлено значение (20000)=20 сек., но вы можете установить его значение, намного меньше номинального (минимум 100), и система будет закрываться намного быстрее.
Рекомендуемые значения (2000-5000)=2-5 сек. (меньше не рекомендуется, иначе система будет понимать неадекватно отсутсвие откликов от служб, и завершать их в "неподходящий" момент времени, например когда они сохраняют свои последние настройки)

3. Отмена автозапуска у устройства (DVD диска, Flash диска и т.д.)

1) Пуск -> выполнить -> regedit
2) открыть ветку HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) В этом разделе создать ключ(Параметр DWORD) NoDriveTypeAutoRun

Допустимые значения ключа:

0x1 - отключить автозапуск на приводах неизвестных типов
0x4 - отключить автозапуск сьемных устройств
0x8 - отключить автозапуск НЕсьемных устройств
0x10 - отключить автозапуск сетевых дисков
0x20 - отключить автозапуск CD-приводов
0x40 - отключить автозапуск RAM-дисков
0x80 - отключить автозапуск на приводах неизвестных типов
0xFF - отключить автозапуск вообще всех дисков.

4. Смена фона в экране авторизации.

1) Создайте ключ типа DWORD с названием OEMBackground в ветке реестра
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background

2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
4) Поместите сюда свой файл
5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

background768x1280.jpg
background900x1440.jpg
background960x1280.jpg
background1024x1280.jpg
background1280x1024.jpg
background1024x768.jpg
background1280x960.jpg
background1600x1200.jpg
background1440x900.jpg
background1920x1200.jpg
background1280x768.jpg
background1360x768.jpg
backgroundDefault.jpg - в случае нестандартного расширения монитора

Размер изображений не должен превышать 256Кб.
Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

5. Ускорение анимации всплывающего меню в меню Пуск и появления окна предварительного просмотра в панели задач.

При наведении на значок приложения в панели задач окно предварительного просмотра появляется с задержкой.

1.Запускаем редактор реестра (Пуск –> Выполнить –> regedit)
2.Находим ключ HKEY_CURRENT_USER –> Control Panel –> Mouse
3.В этом ключе находим значение MouseHoverTime
Выбираем желательное время в миллисекундах, по прошествии которого после наведения указателя мыши будет показываться эскиз окна.
Чтобы случайно при проведении мыши, окно не выскочило, но при наведении целенаправленно, окно появилось практически мгновенно поставьте значения не меньше 50.
4. Находим ключ HKEY_CURRENT_USER\Control Panel\Desktop
5. В этом ключе находим значение MenuShowDelay
Выбираем желательное значение от 1 до 4000, означающее задержку в милисекундах, до показа всплывающего меню.
6. Закрываем regedit и перезагружаем систему.

6. Как продлевать срок начального льготного доактивационного периода?

Эта процедура не хакерская уловка и не требует никаких инструментов или утилит вообще и, более того, документирована Microsoft, на ее сайте Technet.
1. В запущенной Windows 7, которая не была еще активирована, щелкните кнопку Start, напечатайте regedit в строке Поиска, затем нажмите ENTER, чтобы запустить Редактор реестра.
2. Перейдите к ключу реестра:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform
3. Щёлкните правой кнопкой мыши на SkipRearm и выберите Edit. Установленное значение по умолчанию - Dword с значением 00000000.
Измените это значение на любое положительное целое число, например, 00000001, сохраните и закройте редактор реестра.
4. Запустите командную строку с правами администратора.
5. Напечатайте одну из следующих двух команд и нажмите ENTER:
slmgr -rearm или rundll32 slc.dll,SLReArmWindows
Эти команды используют встроенный в Windows 7 Менеджер лицензий (SLMGR), который по умолчанию дает 30 дней доактивационного периода.
Изменение ключа SkipRearm с 0 на 1 (с 00000000 на 00000001) позволяет менеджеру лицензий SLMGR проделывать процедуру сброса счетчика неограниченное количество раз!
Изменение значения ключа SkipRearm с 1 на 0 возвращает SLMGR к исходному состоянию. 6. Перезагрузите компьютер, чтобы изменения вступили в силу.

7. Переназначение гнезд звуковой карты Realtek используя реестр.
На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

1) Установите драйвера звуковой карты
2) Запустите редактор реестра (Win+К -> regedit -> Ok)
3) Пройдите к папке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\
4) Откройте папку Drv6013_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
5) Создайте двоичный параметр(Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

Рисунок 1 из 2

Имя(вставлять без кавычек):

"Pin01" = Заднее зеленое гнездо
"Pin02" = Заднее черное гнездо
"Pin03" = Заднее коричневое гнездо
"Pin04" = Заднее серое гнездо
"Pin05" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
"Pin07" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

"Pin06" = Переднее розовое гнездо
"Pin08" = Переднее зеленое гнездо

Значение(вставлять без кавычек):

"00 00 00 00" = Линейный вход
"01 00 00 00" = Микрофон
"02 00 00 00" = Наушники
"04 00 00 00" = Передние динамики
"05 00 00 00" = Тыловые динамики
"06 00 00 00" = Центральный канал/Сабвуфер
"07 00 00 00" = Боковые динамики

Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

Drv6013_DevType_0888_SS10438357 - на версию вашего драйвера
(имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
Pin04 - на любое значение из списка Имя
hex:02,00,00,00 - на любое значение из списка Значение(просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\Drv6013_DevType_0888_SS10438357]
"Pin04"=hex:02,00,00,00

Рисунок 2 из 2

8. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

1) Запустите редактор реестра (Нажмите Win+R, введите команду regedit.exe и нажмите Ок)
2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
3) Измените значение параметра MessageDuration.

9. Настройка диалога переключения между окнами ("Alt"+"Tab").

1) Запустите Редактор Реестра (Win+R -> Regedit -> Ok)
2) Откройте ветку реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если она отсутствует, то создайте её (щелкните на папке Explorer правой кнопкой мыши, выберите Создать -> Раздел и назовите её AltTab).
В данной папке создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD.

Для создания твика, воспользуйтесь инструкцией:

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Параметры, отвечающие за количество отображаемых столбцов и строк

Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"Columns"=dword:00000005
"Rows"=dword:00000003
Параметры, отвечающие за отступы в диалоге переключения между окнами

Упомянутые ниже параметры указываются в пикселях.

TopMarginPx - величина верхнего поля, добавляемого в диалог
SideMarginPx - величина бокового поля, добавляемого в диалог
BottomMarginPx - величина нижнего поля, добавляемого в диалог
MinWidthPx - минимальная возможная ширина диалога AltTab
ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"TopMarginPx"=dword:00000027
"SideMarginPx"=dword:00000005
"BottomMarginPx"=dword:00000003
"MinWidthPx"=dword:00000050
"ThumbSpacingXPx"=dword:00000006
"ThumbSpacingYPx"=dword:00000015
Параметры, отвечающие за значки эскизов окон

Упомянутые ниже параметры указываются в пикселях.

OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"OverlayIconDYPx"=dword:00000008
"OverlayIconDXPx"=dword:00000008
"OverlayIconPx"=dword:00000030
Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

Упомянутые ниже параметры указываются в пикселях.
MaxThumbSizePx - максимальный размер эскизов окон
MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
TextButtomPx - высота заголовка диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"MinThumbSizePcent"=dword:00000010
"MaxThumbSizePx"=dword:00000085
"TextButtomPx"=dword:00000010
Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

StartAlpha - начальная прозрачность диалога переключения между окнами
FinalAlpha - конечная прозрачность диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"FadeOut_ms"=dword:00000100
"FadeIn_ms"=dword:00000100
"StartAlpha"=dword:00000002
"FinalAlpha"=dword:00000004
Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt+Tab, создайте DWORD-параметр AltTabSettings в ветви реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

Назад на страницу раздела Твики Реестра.


1. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

1) Запустите меню Выполнить(Win+R) или командную строку от имени Администратора
2) Введите команду
unregmp2.exe /SwapTo:64
(команда чувствительна к регистру)
3) Откройте редактор реестра: Win+R --> regedit
4) Перейдите к ветке
HKLM\Software\Microsoft\Windows\CurrentVersion\App Paths\wmplayer.exe\
и кликните два раза по значению Path
5) Измените
"%ProgramFiles(x86)%\Windows Media Player"
на
"%ProgramFiles%\Windows Media Player"
6) Закройте реестр и наслаждайтесь Windows Media Player х64

Готовые bat-файлы Вы можете скачать по ссылке: Windows_Media_Player_x64.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


2. Ускорение выключения компьютера.

Измените задержку перед выключением компьютера в реестре в разделе:
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WaitToKillServiceTimeout" - отвечает за задержку перед выключением.
По умолчанию установлено значение (20000)=20 сек., но вы можете установить его значение, намного меньше номинального (минимум 100), и система будет закрываться намного быстрее.
Рекомендуемые значения (2000-5000)=2-5 сек. (меньше не рекомендуется, иначе система будет понимать неадекватно отсутсвие откликов от служб, и завершать их в "неподходящий" момент времени, например когда они сохраняют свои последние настройки)

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


3. Отмена автозапуска у устройства (DVD диска, Flash диска и т.д.)

1) Пуск -> выполнить -> regedit
2) открыть ветку HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) В этом разделе создать ключ(Параметр DWORD) NoDriveTypeAutoRun

Допустимые значения ключа:

0x1 - отключить автозапуск на приводах неизвестных типов
0x4 - отключить автозапуск сьемных устройств
0x8 - отключить автозапуск НЕсьемных устройств
0x10 - отключить автозапуск сетевых дисков
0x20 - отключить автозапуск CD-приводов
0x40 - отключить автозапуск RAM-дисков
0x80 - отключить автозапуск на приводах неизвестных типов
0xFF - отключить автозапуск вообще всех дисков.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


4. Смена фона в экране авторизации.

1) Создайте ключ типа DWORD с названием OEMBackground в ветке реестра
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background

2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
4) Поместите сюда свой файл
5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

background768x1280.jpg
background900x1440.jpg
background960x1280.jpg
background1024x1280.jpg
background1280x1024.jpg
background1024x768.jpg
background1280x960.jpg
background1600x1200.jpg
background1440x900.jpg
background1920x1200.jpg
background1280x768.jpg
background1360x768.jpg
backgroundDefault.jpg - в случае нестандартного расширения монитора

Размер изображений не должен превышать 256Кб.
Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


5. Ускорение анимации всплывающего меню в меню Пуск и появления окна предварительного просмотра в панели задач.

При наведении на значок приложения в панели задач окно предварительного просмотра появляется с задержкой.

1.Запускаем редактор реестра (Пуск –> Выполнить –> regedit)
2.Находим ключ HKEY_CURRENT_USER –> Control Panel –> Mouse
3.В этом ключе находим значение MouseHoverTime
Выбираем желательное время в миллисекундах, по прошествии которого после наведения указателя мыши будет показываться эскиз окна.
Чтобы случайно при проведении мыши, окно не выскочило, но при наведении целенаправленно, окно появилось практически мгновенно поставьте значения не меньше 50.
4. Находим ключ HKEY_CURRENT_USER\Control Panel\Desktop
5. В этом ключе находим значение MenuShowDelay
Выбираем желательное значение от 1 до 4000, означающее задержку в милисекундах, до показа всплывающего меню.
6. Закрываем regedit и перезагружаем систему.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


6. Как продлевать срок начального льготного доактивационного периода?

Эта процедура не хакерская уловка и не требует никаких инструментов или утилит вообще и, более того, документирована Microsoft, на ее сайте Technet.
1. В запущенной Windows 7, которая не была еще активирована, щелкните кнопку Start, напечатайте regedit в строке Поиска, затем нажмите ENTER, чтобы запустить Редактор реестра.
2. Перейдите к ключу реестра:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform
3. Щёлкните правой кнопкой мыши на SkipRearm и выберите Edit. Установленное значение по умолчанию - Dword с значением 00000000.
Измените это значение на любое положительное целое число, например, 00000001, сохраните и закройте редактор реестра.
4. Запустите командную строку с правами администратора.
5. Напечатайте одну из следующих двух команд и нажмите ENTER:
slmgr -rearm или rundll32 slc.dll,SLReArmWindows
Эти команды используют встроенный в Windows 7 Менеджер лицензий (SLMGR), который по умолчанию дает 30 дней доактивационного периода.
Изменение ключа SkipRearm с 0 на 1 (с 00000000 на 00000001) позволяет менеджеру лицензий SLMGR проделывать процедуру сброса счетчика неограниченное количество раз!
Изменение значения ключа SkipRearm с 1 на 0 возвращает SLMGR к исходному состоянию. 6. Перезагрузите компьютер, чтобы изменения вступили в силу.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


7. Переназначение гнезд звуковой карты Realtek используя реестр.

На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

1) Установите драйвера звуковой карты
2) Запустите редактор реестра (Win+К -> regedit -> Ok)
3) Пройдите к папке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\
4) Откройте папку Drv6013_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
5) Создайте двоичный параметр(Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

Имя(вставлять без кавычек):

"Pin01" = Заднее зеленое гнездо
"Pin02" = Заднее черное гнездо
"Pin03" = Заднее коричневое гнездо
"Pin04" = Заднее серое гнездо
"Pin05" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
"Pin07" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

"Pin06" = Переднее розовое гнездо
"Pin08" = Переднее зеленое гнездо

Значение(вставлять без кавычек):

"00 00 00 00" = Линейный вход
"01 00 00 00" = Микрофон
"02 00 00 00" = Наушники
"04 00 00 00" = Передние динамики
"05 00 00 00" = Тыловые динамики
"06 00 00 00" = Центральный канал/Сабвуфер
"07 00 00 00" = Боковые динамики

Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

Drv6013_DevType_0888_SS10438357 - на версию вашего драйвера
(имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
Pin04 - на любое значение из списка Имя
hex:02,00,00,00 - на любое значение из списка Значение(просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\Drv6013_DevType_0888_SS10438357]
"Pin04"=hex:02,00,00,00

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


8. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Запустите редактор реестра (Нажмите Win+R, введите команду regedit.exe и нажмите Ок)
2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
3) Измените значение параметра MessageDuration.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


9. Настройка диалога переключения между окнами ("Alt"+"Tab").

1) Запустите Редактор Реестра (Win+R -> Regedit -> Ok)
2) Откройте ветку реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если она отсутствует, то создайте её (щелкните на папке Explorer правой кнопкой мыши, выберите Создать -> Раздел и назовите её AltTab).
В данной папке создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Для создания твика, воспользуйтесь инструкцией:

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Параметры, отвечающие за количество отображаемых столбцов и строк

Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"Columns"=dword:00000005
"Rows"=dword:00000003
Параметры, отвечающие за отступы в диалоге переключения между окнами

Упомянутые ниже параметры указываются в пикселях.

TopMarginPx - величина верхнего поля, добавляемого в диалог
SideMarginPx - величина бокового поля, добавляемого в диалог
BottomMarginPx - величина нижнего поля, добавляемого в диалог
MinWidthPx - минимальная возможная ширина диалога AltTab
ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"TopMarginPx"=dword:00000027
"SideMarginPx"=dword:00000005
"BottomMarginPx"=dword:00000003
"MinWidthPx"=dword:00000050
"ThumbSpacingXPx"=dword:00000006
"ThumbSpacingYPx"=dword:00000015
Параметры, отвечающие за значки эскизов окон

Упомянутые ниже параметры указываются в пикселях.

OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"OverlayIconDYPx"=dword:00000008
"OverlayIconDXPx"=dword:00000008
"OverlayIconPx"=dword:00000030
Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

Упомянутые ниже параметры указываются в пикселях.
MaxThumbSizePx - максимальный размер эскизов окон
MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
TextButtomPx - высота заголовка диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"MinThumbSizePcent"=dword:00000010
"MaxThumbSizePx"=dword:00000085
"TextButtomPx"=dword:00000010
Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

StartAlpha - начальная прозрачность диалога переключения между окнами
FinalAlpha - конечная прозрачность диалога переключения между окнами

Пример твика реестра с использованием этих параметров:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab]
"FadeOut_ms"=dword:00000100
"FadeIn_ms"=dword:00000100
"StartAlpha"=dword:00000002
"FinalAlpha"=dword:00000004
Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt+Tab, создайте DWORD-параметр AltTabSettings в ветви реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Изменение.


Твики Реестра

Твики Реестра - Удаление

1. Как убрать цифру при пересоздании адаптера сети в Диспетчере устройств?

Вариант 1

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" установите значение адаптера сети на 0.
3) Создайте драйвер сетевого адаптера

Вариант 2

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" удалите ваш сетевой адаптер.
3) Создайте драйвер сетевого адаптера.

2. Как отключить проверку подписи для загруженных программ?

Избавляет от этого:

1) В Панель управления -> Свойства браузера-> вкладка Дополнительно -> снять галочку "Проверка подписи для загруженных программ" и поставить галочку "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
2) Создайте и примените reg-файл следующего содержания.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"DefaultFileTypeRisk"=dword:00006152

;Отключить предупреждение при открытии файлов, загруженных из Интернета
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments]
"HideZoneInfoOnProperties"=dword:00000001
"SaveZoneInformation"=dword:00000002

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000095

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"LowRiskFileTypes"=".zip;.rar;.nfo;.txt;.exe;.bat;.com;.cmd;.reg;.msi;.htm;.html;.gif;.bmp;.jpg;.avi;.mpg;.mpeg;.mov;.mp3;.m3u;.wav;"

3. Как удалить (вернуть) стрелки с ярлыков Windows?

Готовые файлы для убирания стрелок вы можете скачать по ссылке:
Shortcut_Arrows.rar
1) Распакуйте и откройте папку нужного вам варианта
2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat
3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat

Вариант 1

Для удаления стрелок с ярлыков:

1) Запустите диалоговое окно "Выполнить" (Win + R)
2) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %WINDIR%\system32\shell32.dll,50 /f
Для восстановления стрелок на ярлыках:
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f

Вариант 2

Для удаления стрелок с ярлыков:

1) Создайте пустой файл иконки назовите его Blank.ico
2) Скопируйте его в папку C:\Windows
3) Запустите диалоговое окно "Выполнить" (Win + R)
4) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %SystemRoot%\Blank.ico,0 /f
Для восстановления стрелок на ярлыках:

1) Удалите файл Blank.ico из папки C:\Windows
2) Запустите диалоговое окно "Выполнить" (Win + R)
3) Скопируйте код указанный ниже и нажмите OK
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f

4. Как отключить или переназначить клавишу Caps Lock?

Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра. Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

Клавиша Caps Lock будет выполнять действие клавиши Ctrl
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,1d,00,3a,00,00,00,00,00
Клавиша Caps Lock будет выполнять действие клавиши Shift

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,2a,00,3a,00,00,00,00,00
Отключает Caps Lock и переназначает действие клавиши Scroll Lock на выполнение Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,3A,00,46,00,00,00,00,00
Отключает клавишу Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,00,00,00,00
Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=-

5. Удаление просроченных элементов в области уведомления панели задач.

1. Запустите редактор реестра: Win+R --> regedit
2. Перейдите в следующий раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify
3. Удалите параметры "IconStreams" и "PastIconsStream"
4. Запустите диспетчер задач Ctrl+Shift+Esc
5. Остановите процесс explorer.exe
6. File --> New Task (Run...) --> explorer --> ОК.
7. Установите необходимые параметры отображения области уведомления панели задач.

6. Удаление папок из Рабочего стола в Проводнике.

Если вы хотите, удалить папки из Рабочего стола в Проводнике.

Вариант 1

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
3) Пройдите к ветке реестра "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace"
4) Сделайте себе её экспорт, на случай восстановления(ПКМ на данной ветке-Экспортировать).
5) Удалите следующие ветки:
Favorites(Избранное)             = {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки)            = {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа)       = {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Папки)    = {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер)              = {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть)                    = {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) = {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина)             = {645FF040-5081-101B-9F08-00AA002F954E}

Вариант 2

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
Для удаления Favorites(Избранное), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a9400100
Для восстановления Favorites(Избранное) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a0900100
Для удаления Libraries(Библиотеки), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b090010d
Для восстановления Libraries(Библиотеки) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b080010d
Для удаления Homegroup(Домашняя группа), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Homegroup(Домашняя группа) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Computer(Компьютер), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Computer(Компьютер) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Network(Сеть), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0940064
Для восстановления Network(Сеть) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0040064
Для удаления Recycle Bin(Корзина), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:70,01,00,20
Для восстановления Recycle Bin(Корзина) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:40,01,00,20

7. Очистка устаревших значков из диалога выбора значков и уведомлений.

После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify]
"PastIconsStream"=-
"IconStreams"=-
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Скачать готовый reg-файл Вы можете по ссылке: Clean_TrayNotify.zip

8. Очистка истории расположений фонов рабочего стола в Windows 7.

В окне настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев Рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

1. Фоны рабочего стола Windows;
2. Библиотека изображений;
3. Самые популярные фотографии;
4. Сплошные цвета.

Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

Назад на страницу раздела Твики Реестра.


1. Как убрать цифру при пересоздании адаптера сети в Диспетчере устройств?

Вариант 1

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" установите значение адаптера сети на 0.
3) Создайте драйвер сетевого адаптера

Вариант 2

1) Удалите драйвер сетевого адаптера
2) В ветке реестра "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions" удалите ваш сетевой адаптер.
3) Создайте драйвер сетевого адаптера.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


2. Как отключить проверку подписи для загруженных программ?

Избавляет от этого:

1) В Панель управления -> Свойства браузера-> вкладка Дополнительно -> снять галочку "Проверка подписи для загруженных программ" и поставить галочку "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
2) Создайте и примените reg-файл следующего содержания.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"DefaultFileTypeRisk"=dword:00006152

;Отключить предупреждение при открытии файлов, загруженных из Интернета
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments]
"HideZoneInfoOnProperties"=dword:00000001
"SaveZoneInformation"=dword:00000002

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000095

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"LowRiskFileTypes"=".zip;.rar;.nfo;.txt;.exe;.bat;.com;.cmd;.reg;.msi;.htm;.html;.gif;.bmp;.jpg;.avi;.mpg;.mpeg;.mov;.mp3;.m3u;.wav;"

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


3. Как удалить (вернуть) стрелки с ярлыков Windows?

Готовые файлы для убирания стрелок вы можете скачать по ссылке:
Shortcut_Arrows.rar
1) Распакуйте и откройте папку нужного вам варианта
2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat
3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat

Вариант 1

Для удаления стрелок с ярлыков:

1) Запустите диалоговое окно "Выполнить" (Win + R)
2) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %WINDIR%\system32\shell32.dll,50 /f
Для восстановления стрелок на ярлыках:
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f

Вариант 2

Для удаления стрелок с ярлыков:

1) Создайте пустой файл иконки назовите его Blank.ico
2) Скопируйте его в папку C:\Windows
3) Запустите диалоговое окно "Выполнить" (Win + R)
4) Скопируйте код указанный ниже и нажмите OK
REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /v 29 /d %SystemRoot%\Blank.ico,0 /f
Для восстановления стрелок на ярлыках:

1) Удалите файл Blank.ico из папки C:\Windows
2) Запустите диалоговое окно "Выполнить" (Win + R)
3) Скопируйте код указанный ниже и нажмите OK
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons" /f

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


4. Как отключить или переназначить клавишу Caps Lock?

Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра. Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

Клавиша Caps Lock будет выполнять действие клавиши Ctrl
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,1d,00,3a,00,00,00,00,00
Клавиша Caps Lock будет выполнять действие клавиши Shift

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,2a,00,3a,00,00,00,00,00
Отключает Caps Lock и переназначает действие клавиши Scroll Lock на выполнение Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,3A,00,46,00,00,00,00,00
Отключает клавишу Caps Lock
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,3a,00,00,00,00,00
Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=-

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


5. Удаление просроченных элементов в области уведомления панели задач.

1. Запустите редактор реестра: Win+R --> regedit
2. Перейдите в следующий раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify
3. Удалите параметры "IconStreams" и "PastIconsStream"
4. Запустите диспетчер задач Ctrl+Shift+Esc
5. Остановите процесс explorer.exe
6. File --> New Task (Run...) --> explorer --> ОК.
7. Установите необходимые параметры отображения области уведомления панели задач.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


6. Удаление папок из Рабочего стола в Проводнике.

Если вы хотите, удалить папки из Рабочего стола в Проводнике.

Вариант 1

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
3) Пройдите к ветке реестра "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace"
4) Сделайте себе её экспорт, на случай восстановления(ПКМ на данной ветке-Экспортировать).
5) Удалите следующие ветки:
Favorites(Избранное)             = {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки)            = {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа)       = {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Папки)    = {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер)              = {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть)                    = {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) = {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина)             = {645FF040-5081-101B-9F08-00AA002F954E}

Вариант 2

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
Для удаления Favorites(Избранное), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a9400100
Для восстановления Favorites(Избранное) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder]
"Attributes"=dword:a0900100
Для удаления Libraries(Библиотеки), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b090010d
Для восстановления Libraries(Библиотеки) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder]
"Attributes"=dword:b080010d
Для удаления Homegroup(Домашняя группа), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Homegroup(Домашняя группа) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Computer(Компьютер), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b094010c
Для восстановления Computer(Компьютер) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder]
"Attributes"=dword:b084010c
Для удаления Network(Сеть), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0940064
Для восстановления Network(Сеть) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder]
"Attributes"=dword:b0040064
Для удаления Recycle Bin(Корзина), измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:70,01,00,20
Для восстановления Recycle Bin(Корзина) по умолчанию, измените значение реестра на:
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:40,01,00,20

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


7. Очистка устаревших значков из диалога выбора значков и уведомлений.

После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify]
"PastIconsStream"=-
"IconStreams"=-
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Скачать готовый reg-файл Вы можете по ссылке: Clean_TrayNotify.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


8. Очистка истории расположений фонов рабочего стола в Windows 7.

В окне настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев Рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

1. Фоны рабочего стола Windows;
2. Библиотека изображений;
3. Самые популярные фотографии;
4. Сплошные цвета.

Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Удаление.


Твики Реестра

Твики Реестра - Восстановление

1. Принудительное включение Windows Aero (только для Standard Administrator).

1) Нажмите Win+R и введите regedit
2) Установите следующие значения в регистре:
HKCU\Software\Microsoft\Windows\DWM\Composition равный 1 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy равынй 2 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\ColorizationOpaqueBlend равный 1 (32-bit DWORD)
Готовый reg-файл enableaero.reg
3) Перезапустите DWM из command prompt, запущенного с правами администратора:
net stop UxSms
net start UxSms

2. Как исправить высокий пинг в Windows 7?

1. Пуск - Выполнить - regedit
2. Ищем там HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
3. Ищем там интерфейс по которому у вас работает интернет, если не в курсе то делаем следующий шаг во всех
4. Правой кнопкой в поле справа, там создать строчку DWORD, называем ее TcpAckFrequency потом правой кнопкой на ней, изменить, ставим шестнадцатиричную галочку, и пишем значение 1
5. Идем в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
Если такого пункта в реестре нет, а его скорее всего нет, то делаем следующие шаги:
Открываем - Пуск- Панель управления - Программы и Компоненты-(слева)Включение и отключение компонентов Windows.
Там находим пункт - Сервер очереди сообщений Майкрософт (MSMQ), и ставим галочку напротив него и все галочки внутри в выпадающем списке компонентов. Перегружаемся, идем в реестр и видим там нужную нам запись.

6. В месте указанном в пункте 5 ищем TCPNoDelay, если нету создаем DWORD параметр с таким названием. значение 1.

3. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"
Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

Необходимо восстановить через реестр значение по умолчанию "JSFile" .

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.JS]
@="JSFile"

4. Решение проблемы, когда вместо русских букв возникают ???? (реестр).
1) Замените в реестре в ветке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage С "1252"="c_1252.nls" на "1252"="c_1251.nls"
2) В папке \WINDOWS\system32\ найдите файлы С_1251 и С_1252. С_1251 куда-нибудь копируем и переименовываем в С_1252.
3) Оригинальный С_1252 переименовываем или удаляем (потребуется изменить права доступа). Возвращаем новую версию 1252 на место. В итоге файл С_1252, должен быть переименованной копией С_1251
4) Пуск-Панель управления-Язык и региональные установки-Дополнительно. Выбрать в пункте Текущий язык программ не поддерживающий Юникод: Русский (Россия)
5) Перезагружаемся.

5. Гаджеты или их настройки отказываются запускаться.

Для нормального функционирования гаджетов не отключайте UAC системы полностью. Выставьте минимальный уровень.
В случае если вы хотите восстановить работоспособность гаджетов при отключенном UAC, понимая уязвимость такого решения, вы можете применить твик реестра, указанный ниже. После перезагрузки гаджеты будут работать.
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings"
"AllowElevatedProcess"=dword:00000001

6. Восстановление пункта "Закрепить программу в панели задач".

Если у вас пропал пункт "Закрепить программу в панели задач":
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
"IsShortCut"=""
"IsNotShortCut"=-

7. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

Удаление кэша эскизов может понадобиться при возникновении проблем с их отображением. После удаления кэша эскизов они вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов, таким образом пересоздастся кэш и возможно удастся решить проблему с отображением некоторых эскизов.
Для очистки кэша эскизов сделайте следующее.

1) Нажмите комбинацию клавишь WinKey+R, в поле Открыть напишите cleanmgr и нажмите OK
2) Выберите диск C: и после оценки объема отметьте "Эскизы" и нажмите OK
3) В папке %USERPROFILE%\AppData\Local\ стереть файл IconCache.db

Еще можно попробовать увеличить размер этого кеша, создав в реестре в ключе [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer] новый параметр Max Cached Icons типа строки (REG_SZ) и занеся в него 4096 (а если такой параметр уже был, увеличить его вдвое).

8. Пользовательские папки отображаются обычными иконками.

Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
IconResource=%SystemRoot%\system32\imageres.dll,-112
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-235
Изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21779
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\imageres.dll,-113
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-236
[LocalizedFileNames]
Sample Pictures.lnk=@%SystemRoot%\system32\shell32.dll,-21805
Музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21790
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\imageres.dll,-108
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-237
[LocalizedFileNames]
Sample Music.lnk=@%SystemRoot%\system32\shell32.dll,-21806
Видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21791
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\imageres.dll,-189
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-238
[LocalizedFileNames]
Sample Videos.lnk=@%SystemRoot%\system32\shell32.dll,-21807
Поиски
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-9031
IconResource=%SystemRoot%\system32\imageres.dll,-18
[LocalizedFileNames]
Indexed Locations.search-ms=@shell32.dll,-32811
Everywhere.search-ms=@shell32.dll,-32814
Shared By Me.search-ms=@shell32.dll,-32802
Recent Music.search-ms=@shell32.dll,-32803
Recent Documents.search-ms=@shell32.dll,-32804
Recent Pictures and Videos.search-ms=@shell32.dll,-32806
Recent E-mail.search-ms=@shell32.dll,-32807
Recently Changed.search-ms=@shell32.dll,-3281
Загрузка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21798
IconResource=%SystemRoot%\system32\imageres.dll,-184
Избранное
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21796
IconResource=%SystemRoot%\system32\imageres.dll,-115
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-173
Контакты
[.ShellClassInfo]
LocalizedResourceName=@%CommonProgramFiles%\system\wab32res.dll,-10100
InfoTip=@%CommonProgramFiles%\system\wab32res.dll,-10200
IconResource=%SystemRoot%\system32\imageres.dll,-181
Рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183
Ссылки
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21810
IconResource=%SystemRoot%\system32\imageres.dll,-185
DefaultDropEffect=4
[LocalizedFileNames]
Public.lnk=@shell32.dll,-21816
Searches.lnk=@shell32.dll,-9031
Recently Changed.lnk=@shell32.dll,-32813
Music.lnk=@shell32.dll,-21790
Pictures.lnk=@shell32.dll,-21779
Documents.lnk=@shell32.dll,-21770
Сохраненные игры
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21814
IconResource=%SystemRoot%\system32\imageres.dll,-186
Общий рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21799
Общие документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21801
IconResource=%SystemRoot%\system32\shell32.dll,-235
Общая музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21803
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\shell32.dll,-237
Общие изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21802
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\shell32.dll,-236
Общее видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21804
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\shell32.dll,-238

9. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

Internet Explorer не удается загрузить / из help
Не удается открыть этот узел Интернета. Узел не доступен или не найден. Повторите попытку позднее.

Это может происходить по причине неправильного сопоставления программам типа файлов .xml
Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.xml]
@="xmlfile"
"Content Type"="text/xml"
"PerceivedType"="text"

[HKEY_CLASSES_ROOT\.xml\OpenWithList]

[HKEY_CLASSES_ROOT\.xml\OpenWithList\winword.exe]
@=""

[HKEY_CLASSES_ROOT\.xml\PersistentHandler]
@="{7E9D8D44-6926-426F-AA2B-217A819A5CCE}"

Назад на страницу раздела Твики Реестра.


1. Принудительное включение Windows Aero (только для Standard Administrator).

1) Нажмите Win+R и введите regedit
2) Установите следующие значения в регистре:
HKCU\Software\Microsoft\Windows\DWM\Composition равный 1 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy равынй 2 (32-bit DWORD)
HKCU\Software\Microsoft\Windows\DWM\ColorizationOpaqueBlend равный 1 (32-bit DWORD)
Готовый reg-файл enableaero.reg
3) Перезапустите "Диспетчер сеансов диспетчера окон рабочего стола" из command prompt, запущенного с правами администратора:
net stop UxSms
net start UxSms

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Восстановление.


2. Как исправить высокий пинг в Windows 7?

1. Пуск - Выполнить - regedit
2. Ищем там HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
3. Ищем там интерфейс по которому у вас работает интернет, если не в курсе то делаем следующий шаг во всех
4. Правой кнопкой в поле справа, там создать строчку DWORD, называем ее TcpAckFrequency потом правой кнопкой на ней, изменить, ставим шестнадцатиричную галочку, и пишем значение 1
5. Идем в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
Если такого пункта в реестре нет, а его скорее всего нет, то делаем следующие шаги:
Открываем - Пуск- Панель управления - Программы и Компоненты-(слева)Включение и отключение компонентов Windows.
Там находим пункт - Сервер очереди сообщений Майкрософт (MSMQ), и ставим галочку напротив него и все галочки внутри в выпадающем списке компонентов. Перегружаемся, идем в реестр и видим там нужную нам запись.

6. В месте указанном в пункте 5 ищем TCPNoDelay, если нету создаем DWORD параметр с таким названием. значение 1.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Восстановление.


3. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"

Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

Необходимо восстановить через реестр значение по умолчанию "JSFile" .

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.JS]
@="JSFile"

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Восстановление.


4. Решение проблемы, когда вместо русских букв возникают ???? (реестр).

1) Замените в реестре в ветке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage С "1252"="c_1252.nls" на "1252"="c_1251.nls"
2) В папке \WINDOWS\system32\ найдите файлы С_1251 и С_1252. С_1251 куда-нибудь копируем и переименовываем в С_1252.
3) Оригинальный С_1252 переименовываем или удаляем (потребуется изменить права доступа). Возвращаем новую версию 1252 на место. В итоге файл С_1252, должен быть переименованной копией С_1251
4) Пуск-Панель управления-Язык и региональные установки-Дополнительно. Выбрать в пункте Текущий язык программ не поддерживающий Юникод: Русский (Россия)
5) Перезагружаемся.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Восстановление.


5. Гаджеты или их настройки отказываются запускаться.

Для нормального функционирования гаджетов не отключайте UAC системы полностью. Выставьте минимальный уровень.
В случае если вы хотите восстановить работоспособность гаджетов при отключенном UAC, понимая уязвимость такого решения, вы можете применить твик реестра, указанный ниже. После перезагрузки гаджеты будут работать.
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings"
"AllowElevatedProcess"=dword:00000001

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Восстановление.


6. Восстановление пункта "Закрепить программу в панели задач".

Если у вас пропал пункт "Закрепить программу в панели задач":
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\lnkfile]
"IsShortCut"=""
"IsNotShortCut"=-

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Восстановление.


7. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

Удаление кэша эскизов может понадобиться при возникновении проблем с их отображением. После удаления кэша эскизов они вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов, таким образом пересоздастся кэш и возможно удастся решить проблему с отображением некоторых эскизов.
Для очистки кэша эскизов сделайте следующее.

1) Нажмите комбинацию клавишь WinKey+R, в поле Открыть напишите cleanmgr и нажмите OK
2) Выберите диск C: и после оценки объема отметьте "Эскизы" и нажмите OK
3) В папке %USERPROFILE%\AppData\Local\ стереть файл IconCache.db

Еще можно попробовать увеличить размер этого кеша, создав в реестре в ключе [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer] новый параметр Max Cached Icons типа строки (REG_SZ) и занеся в него 4096 (а если такой параметр уже был, увеличить его вдвое).

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Восстановление.


8. Пользовательские папки отображаются обычными иконками.

Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
IconResource=%SystemRoot%\system32\imageres.dll,-112
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-235
Изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21779
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\imageres.dll,-113
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-236
[LocalizedFileNames]
Sample Pictures.lnk=@%SystemRoot%\system32\shell32.dll,-21805
Музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21790
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\imageres.dll,-108
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-237
[LocalizedFileNames]
Sample Music.lnk=@%SystemRoot%\system32\shell32.dll,-21806
Видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21791
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\imageres.dll,-189
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-238
[LocalizedFileNames]
Sample Videos.lnk=@%SystemRoot%\system32\shell32.dll,-21807
Поиски
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-9031
IconResource=%SystemRoot%\system32\imageres.dll,-18
[LocalizedFileNames]
Indexed Locations.search-ms=@shell32.dll,-32811
Everywhere.search-ms=@shell32.dll,-32814
Shared By Me.search-ms=@shell32.dll,-32802
Recent Music.search-ms=@shell32.dll,-32803
Recent Documents.search-ms=@shell32.dll,-32804
Recent Pictures and Videos.search-ms=@shell32.dll,-32806
Recent E-mail.search-ms=@shell32.dll,-32807
Recently Changed.search-ms=@shell32.dll,-3281
Загрузка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21798
IconResource=%SystemRoot%\system32\imageres.dll,-184
Избранное
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21796
IconResource=%SystemRoot%\system32\imageres.dll,-115
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-173
Контакты
[.ShellClassInfo]
LocalizedResourceName=@%CommonProgramFiles%\system\wab32res.dll,-10100
InfoTip=@%CommonProgramFiles%\system\wab32res.dll,-10200
IconResource=%SystemRoot%\system32\imageres.dll,-181
Рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183
Ссылки
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21810
IconResource=%SystemRoot%\system32\imageres.dll,-185
DefaultDropEffect=4
[LocalizedFileNames]
Public.lnk=@shell32.dll,-21816
Searches.lnk=@shell32.dll,-9031
Recently Changed.lnk=@shell32.dll,-32813
Music.lnk=@shell32.dll,-21790
Pictures.lnk=@shell32.dll,-21779
Documents.lnk=@shell32.dll,-21770
Сохраненные игры
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21814
IconResource=%SystemRoot%\system32\imageres.dll,-186
Общий рабочий стол
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21799
Общие документы
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21801
IconResource=%SystemRoot%\system32\shell32.dll,-235
Общая музыка
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21803
InfoTip=@%SystemRoot%\system32\shell32.dll,-12689
IconResource=%SystemRoot%\system32\shell32.dll,-237
Общие изображения
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21802
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\shell32.dll,-236
Общее видео
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21804
InfoTip=@%SystemRoot%\system32\shell32.dll,-12690
IconResource=%SystemRoot%\system32\shell32.dll,-238

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Восстановление.


9. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

Internet Explorer не удается загрузить / из help
Не удается открыть этот узел Интернета. Узел не доступен или не найден. Повторите попытку позднее.

Это может происходить по причине неправильного сопоставления программам типа файлов .xml
Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.xml]
@="xmlfile"
"Content Type"="text/xml"
"PerceivedType"="text"

[HKEY_CLASSES_ROOT\.xml\OpenWithList]

[HKEY_CLASSES_ROOT\.xml\OpenWithList\winword.exe]
@=""

[HKEY_CLASSES_ROOT\.xml\PersistentHandler]
@="{7E9D8D44-6926-426F-AA2B-217A819A5CCE}"

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Восстановление.


Устранение неполадок

1. Перестали запускаться анимированые обои. Ошибка:"Windows DreamScene can only run when Windows Aero scheme is selected."

Вероятно, аэро - отключено.
Щелкаете правой кнопкой на монитор - Персонализация - выберите тему с прозрачными окнами (они вверху). Или C:\Windows\Resources\Themes выбрать aero.

2. Решение проблемы с анимацией DWM (Desktop Window Manager).

1) Нажимаете "Пуск" на панели задач
2) Нажимаете правой кнопкой на Компьютер
3) Выбираете Свойства -> Дополнительные параметры системы
4) В открытом окне выбираете вкладку Дополнительно-Быстродействие-Параметры
5) На вкладке Визуальные эффекты, уберите галочку - Анимация окон при свертывании и развертывании.

3. Создаете панель быстрого запуска, но после перезагрузки она исчезает.

Возможная причина - отсутствие пароля учетной записи.

4. Если гаджет погоды пишет service unavailable for your region.

Для нормальной работы гаджетов не отключайте UAC полностью, а ставьте на минимум.
Если отключить UAC совсем (крайне нижнее положение - Never Notify), то гаджеты могут пропасть.
А панель настройки гаджетов может стать недоступной.

Вариант 1

Завершите процесс sidebar.exe и перезапустите его (правой кнопкой мыши на рабочем столе --> Gadgets)

Также добавьте в папке %WINDIR%\system32\driverc\etc в файл hosts следующие строки:
207.68.172.246 www.msnweather.com
198.78.215.126 blst.msn.com
65.55.228.63 weather.msn.com
65.55.17.39 weather.service.msn.com

Вариант 2

Если перезапуск не помогает, то вы можете поставить другой гаджет погоды, например: AccuWeather.com® Forecast Gadget

5. Решение проблемы, когда вместо русских букв возникают ????.

При новой установке с компакт-диска выводится окно, там три строчки.
В верхней - язык, на котором работает система (в нашем случае - английский US).
Вторая строчка - месторасположение компьютера - там куча стран - начиная от Афганистана и заканчивая Ямайкой. Там надо найти страну - RUSSIAN FEDERATION.
Третья строка - язык раскладки клавиатуры по умолчанию. При выборе во второй строке нашей страны (РФ), там автоматом ставится русский.

6. В Windows Update при попытке обновления появляется error 80072ee7.

Если во время проверки наличия обновлений Центр обновления Windows выдает сообщение об ошибке 80072ee7, возможно, следует изменить или удалить статические IP-адреса для службы Центра обновления Windows . Адреса хранятся в файле операционной системы Hosts.

IP-адрес для службы Центра обновления Windows может изменяться во время каждой проверки наличия обновлений, однако некоторые программы-надстройки Windows добавляют в файл Hosts статические адреса. Статический IP-адрес для службы Центра обновления Windows не позволит компьютеру получать обновления.

Удаление статического IP-адреса для веб-сайта службы Центра обновления Windows

1. Откройте компонент Компьютер. Для этого нажмите кнопку Пуск и выберите пункт Компьютер.
2. Дважды щелкните значок локального жесткого диска, на котором установлена система Windows (обычно диск С).
3. Дважды щелкните папку Windows, а затем - папку System32.
4. Дважды щелкните папку драйверы, а затем - папку и т. д..
5. В папке etc щелкните правой кнопкой мыши файл hosts и нажмите Открыть. После того как вам будет предложено выбрать программу, с помощью которой следует открывать данный файл, выберите Блокнот.
6. Проверьте, стоит ли в файле hosts знак # около всех записей IP-адресов и имен узлов Центра обновления Windows. Если это не так, вставьте значок # или удалите запись целиком.
7. Откройте меню Файл, выберите команду Сохранить и повторно выполните проверку наличия обновлений.

7. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.
На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
Скачать исправление KB977178 : для x86 или для x64

8. Как восстановить стандартный бутскрин Windows 7?

Вариант 1

Выполнить - C:\Windows\System32\sysprep\sysprep.exe выбрать OOBE и ОК. Не забываем о разрешении экрана (17" -1280*1024)

Вариант 2

1. Откройте меню Start и в поле для ввода наберите "cmd" (без кавычек). Щелкните правой кнопкой на найденном элементе и из выпавшего меню выберите Run As Administrator. При необходимости введите пароль.
2. В открытом окне консоли введите команду:

bcdedit /set {current} locale en-US
Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Выйдите из консоли, перезагрузите систему и вуаля - пред вами снова анимированный экран загрузки Windows 7.

9. При использовании сторонних плееров для видео выкидывает синий экран.

Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

10. Исправление сбоев в Проводнике и Windows Installer (msiexec.exe).

Вариант 1

Запустите командную строку от имени Администратора (Пуск->Все программы->Стандартные->Командная строка) и скопируйте следущую строчку:
reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\Disabled Sessions /va /f

Вариант 2

1) В меню Выполнить введите "gpedit.msc" перейдите по адресу:
Конфигурация компьютера->Административные шаблоны->Система->Управление связью через Интернет->Параметры связи через Интернет.
2) Щелкните на строчку "Отключить программу по улучшению качества программного обеспечения Windows"
3) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

11. Как восстановить стандартный бутскрин Windows 7?

В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, когда пользователь пытается внести различного рода изменения в загрузчик ОС.
Если вы столкнулись с этой проблемой, вот вам простое и действенное решение:
1. Откройте меню Start и в поле для ввода наберите "cmd" (без кавычек). Щелкните правой кнопкой на найденном элементе и из выпавшего меню выберите Run As Administrator. При необходимости введите пароль.
2. В открытом окне консоли введите команду:
bcdedit /set {current} locale en-US
Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Выйдите из консоли, перезагрузите систему и вуаля - пред вами снова анимированный экран загрузки Windows 7.

12. В Мой Компьютер не показывают DVD-дисководы.

Уберите галочку в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

13. Как получить полный доступ к NTFS-томам, системному реестру, параметрам настройки и драйверам в случае тотального повреждения существующей на диске ОС или для перезаписи исправлений к русификации поверх оригинальных файлов?

Для этой функции можно использовать программу Microsoft ERD Commander входящую в состав Microsoft Diagnostics and Recovery Toolset.
Вы можете создать свой загрузочный образ на основе имеющегося у вас дистрибутива или скачать готовый образ Microsoft ERD Commander.
Программа для создания своего образа, на основе дистрибутива Windows 7. Запускается только в Windows 7.

ERD Commander для x86 или x64

14. Решение проблемы с punkbuster на Windows 7.

Вариант 1

Решение проблемы вылетов игр (COD 5 и battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136). Лечится так:
1. обновляем punkbuster - качаем это запускаем и добавляем туда игру, pb которой нужно обновить и жмем check for updates. в конце появится сообщение об окончании.
2. находим на диске с windows два файла: PnkBstrA.exe и PnkBstrB.exe оба лежат в C:\Windows\SysWOW64 (для х64) и C:\Windows\System32 (для х86) (PnkBstrB.exe еще есть в папке с игрой C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb (думаю аналогично и в cod5). У этих файлов в свойствах выставить совместимость с XP и Vista.

Вариант 2

1. в %WINDIR%\system32\ файлам PnkBstrA.exe, PnkBstrB.exe поставить совместимость с Вистой и Права администратора.
2.На рабочем столе создать батник с следующим содержанием :
:start

sc config PnkBstrA type= own type= interact

sc config PnkBstrB type= own type= interact

timeout 60

goto start
3. Запускать батник перед запуском игр.
4. Играть

15. Моргание игр в режиме OpenGL.

Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

16. Восстановление пункта "Выполнить" в меню "Пуск".

Если у вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает вы можете восстановить его так:
1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
2) В левой части открывшегося окна пройти к вкладке:
Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

17. В Windows и Nero не стираются диски DVD RW и CD RW.

Если при попытке стереть данные диски вы получаете ответ "Не перезаписываемый диск" или "Диск защищён от записи". По всей видимости была сделана метка на диске и программы определяют его как DVD-R. Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис -> Настройки -> Эмуляция -> Игнорировать тип носителя, в Daemon Tools Спрятать CD-R.
Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.

18. Как убрать появляющуюся в меню "Пуск" полоску справа, которая пропадает при следующем открытии.

1) Переключаете язык интерфейса в английскую версию Windows: Панель управления->Язык и Региональные Стандарты->Языки и Клавиатуры->Язык интерфейса->выбираете английский
2) Перелогиниваетесь или перезапускаете комп
3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
5) Возвращаете язык интерфейса на русский
6) Радуетесь!
Для тех у кого изначально русская, выкладываю данный файлик отдельно для x64: aero.msstyles.mui и для x86: aero.msstyles.mui

19. Как восстановить ассоциацию с файлами *.cpl?

Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

1) Щелкаете ПКМ на любом файле *.cpl
2) Выбираете Свойства -> Приложение -> Изменить
3) Заходим в папку C:\Windows\System32 и выбираем там control.exe
4) Жмем Ок

20. Исправление вылета проводника при нажатии правой клавиши на файле.

Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
1) Скачайте небольшую утилиту ShellExView: с оффициального сайта или с зеркала.
2) После установки и запуска программы, найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
4) Перезагрузите компьютер.

21. Запись последовательности действий пользователя для анализа их разработчиком.

Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести имя файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

22. Восстановление исчезнувшей языковой панели.

Вариант 1

1) Идем в Панель управления - Язык и региональные стандарты
2) Смотрим скриншот и делаем все по пунктам

Рисунок 1 из 2

3) Жмем OK, OK
4) Щелкаем правой кнопкой на панели задач, выбираем Свойства.
5) В пункте Область уведомлений щелкаем кнопку Настроить

Рисунок 2 из 2

6) В открывшемся окне ставим галочку "Всегда показывать все значки и уведомления на панели задач" и нажимаем OK, OK

Вариант 2

Найдите файл ctfmon.exe и добавьте его в Атозагрузку или создайте reg-файл со следующим содержанием:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
"CTFMon"="C:\Windows\system32\ctfmon.exe"

23. Определение драйвера, вызвавшего BSOD.

Включение записи дампов памяти

1) Нажимаете комбинацию клавиш Win+Pause
2) Щелкаете ссылку Дополнительные параметры системы
3) Переходите на вкладку Дополнительно
4) Нажимаете кнопку Параметры в Загрузка и восстановление

Рисунок 1 из 2

5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

Рисунок 2 из 2

Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

Вариант 1

1) Загрузите и установите Debugging Tools for Windows.
2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
3) Распакуйте архив в любую папку.
Примечание: Если папка Debugging Tools for Windows находиться у вас не в папке Program Files, то в файле kdfe.cmd необходимо указать другой путь к папке, в которую установлены средства Debugging Tools for Windows.
Путь к папке указан после параметра set dbgpath=
4) Откройте командную строку и перейдите в папку, в которую вы распаковали kdfe.cmd.
5) Запустите файл, указав в качестве параметра путь к файлу дампа памяти (в примере ниже файл называется Mini1110307-01.dmp)
kdfe.cmd "%systemroot%\Minidump\Mini1110307-01.dmp"
6) Дождитесь завершениия анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

Вариант 2

1) Скачиваете утилиту BlueScreenView.
2) Устанавливаете BlueScreenView.
3) Распаковываете bluescreenview_russian.zip и кладете файл bluescreenview_lng.ini в туже папку куда установлена BlueScreenView.
4) Запускаете BlueScreenView.

Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options –> Advanced).
Для найденных дампов памяти утилита отображает:
  • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
  • В нижней панели – (в зависимости от настроек в Options –> Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы.

24. Расшифровка значений ошибок синего экрана смерти(BSOD) и способы их устранения.

Порой, получив какую-либо ошибку синего экрана смерти, вы задумываетесь из-за чего же она произошла. Для этого случая, скачайте подборку с разъяснениями значений часто встречающихся ошибок и способами устранения многих из них.
Скачать: BSOD.rar

25. В Windows x64 стало показывать меньше памяти, чем есть.

Зайдите:
Панель управления->Администрирование->Конфигурация системы>вкладка Загрузка->Дополнительные параметры
Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

Также посмотрите значение функций в биосе:

1. HPET Mode должно быть 64-bit (если есть такая функция)
или
2. Memory Remap Feature должно быть Enabled
3. Memory Hole должно быть Disabled


1. Перестали запускаться анимированые обои. Ошибка:"Windows DreamScene can only run when Windows Aero scheme is selected."

Вероятно, аэро - отключено.
Щелкаете правой кнопкой на монитор - Персонализация - выберите тему с прозрачными окнами (они вверху). Или C:\Windows\Resources\Themes выбрать aero

Назад на страницу раздела Устранение неполадок.


2. Решение проблемы с анимацией DWM (Desktop Window Manager).

1) Нажимаете "Пуск" на панели задач
2) Нажимаете правой кнопкой на Компьютер
3) Выбираете Свойства -> Дополнительные параметры системы
4) В открытом окне выбираете вкладку Дополнительно-Быстродействие-Параметры
5) На вкладке Визуальные эффекты, уберите галочку - Анимация окон при свертывании и развертывании.

Назад на страницу раздела Устранение неполадок.


3. Создаете панель быстрого запуска, но после перезагрузки она исчезает.

Возможная причина - отсутствие пароля учетной записи.

Назад на страницу раздела Устранение неполадок.


4. Если гаджет погоды пишет service unavailable for your region.

Для нормальной работы гаджетов не отключайте UAC полностью, а ставьте на минимум.
Если отключить UAC совсем (крайне нижнее положение - Never Notify), то гаджеты могут пропасть.
А панель настройки гаджетов может стать недоступной.

Вариант 1

Завершите процесс sidebar.exe и перезапустите его (правой кнопкой мыши на рабочем столе --> Gadgets)

Также добавьте в папке %WINDIR%\system32\driverc\etc в файл hosts следующие строки:
207.68.172.246 www.msnweather.com
198.78.215.126 blst.msn.com
65.55.228.63 weather.msn.com
65.55.17.39 weather.service.msn.com

Вариант 2

Если перезапуск не помогает, то вы можете поставить другой гаджет погоды, например: AccuWeather.com® Forecast Gadget

Назад на страницу раздела Устранение неполадок.


5. Решение проблемы, когда вместо русских букв возникают ????.

При новой установке с компакт-диска выводится окно, там три строчки.
В верхней - язык, на котором работает система (в нашем случае - английский US).
Вторая строчка - месторасположение компьютера - там куча стран - начиная от Афганистана и заканчивая Ямайкой. Там надо найти страну - RUSSIAN FEDERATION.
Третья строка - язык раскладки клавиатуры по умолчанию. При выборе во второй строке нашей страны (РФ), там автоматом ставится русский.

Назад на страницу раздела Устранение неполадок.


6. В Windows Update при попытке обновления появляется error 80072ee7.

Если во время проверки наличия обновлений Центр обновления Windows выдает сообщение об ошибке 80072ee7, возможно, следует изменить или удалить статические IP-адреса для службы Центра обновления Windows . Адреса хранятся в файле операционной системы Hosts.

IP-адрес для службы Центра обновления Windows может изменяться во время каждой проверки наличия обновлений, однако некоторые программы-надстройки Windows добавляют в файл Hosts статические адреса. Статический IP-адрес для службы Центра обновления Windows не позволит компьютеру получать обновления.

Удаление статического IP-адреса для веб-сайта службы Центра обновления Windows

1. Откройте компонент Компьютер. Для этого нажмите кнопку Пуск и выберите пункт Компьютер.
2. Дважды щелкните значок локального жесткого диска, на котором установлена система Windows (обычно диск С).
3. Дважды щелкните папку Windows, а затем - папку System32.
4. Дважды щелкните папку драйверы, а затем - папку и т. д..
5. В папке etc щелкните правой кнопкой мыши файл hosts и нажмите Открыть. После того как вам будет предложено выбрать программу, с помощью которой следует открывать данный файл, выберите Блокнот.
6. Проверьте, стоит ли в файле hosts знак # около всех записей IP-адресов и имен узлов Центра обновления Windows. Если это не так, вставьте значок # или удалите запись целиком.
7. Откройте меню Файл, выберите команду Сохранить и повторно выполните проверку наличия обновлений.

Назад на страницу раздела Устранение неполадок.


7. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.

На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
Скачать исправление KB977178 : для x86 или для x64

Назад на страницу раздела Устранение неполадок.


8. Как восстановить стандартный бутскрин Windows 7?

Вариант 1

Выполнить - C:\Windows\System32\sysprep\sysprep.exe выбрать OOBE и ОК. Не забываем о разрешении экрана (17" -1280*1024)

Вариант 2

1. Откройте меню Start и в поле для ввода наберите "cmd" (без кавычек). Щелкните правой кнопкой на найденном элементе и из выпавшего меню выберите Run As Administrator. При необходимости введите пароль.
2. В открытом окне консоли введите команду:

bcdedit /set {current} locale en-US
Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Выйдите из консоли, перезагрузите систему и вуаля - пред вами снова анимированный экран загрузки Windows 7.

Назад на страницу раздела Устранение неполадок.


9. При использовании сторонних плееров для видео выкидывает синий экран.

Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

Назад на страницу раздела Устранение неполадок.


10. Исправление сбоев в Explorer и Windows Installer (msiexec.exe).

10. Исправление сбоев в Проводнике и Windows Installer (msiexec.exe).

Вариант 1

Запустите командную строку от имени Администратора (Пуск->Все программы->Стандартные->Командная строка) и скопируйте следущую строчку:
reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\Disabled Sessions /va /f

Вариант 2

1) В меню Выполнить введите "gpedit.msc" перейдите по адресу:
Конфигурация компьютера->Административные шаблоны->Система->Управление связью через Интернет->Параметры связи через Интернет.
2) Щелкните на строчку "Отключить программу по улучшению качества программного обеспечения Windows"
3) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

Назад на страницу раздела Устранение неполадок.


11. Как восстановить стандартный бутскрин Windows 7?

В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, когда пользователь пытается внести различного рода изменения в загрузчик ОС.
Если вы столкнулись с этой проблемой, вот вам простое и действенное решение:
1. Откройте меню Start и в поле для ввода наберите "cmd" (без кавычек). Щелкните правой кнопкой на найденном элементе и из выпавшего меню выберите Run As Administrator. При необходимости введите пароль.
2. В открытом окне консоли введите команду:
bcdedit /set {current} locale en-US
Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Выйдите из консоли, перезагрузите систему и вуаля - пред вами снова анимированный экран загрузки Windows 7.

Назад на страницу раздела Устранение неполадок.


12. В Мой Компьютер не показывают DVD-дисководы.

Уберите галочку в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

Назад на страницу раздела Устранение неполадок.


13. Как получить полный доступ к NTFS-томам, системному реестру, параметрам настройки и драйверам...

13. Как получить полный доступ к NTFS-томам, системному реестру, параметрам настройки и драйверам в случае тотального повреждения существующей на диске ОС или для перезаписи исправлений к русификации поверх оригинальных файлов?

Для этой функции можно использовать программу Microsoft ERD Commander входящую в состав Microsoft Diagnostics and Recovery Toolset.
Вы можете создать свой загрузочный образ на основе имеющегося у вас дистрибутива или скачать готовый образ Microsoft ERD Commander.
Программа для создания своего образа, на основе дистрибутива Windows 7. Запускается только в Windows 7.

ERD Commander для x86 или x64

Назад на страницу раздела Устранение неполадок.


14. Решение проблемы с punkbuster на Windows 7.

Вариант 1

Решение проблемы вылетов игр (COD 5 и battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136). Лечится так:
1. обновляем punkbuster - качаем это запускаем и добавляем туда игру, pb которой нужно обновить и жмем check for updates. в конце появится сообщение об окончании.
2. находим на диске с windows два файла: PnkBstrA.exe и PnkBstrB.exe оба лежат в C:\Windows\SysWOW64 (для х64) и C:\Windows\System32 (для х86) (PnkBstrB.exe еще есть в папке с игрой C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb (думаю аналогично и в cod5). У этих файлов в свойствах выставить совместимость с XP и Vista.

Вариант 2

1. в %WINDIR%\system32\ файлам PnkBstrA.exe, PnkBstrB.exe поставить совместимость с Вистой и Права администратора.
2.На рабочем столе создать батник с следующим содержанием :

:start

sc config PnkBstrA type= own type= interact

sc config PnkBstrB type= own type= interact

timeout 60

goto start
3. Запускать батник перед запуском игр.
4. Играть

Назад на страницу раздела Устранение неполадок.


15. Моргание игр в режиме OpenGL.

Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

Назад на страницу раздела Устранение неполадок.


16. Восстановление пункта "Выполнить" в меню "Пуск".

Если у вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает вы можете восстановить его так:
1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
2) В левой части открывшегося окна пройти к вкладке:
Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

Назад на страницу раздела Устранение неполадок.


17. В Windows и Nero не стираются диски DVD RW и CD RW.

Если при попытке стереть данные диски вы получаете ответ "Не перезаписываемый диск" или "Диск защищён от записи". По всей видимости была сделана метка на диске и программы определяют его как DVD-R. Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис -> Настройки -> Эмуляция -> Игнорировать тип носителя, в Daemon Tools Спрятать CD-R.
Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.

Назад на страницу раздела Устранение неполадок.


18. Как убрать появляющуюся в меню "Пуск" полоску справа, которая пропадает при следующем открытии.

1) Переключаете язык интерфейса в английскую версию Windows: Панель управления->Язык и Региональные Стандарты->Языки и Клавиатуры->Язык интерфейса->выбираете английский
2) Перелогиниваетесь или перезапускаете комп
3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
5) Возвращаете язык интерфейса на русский
6) Радуетесь!
Для тех у кого изначально русская, выкладываю данный файлик отдельно для x64: aero.msstyles.mui и для x86: aero.msstyles.mui

Назад на страницу раздела Устранение неполадок.


19. Как восстановить ассоциацию с файлами *.cpl?

Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

1) Щелкаете ПКМ на любом файле *.cpl
2) Выбираете Свойства -> Приложение -> Изменить
3) Заходим в папку C:\Windows\System32 и выбираем там control.exe
4) Жмем Ок

Назад на страницу раздела Устранение неполадок.


20. Исправление вылета проводника при нажатии правой клавиши на файле.

Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
1) Скачайте небольшую утилиту ShellExView: с оффициального сайта или с зеркала.
2) После установки и запуска программы, найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
4) Перезагрузите компьютер.

Назад на страницу раздела Устранение неполадок.


21. Запись последовательности действий пользователя для анализа их разработчиком.

Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести имя файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

Назад на страницу раздела Устранение неполадок.


22. Восстановление исчезнувшей языковой панели.

Вариант 1

1) Идем в Панель управления - Язык и региональные стандарты
2) Смотрим скриншот и делаем все по пунктам

3) Жмем OK, OK
4) Щелкаем правой кнопкой на панели задач, выбираем Свойства.
5) В пункте Область уведомлений щелкаем кнопку Настроить

6) В открывшемся окне ставим галочку "Всегда показывать все значки и уведомления на панели задач" и нажимаем OK, OK

Вариант 2

Найдите файл ctfmon.exe и добавьте его в Атозагрузку или создайте reg-файл со следующим содержанием:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
"CTFMon"="C:\Windows\system32\ctfmon.exe"

Назад на страницу раздела Устранение неполадок.


23. Определение драйвера, вызвавшего BSOD.

Включение записи дампов памяти

1) Нажимаете комбинацию клавиш Win+Pause
2) Щелкаете ссылку Дополнительные параметры системы
3) Переходите на вкладку Дополнительно
4) Нажимаете кнопку Параметры в Загрузка и восстановление

5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

Вариант 1

1) Загрузите и установите Debugging Tools for Windows.
2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
3) Распакуйте архив в любую папку.
Примечание: Если папка Debugging Tools for Windows находиться у вас не в папке Program Files, то в файле kdfe.cmd необходимо указать другой путь к папке, в которую установлены средства Debugging Tools for Windows.
Путь к папке указан после параметра set dbgpath=
4) Откройте командную строку и перейдите в папку, в которую вы распаковали kdfe.cmd.
5) Запустите файл, указав в качестве параметра путь к файлу дампа памяти (в примере ниже файл называется Mini1110307-01.dmp)
kdfe.cmd "%systemroot%\Minidump\Mini1110307-01.dmp"
6) Дождитесь завершениия анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

Вариант 2

1) Скачиваете утилиту BlueScreenView.
2) Устанавливаете BlueScreenView.
3) Распаковываете bluescreenview_russian.zip и кладете файл bluescreenview_lng.ini в туже папку куда установлена BlueScreenView.
4) Запускаете BlueScreenView.

Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options –> Advanced).
Для найденных дампов памяти утилита отображает:
  • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
  • В нижней панели – (в зависимости от настроек в Options –> Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы.

Назад на страницу раздела Устранение неполадок.


24. Расшифровка значений ошибок синего экрана смерти(BSOD) и способы их устранения.

Порой, получив какую-либо ошибку синего экрана смерти, вы задумываетесь из-за чего же она произошла. Для этого случая, скачайте подборку с разъяснениями значений часто встречающихся ошибок и способами устранения многих из них.
Скачать: BSOD.rar

Назад на страницу раздела Устранение неполадок.


25. В Windows x64 стало показывать меньше памяти, чем есть.

Зайдите:
Панель управления->Администрирование->Конфигурация системы>вкладка Загрузка->Дополнительные параметры
Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

Также посмотрите значение функций в биосе:

1. HPET Mode должно быть 64-bit (если есть такая функция)
или
2. Memory Remap Feature должно быть Enabled
3. Memory Hole должно быть Disabled

Назад на страницу раздела Устранение неполадок.


Разное

1. Где можно скачать последнюю версию DirectX?

Оффициальный сайт для скачивания последних версий DirectX находится по ссылке ниже:

Оффициальный сайт DirectX

2. Как открыть файлы с расширением .hlp?

Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe. Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
Оффициальная ссылка: здесь

3. Как свернуть все неактивные окна, кроме текущего активного, при помощи функции Aero Shake?

В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

4. Список клавиатурных сокращений.
Основные:

Win+Up - Развернуть окно
Win+Down - Восстановить / Минимизировать окно
Win+Left - Прикрепить окно к левому краю экрана
Win+Right - Прикрепить окно к правому краю экрана
Win+Shift+Left - Переключиться на левый монитор
Win+Shift+Right - Переключиться на правый монитор
Win+Home - Минимизировать / Восстановить все неактивные окна
Win+M - Минимизировать все окна
Win+Т - Выбрать первый элемент в панели задач (Повторное нажатие переключает на следующий элемент, Win+Shift+T - прокручивает в обратном порядке)
Win+Space - Показать рабочий стол
Win+B - Переход в область уведомлений(трей)
Win+G - Отобразить гаджеты поверх всех окон
Win+P - Отобразить дополнительные опции дисплея (расширить рабочий стол на 2 монитор и т.п.)
Win+X - Запустить Mobility Center
Win+ цифра- Запустить приложение с панели задач (Win+1 запускает первое приложения слева, Win+2, второе, и т.к.)
Win + "+" - Увеличить масштаб
Win + "-" - Уменьшить масштаб
Ctrl + колесо мыши (вверх\вниз) на рабочем столе - увеличить\уменьшить иконки рабочего стола.

Windows Explorer:
Alt+P - Показать / Скрыть Область предпросмотра

Панель задач:
Shift + щелчок на иконке - Открыть новое окно приложения
Ctrl + Shift + щелчок по иконке - Открыть новое окно приложения с привилегиями администратора
Shift + щелчок правой кнопкой на иконке - Показать меню приложения
Shift + щелчок правой кнопкой на группе иконок - Показать меню, восстановить все / cвернуть все / Закрыть все
Ctrl + щелчок по группе икнонок - Развернуть все окна группы

5. Включение Aero Glass в Windows на VirtualPC.
1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
5. Установить Сетевое соединение между двумя компьютерами.

На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
Жмите Connect и вводите логин.

Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

Грубо говоря, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

6. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

1) Закройте *.chm файл
2) Зайдите в Internet Explorer
3) Нажмите правую кнопку мыши
4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
5) Запустите ваш *.chm и система сама определит кодировку.

7. Автоматическое переключение русской и английской раскладок клавиатуры.
Часто бывает, что напечатав какой-то текст, вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".
Для того чтобы сохранить ваше терпение и нервы, существуют две замечательные программы: Punto Switcher(если вы в основном работаете с русской или английской клавиатурой) и Key Switcher(если вы работаете с несколькими европейскими языками).

Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером. Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

8. Удаление Windows 7 без форматирования раздела и без потери данных.
Для удаления Windows 7 описанным здесь способом вам потребуются:

а) ERD Commander;
б) Установочный диск Windows 7;

Шаг I. Удаление загрузочной информации Windows 7.

1) Загрузитесь в ERD Commader и вставьте установочный диск Windows 7 в свой DVD-привод.
2) Запустите Command Prompt
3) В открывшемся окне введите команду
E:\boot\bootsect.exe /nt60 ALL C: /force
Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

Шаг II. Удаление файлов и папок Windows 7.

1) Запустите Micosoft Diagnostics and Recovery Toolset -> Explorer
2) Как в обычном Explorer, тем же способом удалите следующие папки:
  • PerfLogs
  • Users
  • Windows
  • Recycle.Bin
  • Documents and Settings
  • ProgramData
  • Recovery

9. Создание образа и использование ERD Commander (необходим для получения полного доступа к файлам и папкам).

Скачиваете и устанавливаете сборщик образа ERD Commander для x86 или x64
Запускаете Пуск -> Все программы -> Microsoft Diagnostics and Recovery Toolset -> Мастер создания загрузочных носителей ERD Commander

По инструкции ниже создаете свой образ ERD Commander:

1) Монтируете образ дистрибутива Windows 7 в виртуальный дисковод
2) На вкладке Выбор образа загрузки указываете наш смонтированный виртуальный диск Windows 7

Рисунок 1 из 3

3) Щелкаете Ок, затем несколько раз кнопку Далее
4) На вкладке Выбор программных средств снова нажимаете Далее
5) В Мастер анализа сбоев выбираете Найти средства отладки для Windows в восстанавливаемой системе ...

Рисунок 2 из 3

6) На вкладке Загрузка определения автономного средства проверки системы Далее выбираете Нет, загрузить определения вручную позднее, затем Далее
7) На вкладке Дополнительные драйверы добавьте драйвера в образ, если необходимо, затем Далее
8) На вкладке Дополнительные файлы добавьте файлы в образ, если необходимо, затем Далее
9) На вкладке Создание образа загрузки укажите куда сохранить готовый образ ISO.
10) Оставляете галочку на пункте Записать готовый образ с помощью следующего устройства записи компакт-дисков, вставляете чистый диск в дисковод или убираете галочку с данного пункта, для дальнейшей записи на флэшку и нажимаете Далее.

Рисунок 3 из 3

На флэшку образ записывается через программу UltraISO так:
1) Открывате образ в UltraISO.
2) Выбираете Самозагрузка -> Записать образ жесткого диска...
3) Нажимаете Записать)

11) Перезагружаемся в ERD Commander.
12) Would you like to initialize network connectivity in the background?
Если собираетесь восстанавливать настройки сети (Интернет или Локальной) выбираете Yes жмете Enter, если не собираетесь, то выбираете No и жмете Enter
13) Would you like to remap the drive letters to match the mappings from the target operating system?
Для сопоставления букв дисков целевой операционной системе выбираете выбираете Yes и жмете Enter, в противоположном случае выбираете No и жмете Enter
14) Select a keyboard input method
Выбираете нужную раскладку, нажимаете Next
15) В окне для выбора операционной системы:

Для работы с восстановительными программами Windows, выбирате пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. И выбираете вашу операционную систему.

Для работы с системными файлами и папками(удаление, переименование или их замена) не выбираете никакую систему(должно сняться выделение с какой-либо системы). Для этого выберите пункт: Restore your computer using a system image that you created earlier, а затем снова выберите пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. и выделение само снимется.
16) Нажимаете Next.

10. Активация Windows 7 по телефону.

1) Пуск - правой кнопкой мыши по Компьютер - Свойства.
2) Изменить ключ продукта
3) Вводим ключ: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX .
4) Жмем Активировать.
5) Ждем. Затем выбираем Другие способы активации - Активация по телефону. Выбираете свой регион.
6) Звоним по бесплатному номеру (можно через Скайп) .
7) Девушка робот начнет перечислять варианты активации.
8) Жмем 1(активировать продукт майкрософт).
9) На вопрос на скольких компьютерах установлен продукт, нажимаем 1.
10) Затем вас попросят ввести код. Вводите, в ответ другая девушка-робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
11) Вносим цифры в окно активации.
12) Жмем Далее. Интернет, может быть отключен (без разницы). Windows 7 активирована.

11. Как быстро переключиться с одного монитора на другой или с монитора на проектор?
Данное действие осуществляется нажатием клавиш Win+P. Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей. Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

12. Как быстро открыть ещё одну копию приложения?
Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добиться кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

13. Как разместить любое окно Windows поверх других?

При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl+F12 и окно становится OnTop по отношению ко всем открытым.

14. Автоматическая очистка временных папок при выходе из Windows.

Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

1) Создайте командный файл сценария:

Инструкция:

1. Скопируйте код в любой текстовый редактор (например, Блокнот).
2. Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd
3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
PUSHD %TEMP% 2>Nul RD /S/Q "%TEMP%" POPD PUSHD %WinDir%\TEMP 2>Nul RD /S/Q "%WinDir%\TEMP" POPD
2) Скопируйте его для удобства в корневую папку диска С:
3) Запустите редактор групповых политик: Пуск -> Выполнить -> gpedit.msc или Win+R -> gpedit.msc
4) Откройте ветвь Конфигурация пользователя > Конфигурация Windows > Сценарии (вход/выход из системы).
5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами коммандного файла c:\tempdirclean.cmd
7) Нажмите Ок, затем снова Ок
Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

Внимание: Если по указанной выше схеме Вы добавите коммандный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера > Конфигурация Windows > Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

15. Блокирование прямого соединения с серверами проверки активации Windows.

Как бы Вы не пытались активировать Windows, если в активатор не встроено блокирование соединений с серверами проверки активации, то при появлении соединения с интернетом, Ваша Windows будет постоянно соединяться с данными серверами. При этом она передает сведения о вашей системе, об активации и используемом ключе.
Для блокировки соединения, выполните следующее в фаерволле: закройте порт 443 и адрес mpa.one.microsoft.com (IP=131.107.115.40).

Затем в файл hosts, находящийся в папке C:\Windows\System32\drivers\etc\ копируете указанные строчки:

127.0.0.1 mpa.microsoft.com
127.0.0.1 sls.microsoft.com
127.0.0.1 genuine.microsoft.com

Учитывая, что Microsoft знает о возможном блокировании её серверов проверки активации пользователями, то данное решение не защитит Вас от проверок активаций встроенных в обновления для Windows, но может продлить действие активации Вашей системы, если Вы не устанавливаете обновления.
Естественно, ничего этого не нужно делать, если у Вас честно купленная лицензия. Данное решение также позволит Вам высвободить интернет-траффик, если Вы активировали или планируете активировать Windows по телефону.


1. Где можно скачать последнюю версию DirectX?

Оффициальный сайт для скачивания последних версий DirectX находится по ссылке ниже:

Оффициальный сайт DirectX

Назад на страницу раздела Разное.


2. Как открыть файлы с расширением .hlp?

Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe. Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
Оффициальная ссылка: здесь

Назад на страницу раздела Разное.


3. Как свернуть все неактивные окна, кроме текущего активного, при помощи функции Aero Shake?

В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

Назад на страницу раздела Разное.


4. Список клавиатурных сокращений.

Основные:

Win+Up - Развернуть окно
Win+Down - Восстановить / Минимизировать окно
Win+Left - Прикрепить окно к левому краю экрана
Win+Right - Прикрепить окно к правому краю экрана
Win+Shift+Left - Переключиться на левый монитор
Win+Shift+Right - Переключиться на правый монитор
Win+Home - Минимизировать / Восстановить все неактивные окна
Win+M - Минимизировать все окна
Win+Т - Выбрать первый элемент в панели задач (Повторное нажатие переключает на следующий элемент, Win+Shift+T - прокручивает в обратном порядке)
Win+Space - Показать рабочий стол
Win+B - Переход в область уведомлений(трей)
Win+G - Отобразить гаджеты поверх всех окон
Win+P - Отобразить дополнительные опции дисплея (расширить рабочий стол на 2 монитор и т.п.)
Win+X - Запустить Mobility Center
Win+ цифра- Запустить приложение с панели задач (Win+1 запускает первое приложения слева, Win+2, второе, и т.к.)
Win + "+" - Увеличить масштаб
Win + "-" - Уменьшить масштаб
Ctrl + колесо мыши (вверх\вниз) на рабочем столе - увеличить\уменьшить иконки рабочего стола.

Windows Explorer:
Alt+P - Показать / Скрыть Область предпросмотра

Панель задач:
Shift + щелчок на иконке - Открыть новое окно приложения
Ctrl + Shift + щелчок по иконке - Открыть новое окно приложения с привилегиями администратора
Shift + щелчок правой кнопкой на иконке - Показать меню приложения
Shift + щелчок правой кнопкой на группе иконок - Показать меню, восстановить все / cвернуть все / Закрыть все
Ctrl + щелчок по группе икнонок - Развернуть все окна группы

Назад на страницу раздела Разное.


5. Включение Aero Glass в Windows на VirtualPC.

1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
5. Установить Сетевое соединение между двумя компьютерами.

На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
Жмите Connect и вводите логин.

Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

Грубо говоря, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

Назад на страницу раздела Разное.


6. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

1) Закройте *.chm файл
2) Зайдите в Internet Explorer
3) Нажмите правую кнопку мыши
4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
5) Запустите ваш *.chm и система сама определит кодировку.

Назад на страницу раздела Разное.


7. Автоматическое переключение русской и английской раскладок клавиатуры.

Часто бывает, что напечатав какой-то текст, вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".
Для того чтобы сохранить ваше терпение и нервы, существуют две замечательные программы: Punto Switcher(если вы в основном работаете с русской или английской клавиатурой) и Key Switcher(если вы работаете с несколькими европейскими языками).

Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером. Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

Назад на страницу раздела Разное.


8. Удаление Windows 7 без форматирования раздела и без потери данных.

Для удаления Windows 7 описанным здесь способом вам потребуются:

а) ERD Commander;
б) Установочный диск Windows 7;

Шаг I. Удаление загрузочной информации Windows 7.

1) Загрузитесь в ERD Commader и вставьте установочный диск Windows 7 в свой DVD-привод.
2) Запустите Command Prompt
3) В открывшемся окне введите команду
E:\boot\bootsect.exe /nt60 ALL C: /force
Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

Шаг II. Удаление файлов и папок Windows 7.

1) Запустите Micosoft Diagnostics and Recovery Toolset -> Explorer
2) Как в обычном Explorer, тем же способом удалите следующие папки:
  • PerfLogs
  • Users
  • Windows
  • Recycle.Bin
  • Documents and Settings
  • ProgramData
  • Recovery

Назад на страницу раздела Разное.


9. Создание образа и использование ERD Commander (необходим для получения полного доступа к файлам и папкам).

Скачиваете и устанавливаете сборщик образа ERD Commander для x86 или x64
Запускаете Пуск -> Все программы -> Microsoft Diagnostics and Recovery Toolset -> Мастер создания загрузочных носителей ERD Commander

По инструкции ниже создаете свой образ ERD Commander:

1) Монтируете образ дистрибутива Windows 7 в виртуальный дисковод
2) На вкладке Выбор образа загрузки указываете наш смонтированный виртуальный диск Windows 7

3) Щелкаете Ок, затем несколько раз кнопку Далее
4) На вкладке Выбор программных средств снова нажимаете Далее
5) В Мастер анализа сбоев выбираете Найти средства отладки для Windows в восстанавливаемой системе ...

6) На вкладке Загрузка определения автономного средства проверки системы Далее выбираете Нет, загрузить определения вручную позднее, затем Далее
7) На вкладке Дополнительные драйверы добавьте драйвера в образ, если необходимо, затем Далее
8) На вкладке Дополнительные файлы добавьте файлы в образ, если необходимо, затем Далее
9) На вкладке Создание образа загрузки укажите куда сохранить готовый образ ISO.
10) Оставляете галочку на пункте Записать готовый образ с помощью следующего устройства записи компакт-дисков, вставляете чистый диск в дисковод или убираете галочку с данного пункта, для дальнейшей записи на флэшку и нажимаете Далее.

На флэшку образ записывается через программу UltraISO так:
1) Открывате образ в UltraISO.
2) Выбираете Самозагрузка -> Записать образ жесткого диска...
3) Нажимаете Записать)

11) Перезагружаемся в ERD Commander.
12) Would you like to initialize network connectivity in the background?
Если собираетесь восстанавливать настройки сети (Интернет или Локальной) выбираете Yes жмете Enter, если не собираетесь, то выбираете No и жмете Enter
13) Would you like to remap the drive letters to match the mappings from the target operating system?
Для сопоставления букв дисков целевой операционной системе выбираете выбираете Yes и жмете Enter, в противоположном случае выбираете No и жмете Enter
14) Select a keyboard input method
Выбираете нужную раскладку, нажимаете Next
15) В окне для выбора операционной системы:

Для работы с восстановительными программами Windows, выбирате пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. И выбираете вашу операционную систему.

Для работы с системными файлами и папками(удаление, переименование или их замена) не выбираете никакую систему(должно сняться выделение с какой-либо системы). Для этого выберите пункт: Restore your computer using a system image that you created earlier, а затем снова выберите пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. и выделение само снимется.
16) Нажимаете Next.

Назад на страницу раздела Разное.


10. Активация Windows 7 по телефону.

1) Пуск - правой кнопкой мыши по Компьютер - Свойства.
2) Изменить ключ продукта
3) Вводим ключ: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX .
4) Жмем Активировать.
5) Ждем. Затем выбираем Другие способы активации - Активация по телефону. Выбираете свой регион.
6) Звоним по бесплатному номеру (можно через Скайп) .
7) Девушка робот начнет перечислять варианты активации.
8) Жмем 1(активировать продукт майкрософт).
9) На вопрос на скольких компьютерах установлен продукт, нажимаем 1.
10) Затем вас попросят ввести код. Вводите, в ответ другая девушка-робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
11) Вносим цифры в окно активации.
12) Жмем Далее. Интернет, может быть отключен (без разницы). Windows 7 активирована.

Назад на страницу раздела Разное.


11. Как быстро переключиться с одного монитора на другой или с монитора на проектор?

Данное действие осуществляется нажатием клавиш Win+P. Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей. Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

Назад на страницу раздела Разное.


12. Как быстро открыть ещё одну копию приложения?

Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добиться кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

Назад на страницу раздела Разное.


13. Как разместить любое окно Windows поверх других?

При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl+F12 и окно становится OnTop по отношению ко всем открытым.

Назад на страницу раздела Разное.


14. Автоматическая очистка временных папок при выходе из Windows.

Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

1) Создайте командный файл сценария:

Инструкция:

1. Скопируйте код в любой текстовый редактор (например, Блокнот).
2. Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd
3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
PUSHD %TEMP% 2>Nul RD /S/Q "%TEMP%" POPD PUSHD %WinDir%\TEMP 2>Nul RD /S/Q "%WinDir%\TEMP" POPD
2) Скопируйте его для удобства в корневую папку диска С:
3) Запустите редактор групповых политик: Пуск -> Выполнить -> gpedit.msc или Win+R -> gpedit.msc
4) Откройте ветвь Конфигурация пользователя > Конфигурация Windows > Сценарии (вход/выход из системы).
5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами коммандного файла c:\tempdirclean.cmd
7) Нажмите Ок, затем снова Ок
Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

Внимание: Если по указанной выше схеме Вы добавите коммандный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера > Конфигурация Windows > Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

Назад на страницу раздела Разное.


15. Блокирование прямого соединения с серверами проверки активации Windows.

Как бы Вы не пытались активировать Windows, если в активатор не встроено блокирование соединений с серверами проверки активации, то при появлении соединения с интернетом, Ваша Windows будет постоянно соединяться с данными серверами. При этом она передает сведения о вашей системе, об активации и используемом ключе.
Для блокировки соединения, выполните следующее в фаерволле: закройте порт 443 и адрес mpa.one.microsoft.com (IP=131.107.115.40).

Затем в файл hosts, находящийся в папке C:\Windows\System32\drivers\etc\ копируете указанные строчки:

127.0.0.1 mpa.microsoft.com
127.0.0.1 sls.microsoft.com
127.0.0.1 genuine.microsoft.com

Учитывая, что Microsoft знает о возможном блокировании её серверов проверки активации пользователями, то данное решение не защитит Вас от проверок активаций встроенных в обновления для Windows, но может продлить действие активации Вашей системы, если Вы не устанавливаете обновления.
Естественно, ничего этого не нужно делать, если у Вас честно купленная лицензия. Данное решение также позволит Вам высвободить интернет-траффик, если Вы активировали или планируете активировать Windows по телефону.

Назад на страницу раздела Разное.


История версий

Изменения в версии 1.49.

Переработан индекс сборника, что позволяет осуществить более точный поиск, через вкладку Указатель или вкладку Поиск
Исправлены грамматические, орфографические и синтаксические ошибки
Обновлены несколько советов
Добавлено 9 советов

Изменения в версии 1.40.

Добавлен новый раздел Твики Реестра с подразделами, в связи, с чем переработана структура сборника
Многие советы заменены или обновлены
Исправлена ошибка, при которой внешние ссылки указанные на отдельных страницах некоторых советов, открывались в самой справке. Теперь они открываются в новом окне интернет броузера.
Добавлен 1 совет

Изменения в версии 1.39.

Исправлены грамматические, орфографические и синтаксические ошибки
Добавлен 1 совет

Изменения в версии 1.38.

Обновлены ссылки на версии программ.
Исправлена ссылка на изображение в одном из советов
Добавлен 1 совет

Изменения в версии 1.37.8.

Исправлены грамматические, орфографические и синтаксические ошибки
Исправлены ссылки на некоторые страницы и изображения
Добавлен 1 совет

Изменения в версии 1.37.

Исправлены ошибки распознавания кодировки на некоторых страницах
Многие советы заменены или обновлены
Если в совете более одного изображения, то они сгруппированны в галерею
Добавлено 8 советов

Изменения в версии 1.29.

Добавлена функция превью для изображений(увеличение по клику) в общем списке и в страницах разделов
Добавлена История версий
Добавлено 4 совета

Изменения в версии 1.25.1.-1.25.3.

Исправлены грамматические и синтаксические ошибки

Изменения в версии 1.25.

Исправлены грамматические и синтаксические ошибки
Заменены некоторые ссылки
Добавлен 1 совет

Изменения в версии 1.24.

Переписан исходный код страниц
Улучшена (упрощена) навигация в сборнике
Советы сгруппированы по темам (разделам)
Спойлерам добавлен эффект слайда
Спойлеры оставлены только в общем списке и в списках разделов
Убраны спойлеры в отдельных страницах для каждого совета
Добавлены меняющиеся надписи на кнопках.
Исправлены старые и добавлены новые советы (14 штук)

Изменения в версии 1.10.

Исправлена невозможность выделения в общем списке после 49 совета
Исправлена невозможность выделения в 49 совете
Заменены ссылки на оригинальные скрипты
Добавлено принудительное определение кодировки как windows-1251
Добавлено 2 новых совета

Версия 1.08.

Первая версия